X
點擊此處開啟此網站的行動版。

技術支援討論區

Getting "According to WHOIS information..." pop up constantly

已張貼

With a recent update I started getting these pop up messages when I visit a website that say "According to WHOIS information this domain was registered on..." They appear to be associated with the "show site information" icon in the address bar. Can be very annoying as I am just visiting sites and having to constantly dismiss them. Is there some way to eliminate this?

With a recent update I started getting these pop up messages when I visit a website that say "According to WHOIS information this domain was registered on..." They appear to be associated with the "show site information" icon in the address bar. Can be very annoying as I am just visiting sites and having to constantly dismiss them. Is there some way to eliminate this?

被選擇的解決方法

I disabled two plug ins I had from the Mozilla Pioneer project - One was called Firefox Pioneer; the other, Pioneer Online News Study. The problem went a way. Today I looked back and in my add-ons the Firefox Pioneer plug in was there, disabled as expected but the 'Online News Study' had disappeared. Not sure how that happens but perhaps this was an invalid add-on. Anyway, the problem seems to have gone a way so far.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 29.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0

更多資訊

Shadow110 1072 個解決方法 14836 個答案

Hi, sounds like a add-on maybe or a unwanted program installed when installed something else. Firefox it self does not show Whois Info. Only when you click the Information Icon should you get information or if have Push Notifications on would you get info, but not Whois Info.

Please check your add-ons and look for any programs that you did not install. Please do a scan with https://www.malwarebytes.com/mac/ and any other malware program you may have for a Mac.

Please let us know if this solved your issue or if need further assistance.

Hi, sounds like a add-on maybe or a unwanted program installed when installed something else. Firefox it self does not show Whois Info. Only when you click the Information Icon should you get information or if have Push Notifications on would you get info, but not Whois Info. Please check your add-ons and look for any programs that you did not install. Please do a scan with https://www.malwarebytes.com/mac/ and any other malware program you may have for a Mac. Please let us know if this solved your issue or if need further assistance.

提出問題者

Hey things for the reply. I'm attaching a screen shot of the popup. Malwarebytes comes up clean and I don't see any newly installed programs that shouldn't be there.

The add ons I have are: 1password, firefox pioneer, https everywhere, pioneer online new study, privacy badger, rescuetime, ublock origin.

I guess I'll try selectively disabling these add ons.

Hey things for the reply. I'm attaching a screen shot of the popup. Malwarebytes comes up clean and I don't see any newly installed programs that shouldn't be there. The add ons I have are: 1password, firefox pioneer, https everywhere, pioneer online new study, privacy badger, rescuetime, ublock origin. I guess I'll try selectively disabling these add ons.

提出問題者

Oops here's the screen shot.

link text

Oops here's the screen shot. [https://drive.google.com/file/d/1LZdWP1U-3iGmxFp4RG5dg9iN1NX57aIS/view?usp=sharing link text]
Shadow110 1072 個解決方法 14836 個答案

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?
Shadow110 1072 個解決方法 14836 個答案

Hi, what security software are you running ? Was there a update for this before this started. Please visit their Community Support Forum to see if others have this issue.

Hi, what security software are you running ? Was there a update for this before this started. Please visit their Community Support Forum to see if others have this issue.

提出問題者

Thanks - I will try these things. By security software you mean virus scanning? None.

Thanks - I will try these things. By security software you mean virus scanning? None.
Shadow110 1072 個解決方法 14836 個答案

geofffitch said

Thanks - I will try these things. By security software you mean virus scanning? None.

Or a firewall ? Please run this : https://www.malwarebytes.com/mac/

You can work with the info here to globally turn off Push Notifications : WEBSITE NOTIFICATIONS

Websites can ask you to accept several different kinds of communications and updates:

  • Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site.
  • Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox).
  • Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing.

Site-Specific Permissions/Blocks

If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions

(menu bar) Tools menu > Page Info > Permissions or click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content

Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

(5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. (Note: you need to edit the text in the filter box above the list to display this preference.)

Troubleshooting: Site-Specific Permissions Are Forgotten?

Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page.

If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Troubleshooting: Pages still display a permission dialog

Website scripts can display pre-permission dialogs even if Firefox ultimately won't allow the services. This is beyond the control of Firefox, but possibly could be tamped down with add-ons.

''geofffitch [[#answer-1101019|said]]'' <blockquote> Thanks - I will try these things. By security software you mean virus scanning? None. </blockquote> Or a firewall ? Please run this : https://www.malwarebytes.com/mac/ You can work with the info here to globally turn off Push Notifications : WEBSITE NOTIFICATIONS Websites can ask you to accept several different kinds of communications and updates: *Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site. *Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox). *Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing. Site-Specific Permissions/Blocks If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either: *right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions (menu bar) Tools menu > Page Info > Permissions or click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. Session Do Not Disturb To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: *Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only. All-Site Persistent Disable There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste webno and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site (4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites (5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. (Note: you need to edit the text in the filter box above the list to display this preference.) Troubleshooting: Site-Specific Permissions Are Forgotten? Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page. If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox. Troubleshooting: Pages still display a permission dialog Website scripts can display pre-permission dialogs even if Firefox ultimately won't allow the services. This is beyond the control of Firefox, but possibly could be tamped down with add-ons.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

Did you check that this isn't a feature from in installed extension?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Did you check that this isn't a feature from in installed extension? Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

選擇的解決方法

I disabled two plug ins I had from the Mozilla Pioneer project - One was called Firefox Pioneer; the other, Pioneer Online News Study. The problem went a way. Today I looked back and in my add-ons the Firefox Pioneer plug in was there, disabled as expected but the 'Online News Study' had disappeared. Not sure how that happens but perhaps this was an invalid add-on. Anyway, the problem seems to have gone a way so far.

I disabled two plug ins I had from the Mozilla Pioneer project - One was called Firefox Pioneer; the other, Pioneer Online News Study. The problem went a way. Today I looked back and in my add-ons the Firefox Pioneer plug in was there, disabled as expected but the 'Online News Study' had disappeared. Not sure how that happens but perhaps this was an invalid add-on. Anyway, the problem seems to have gone a way so far.
Shadow110 1072 個解決方法 14836 個答案

Hi, unusual for that to happen but am glad you found the cure. Let's just complete that for you : Copy/Paste about:studies into the Address Bar then Enter. Click Change Preferences and pof right there stick a tick in any of the 2 empty boxes and then put a Uncheck Allow Studies.

You can leave check marks in the other boxes if so choose especially if you post here again as we use the info sent to see your add-ons and Video Card Drivers to check for errors and updates.

Or just put the check marks back in before posting a question here.

Please let us know if this solved your issue or if need further assistance.

Hi, unusual for that to happen but am glad you found the cure. Let's just complete that for you : Copy/Paste about:studies into the Address Bar then Enter. Click Change Preferences and pof right there stick a tick in any of the 2 empty boxes and then put a Uncheck Allow Studies. You can leave check marks in the other boxes if so choose especially if you post here again as we use the info sent to see your add-ons and Video Card Drivers to check for errors and updates. Or just put the check marks back in before posting a question here. Please let us know if this solved your issue or if need further assistance.

提出問題者

Thanks. Done.

Thanks. Done.