搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Campaign website won't load images

  • 8 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 cor-el

more options

Hello. I am trying to visit and use this site: https://www.hozelock.com/plantapot-pledge/ The images won't load using Firefox but it works in Chrome (NOT our preference). I have been through the troubleshooter, tried safe mode, disabled extensions, refreshed Firefox, disabled our Kaspersky internet security package etc and nothing works. The grey padlock is shown suggesting 'mixed content' but when this is clicked on we have no options to change the settings as your help article suggested we would. We're running Firefox Quantum 59.0.2 (64-bit) and have noticed that in general it is a fair rate slower than older versions... Thanks in advance UF

所有回覆 (8)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options
more options

The Web Console shows this message about the presence of passive mixed content (image) and this shouldn't have affect since the image isn't blocked.

Loading mixed (insecure) display content “http://www.hozelock.com/wp-content/uploads/2018/01/PLEDGE-button-v4.png” on a secure page

Can you attach a screenshot to show what the page looks like?


If images are missing then check that you do not block images from some domains.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions".

Check "Tools -> Page Info -> Media" for blocked images

  • select the first image and use the cursor Down key to scroll through the list
  • if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain

You can check this pref on the about:config page.

  • permissions.default.image (1)
  • network.http.sendRefererHeader (2)

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, , Discard, #Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You see the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

  • click the shield icon for more detail
  • check the Web Console for more detail about what content is blocked by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

See also:

more options

Thanks Cor-el. The generic help articles are of no help unfortunately as I've tried the actions listed (where relevant). I've attached a screen shot of what the page looks like in Firefox versus Chrome and hope this might help.

There are no adverse permissions, settings that I can spot.

Thanks in advance.

more options

Can you see the image if you paste the link in the location bar?

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and Cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Hi Cor-el and thanks again for trying to help.

Taking your points in turn:

Can you see the image if you paste the link in the location bar?

   http://www.hozelock.com/wp-content/uploads/2018/01/PlantAPotLogo300x300mm72.png 

NO - PC tries to open the file using the picture viewer instead of the browser (although a page remains open) and then I just get the error message that this PNG file cannot be opened.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

   https://developer.mozilla.org/en/Tools/Web_Console 

I can check all I like but don't understand what I'm being told... the mixed blocked content flags just state that some of the content is not secure but I have no options to grant permissions to accept that content..

You can check the Network Monitor to see if content is blocked or otherwise fails to load.


Sorry, the rest of this info is beyond my technical aptitude...

I did do the 'Forget about this site' action but it made no difference. Just going to give up with Firefox.

more options

unionfan said

Can you see the image if you paste the link in the location bar? http://www.hozelock.com/wp-content/uploads/2018/01/PlantAPotLogo300x300mm72.png NO - PC tries to open the file using the picture viewer instead of the browser (although a page remains open) and then I just get the error message that this PNG file cannot be opened.

Firefox always prefers to shows JPEG and PNG images in a tab. Do you have any kind of image downloader add-on that might cause Firefox to handle images differently?

more options

You can rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.