搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

DNS Cache Expire set to 60 but isn't updating to new associated IP addresses after 4 days with Clear History notworking but 0 in network.dnsCacheExpiration does

  • 11 回覆
  • 1 有這個問題
  • 2749 次檢視
  • 最近回覆由 cor-el

more options

Have had issues with XHR calls holding on to the wrong DNS address. The DNS Cache Expiration is set to 60. The ip resolves correctly in every other DNS lookup available except Quantum. That holds onto the incorrect ip address until the network.dnsCacheExpiration is set to 0. Causing several customer complaints about Firefox, repeatable on my own version of Firefox. Our suggestion right now to users is not to use firefox while this behavior appears to be occurring. Would like to support firefox but can't if the DNS caching appears to be broken for some users and is turned on by default.

被選擇的解決方法

Okay, I'm going to encourage you to file a bug because I don't know how to create a test case for this problem.

I was thinking we needed to confirm that the problem keeps recurring even after you clear the DNS cache, but since exiting Firefox and starting a new session should clear it, it seems that we already know the problem recurs.

If the only way to avoid the problem is not to use the DNS cache at all, that's hard to explain. Perhaps cache entries are getting corrupted?? Or Firefox uses a different method of DNS resolution in that case??

https://bugzilla.mozilla.org/enter_bug.cgi

從原來的回覆中察看解決方案 👍 0

所有回覆 (11)

more options

That's hard to understand... I assume you are familiar with the Network Monitor in the developer tools. (https://developer.mozilla.org/docs/Tools/Network_Monitor) It shows the IP address Firefox used for each request, but I don't think it records the DNS resolution process. That might in the very verbose HTTP log file you can create. See: https://developer.mozilla.org/docs/Mozilla/Debugging/HTTP_logging.

Could you experiment with your connection setting here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your OS settings (on Windows, the IE "LAN" setting; I don't know about Mac). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

more options

Thanks for the quick reply. On my own firefox instance I had No Proxy set in preference. I do jump on and off several VPNs, but doing so to test if that caused or would fix the problem never impacted the behavior at all. In network tools, the ip address was the incorrect, stale ip address whereas every other dns lookup tool I could use to test how my machine was resolving resolved to the correct address. Talked to the dev that runs the DNS address in question and he verified the TTL was 3600 on the server. Really appears firefox for whatever reason was not timing out the dns cache. And again appears not to be isolated. Obviously could be other issues regular users are having but my testing seems to point specifically to that as the problem. Will attempt more verbose log output to see if dns resolution is a part of it.

more options

Should also add the URL resolved just fine in the address bar, the DNS cached wrong ip address was only for XHR requests, so potentially a bug in javascript engine specifically.

more options

Is it a same-site or cross-site XHR request?

If the host name is perfectly identical, it's hard to understand how a different IP address would be used from that used for the main page moments earlier.

If it's a cross-site request, it's not clear how the wrong value could be cached when non-cached retrieval works correctly and you've cleared Firefox's cache.

more options

It's a cross-site request returning XML. The network info shows it did not hit a content cache, definitely making a new call out to the stale ip address each time. And it was corrected by setting "network.dnsCacheExpiration" to 0, just not through the Clear History options. Still think it points to a potential bug in the javascript engine with the domain name resolving correctly through the address bar. Not sure how each uses the internal dns cache.

more options

Clearing the cache is supposed to clear both pages and DNS entries.

Another way to flush the DNS cache might be to set it to a very small number of records. What I'm trying to make sure is that we can rule out a stuck entry in there and see whether the problem repeats now:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste dns and pause while the list is filtered

(3) Double-click the network.dnsCacheEntries preference and enter a low value such as 5 and click OK

(4) Leave network.dnsCacheExpiration and network.dnsCacheExpirationGracePeriod with their default values (you can right-click > Reset if needed)

more options

It's more an issue of how to deal with general users on a public site that necessitate this XHR call to make the website work. If it's a configuration change to a default firefox parameter and that's the only fix, I need to put up a message for users not to use Firefox. Can't troubleshoot this for the a public user base.

more options

Will look at the entries value to see if that has any impact, getting the DNS address cached again after setting the Expiration value to zero may not be easy/possible and I've exhausted my firefox instances for this url and server.

more options

選擇的解決方法

Okay, I'm going to encourage you to file a bug because I don't know how to create a test case for this problem.

I was thinking we needed to confirm that the problem keeps recurring even after you clear the DNS cache, but since exiting Firefox and starting a new session should clear it, it seems that we already know the problem recurs.

If the only way to avoid the problem is not to use the DNS cache at all, that's hard to explain. Perhaps cache entries are getting corrupted?? Or Firefox uses a different method of DNS resolution in that case??

https://bugzilla.mozilla.org/enter_bug.cgi

more options

Will do. Thanks for the help.

more options

Note that the about:networking page includes a DNS lookup tool.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and Cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.