Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox 59.0.2, W10, pages do not load, browser stalls.

  • 9 回覆
  • 3 有這個問題
  • 599 次檢視
  • 最近回覆由 FredMcD

more options

Firefox 59.0.2 64 bit becomes unresponsive on page load. Cannot exit browser through upper right "X". Must use Task Manager to kill it.

Windows 10 64 bit, Cleartype is enabled. Possibly significant: machine is a Thinkpad X61 tablet, with simple Intel integrated graphics, GMA X3100, from 2008. RAM usage does not appear excessive. Machine has 8GB RAM. Processor is L7500 dual core.

The problem may only occur, or be accentuated, when another user application is running, even in the background. It resembles the reports of machines running Windows 7.;

被選擇的解決方法

Have you tried disabling the add-ons?

從原來的回覆中察看解決方案 👍 0

All Replies (9)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

In safe mode, Firefox works normally, though proportionally slower than, say, 58.0.2.

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Disabling hardware acceleration normalizes Firefox behavior. But it is not quite as fast as 58 with hardware acceleration, so I'm not marking it as "solved."

Would you hazard an opinion as to whether hardware acceleration will be fixed for these low resource machines?

more options

選擇的解決方法

Have you tried disabling the add-ons?

more options

The anomaly occurs only when two ad blockers, UBlock Origin, and Adblock Plus, are simultaneously activated. Firefox works fine with either one. UBlock Origin has faster page load times.

Apparently, the new thread structure of FIrefox makes it less tolerant to this kind of configuration error.

So the problem is solved. Thank you for your assistance. It is gratifying to discover that 59.0.2 is a goo release.

more options

Glad to hear. You should not have more than one program doing the same job as they may end up tripping each other.

more options

Nothing new with Mozilla Firefox as I also have the problem. Waiting, waiting, and waiting just to realize it has stopped responding to my clicks as of nothing happened. Have to click twice for browser to load intended page.

由 netscaper 於 修改

more options

netscaper Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.