搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website Slow to Load in Firefox

  • 7 回覆
  • 2 有這個問題
  • 6 次檢視
  • 最近回覆由 Shadow110

more options

I have an issue with slow loading pages on several websites, including one I am designing, using the newest Firefox (59.0.1 64 bit). Since I no longer use Firefox as my default browser I can't say every site is slow, but all that I have tried are. The worst so far has been msn.com which took over 30 seconds to load. I was forced to start using Chrome as my default browser due to the speed issues.

The site I am designing has been heavily optimized using GTMetrix and Pingdom. There is still some more work to do but the load times are consistently below two seconds. When I visit the site on any other browser installed (Chrome, Edge, Internet Explorer, Opera) it is fast and responsive (within 2 seconds) but when using Firefox it takes between 5 to 15 seconds on average to load the site and to load each new page from the site. This is for every page, even after it should be cached.

This a completely new computer built from scratch with a fresh install of Windows 10 Pro and all browsers. There are no plugins installed besides the antivirus. I have tried all of the steps listed in https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems as well as completely disabling my antivirus (Avast Free) and disabling hardware acceleration. This issue is reproducable on every new workstation in our office as well as some desktops at different locations but not my laptop with Windows 10 Home and several Linux distributions. I'm at a loss why this is happening and would appreciate any assistance.

所有回覆 (7)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Make sure you are not blocking content. Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Yes, the issue is still there. I've already tried this but tried it again on your suggestion.

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

I'm unable to test Safe Mode right now. For some reason DHCP assigns the wrong IP address in Safe Mode and I can't get internet. I will have to test that as soon as I get a chance.

more options

HI, there appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. So a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in Firefox: https://support.mozilla.org/en-US/kb/performance-settings

more options

I found a band-aid for the issue but am still trying to find a better solution. As far as I can tell the issue isn't related to fonts or acceleration as that was already tried. Completely uninstalling Firefox, manually removing the profile folder, and reinstalling seemed to work. Please note that I tried reinstalling Firefox several times using both versions 57 and 59. The issue persisted until the profile was deleted.

This issue exists across multiple computers and I can't just ask everyone to delete their profiles. Does anyone know what in the profile might be causing this?

more options

Bestrafung said

I found a band-aid for the issue but am still trying to find a better solution. As far as I can tell the issue isn't related to fonts or acceleration as that was already tried. Completely uninstalling Firefox, manually removing the profile folder, and reinstalling seemed to work. Please note that I tried reinstalling Firefox several times using both versions 57 and 59. The issue persisted until the profile was deleted. This issue exists across multiple computers and I can't just ask everyone to delete their profiles. Does anyone know what in the profile might be causing this?

No, but you can dissect it and enter data till it corrupts then will have your answer. Create a new profile as a TEST to check if your current profile is causing the problem.

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files.