X
點擊此處開啟此網站的行動版。

技術支援討論區

Webpage disappears after a few seconds under certain browser width

已張貼

Hi, I'm an eng trying to do cross-browser debugging. Firefox is giving me a weird bug. To start:

- No plugins installed - No ad blockers installed - Cleared cache, cookies, history, everything - version 58.0.2 (64-bit) on Mac OS 10.12.6

Having trouble repro'ing this bug but here's my best shot.

Navigate to https://www.joinhonor.com/care-network

Shrink the browser width to about 500px.

Scroll a bit, wait a bit. Maybe do something else for a few seconds.

Page goes blank except for header, footer and maybe a few other components.

Doesn't happen in Chrome or Safari.

I've been able to repro on a few pages but not consistently.

Any ideas? Thanks!

Hi, I'm an eng trying to do cross-browser debugging. Firefox is giving me a weird bug. To start: - No plugins installed - No ad blockers installed - Cleared cache, cookies, history, everything - version 58.0.2 (64-bit) on Mac OS 10.12.6 Having trouble repro'ing this bug but here's my best shot. Navigate to https://www.joinhonor.com/care-network Shrink the browser width to about 500px. Scroll a bit, wait a bit. Maybe do something else for a few seconds. Page goes blank except for header, footer and maybe a few other components. Doesn't happen in Chrome or Safari. I've been able to repro on a few pages but not consistently. Any ideas? Thanks!

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

更多資訊

FredMcD
  • Top 10 Contributor
4248 個解決方法 59420 個答案

有幫助的回覆

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
jscher2000
  • Top 10 Contributor
8698 個解決方法 71098 個答案

有幫助的回覆

The problem occurs when the display is narrow enough for the photo in the top section to move below the yellow button.

Any time I change something in the Page Inspector, e.g., click off display:flex for a div or assign display:block to a span, everything is good for 5-10 seconds, and then away it goes. There is a constantly running script that is doing something odd, but I have no idea what it is.

This page is very complex. You probably should seek support on a site where experts on this framework hang out.

The problem occurs when the display is narrow enough for the photo in the top section to move below the yellow button. Any time I change something in the Page Inspector, e.g., click off display:flex for a div or assign display:block to a span, everything is good for 5-10 seconds, and then away it goes. There is a constantly running script that is doing something odd, but I have no idea what it is. This page is very complex. You probably should seek support on a site where experts on this framework hang out.

提出問題者

screenshot attached

screenshot attached

提出問題者

@jscher2000

Thanks for the quick response. Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper.

I'm not sure why this issue is happening only on Firefox.

@jscher2000 Thanks for the quick response. Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper. I'm not sure why this issue is happening only on Firefox.
FredMcD
  • Top 10 Contributor
4248 個解決方法 59420 個答案

This is what the picture looks like.

This is what the picture looks like.
jscher2000
  • Top 10 Contributor
8698 個解決方法 71098 個答案

benjamin88 said

Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper.

This framework is waaaaay too complicated for me to find anything. What I can tell you with certainty is: if JavaScript is disabled, the problem goes away.

There are other issues with scripts disabled, such as the quote carousel overlaying body text. I wonder if the carousel could be an issue? It would make sense to be something running on a timer.

''benjamin88 [[#answer-1086793|said]]'' <blockquote>Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper. </blockquote> This framework is waaaaay too complicated for me to find anything. What I can tell you with certainty is: if JavaScript is disabled, the problem goes away. There are other issues with scripts disabled, such as the quote carousel overlaying body text. I wonder if the carousel could be an issue? It would make sense to be something running on a timer.