X
點擊此處開啟此網站的行動版。

技術支援討論區

firefox violates never check

已張貼

I installed Firefox 45 yesterday, and included my favorite addons, including maff support.

I was very careful to check "Never check for updates" and un-check "Use a background service to install updates."

This morning maff would not work, and I found Firefox version 52 on my machine.

I have extremely expensive, bandwidth-limited internet, and it is very disappointing to see how windows will decide to uncheck "never update" and other applications (looking at you, Chrome!) also spend my money without permission. I am sorry to see Firefox engaged in those same bad behaviors.

does anyone have any tips on how to force Firefox to stay the same? I have zipped up the directories, so if this happens again (count on it, right?) I will see if just unzipping will restore it back to what I expect.

Is there an easier way?

Thanks!

I installed Firefox 45 yesterday, and included my favorite addons, including maff support. I was very careful to check "Never check for updates" and un-check "Use a background service to install updates." This morning maff would not work, and I found Firefox version 52 on my machine. I have extremely expensive, bandwidth-limited internet, and it is very disappointing to see how windows will decide to uncheck "never update" and other applications (looking at you, Chrome!) also spend my money without permission. I am sorry to see Firefox engaged in those same bad behaviors. does anyone have any tips on how to force Firefox to stay the same? I have zipped up the directories, so if this happens again (count on it, right?) I will see if just unzipping will restore it back to what I expect. Is there an easier way? Thanks!

額外的系統細節

已安裝的外掛程式

  • 5.1.50907.0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0

更多資訊

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 個解決方法 10670 個答案

You should not use old versions of anything, especially browsers. Please update to Firefox 58 and continue to keep it up to date.

You should not use old versions of anything, especially browsers. Please update to Firefox 58 and continue to keep it up to date.

提出問題者

Tyler Downer said

You should not use old versions of anything, especially browsers. Please update to Firefox 58 and continue to keep it up to date.

Hi Tyler, Thanks for your point of view.

It is critical on my limited bandwidth to prevent applications from unauthorized internet access. Perhaps the latest version of Firefox honors the "Never Check" settings... I don't know.

Unfortunately, I can't run MAFF on the latest Firefox, so I am trapped in Firefox 45 for a while. I have other favorite addons that were also scheduled to never upgrade, so I have not spent much time with the current version.

I read a lot about the new API issues last year, and I was left with the impression that some of the capabilities in the old API were impossible to implement in the new system, so I have worked harder and harder to keep my favorites alive. Perhaps in the future most of my addon features will be supported.

''Tyler Downer [[#answer-1083239|said]]'' <blockquote> You should not use old versions of anything, especially browsers. Please update to Firefox 58 and continue to keep it up to date. </blockquote> Hi Tyler, Thanks for your point of view. It is critical on my limited bandwidth to prevent applications from unauthorized internet access. Perhaps the latest version of Firefox honors the "Never Check" settings... I don't know. Unfortunately, I can't run MAFF on the latest Firefox, so I am trapped in Firefox 45 for a while. I have other favorite addons that were also scheduled to never upgrade, so I have not spent much time with the current version. I read a lot about the new API issues last year, and I was left with the impression that some of the capabilities in the old API were impossible to implement in the new system, so I have worked harder and harder to keep my favorites alive. Perhaps in the future most of my addon features will be supported.
jscher2000
  • Top 10 Contributor
8699 個解決方法 71098 個答案

I think a major reason MAFF cannot run the same way on Firefox 57+ is the tight restrictions on how add-ons can access disk storage. It also makes system-level changes such as setting file associations, which is not trivial with the new API (you need to create a companion program called a native application, installed separately, for the extension to interact with).

However, it should run on the Extended Support Release of Firefox 52. Versions 4.1.3 and later are indicated as compatible on the Versions page. If you disabled auto-updates, that probably kept your extensions on their old versions as well.

Check out the release notes on more recent versions for changes being made:

https://addons.mozilla.org/firefox/addon/mozilla-archive-format/versions/

I think a major reason MAFF cannot run the same way on Firefox 57+ is the tight restrictions on how add-ons can access disk storage. It also makes system-level changes such as setting file associations, which is not trivial with the new API (you need to create a companion program called a native application, installed separately, for the extension to interact with). However, it should run on the Extended Support Release of Firefox 52. Versions 4.1.3 and later are indicated as compatible on the Versions page. If you disabled auto-updates, that probably kept your extensions on their old versions as well. Check out the release notes on more recent versions for changes being made: https://addons.mozilla.org/firefox/addon/mozilla-archive-format/versions/
James
  • Moderator
1596 個解決方法 11250 個答案

enthusiast797 said

Unfortunately, I can't run MAFF on the latest Firefox, so I am trapped in Firefox 45 for a while. I have other favorite addons that were also scheduled to never upgrade, so I have not spent much time with the current version.

Where are you seeing that you must use the old vulnerable Firefox 45.9.0 ESR to use the maff extension?

https://addons.mozilla.org/firefox/addon/mozilla-archive-format/versions/ Version 5.2.1 Released Feb. 21, 2018 Works with Firefox 52.0 - 56.*

You would have to use a older version of this extension for the old EOL Firefox 45.9.0esr. Version 4.1.4 Released Sept. 3, 2017 Works with Firefox 45.0 - 56.*

Firefox 52 ESR is still being supported by Mozilla with security and allowed stability fixes. It does not get new features and if you do not miss a update it should only be small partials.

Firefox 52.6.0 esr is the current and the 52.9.0esr out on June 26 will be the last update. https://www.mozilla.org/firefox/organizations/all/

''enthusiast797 [[#answer-1083254|said]]'' <blockquote>Unfortunately, I can't run MAFF on the latest Firefox, so I am trapped in Firefox 45 for a while. I have other favorite addons that were also scheduled to never upgrade, so I have not spent much time with the current version. </blockquote> Where are you seeing that you must use the old vulnerable Firefox 45.9.0 ESR to use the maff extension? https://addons.mozilla.org/firefox/addon/mozilla-archive-format/versions/ Version 5.2.1 Released Feb. 21, 2018 Works with Firefox '''52.0''' - 56.* You would have to use a older version of this extension for the old EOL Firefox 45.9.0esr. Version 4.1.4 Released Sept. 3, 2017 Works with Firefox 45.0 - 56.* Firefox 52 ESR is still being supported by Mozilla with security and allowed stability fixes. It does not get new features and if you do not miss a update it should only be small partials. Firefox 52.'''6'''.0 esr is the current and the 52.'''9'''.0esr out on June 26 will be the last update. https://www.mozilla.org/firefox/organizations/all/