Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

There is a single website that is displaying in a different language, and I can't figure out why.

  • 9 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 MarcCBT

more options

There is a file sharing website that allows me to view/edit Microsoft Office files. The website displays correctly in English, but when I access an Excel or Word file, the contents of the file display in a different language. It's even stranger because in the case of Excel files, clicking on a cell shows the cell contents in an editing box at the top of the page and that is in English. It only happens on a single computer, and when I run Firefox in Safe Mode it does not happen. I have checked the Add-ons and the only one installed is Adobe Acrobat, and it's disabled. I tried a refresh but the issue still occurred. I also created a new profile but the issue still occurred. Any suggestions would be greatly appreciated.

There is a file sharing website that allows me to view/edit Microsoft Office files. The website displays correctly in English, but when I access an Excel or Word file, the contents of the file display in a different language. It's even stranger because in the case of Excel files, clicking on a cell shows the cell contents in an editing box at the top of the page and that is in English. It only happens on a single computer, and when I run Firefox in Safe Mode it does not happen. I have checked the Add-ons and the only one installed is Adobe Acrobat, and it's disabled. I tried a refresh but the issue still occurred. I also created a new profile but the issue still occurred. Any suggestions would be greatly appreciated.

所有回覆 (9)

more options

What site?

more options

Hi WestEnd, The site is synctedtool.com; it requires a username/password to access. I'm pretty sure it's not the site as it doesn't happen in any other browser on the affected computer, or on any other computer in any browser.

more options

What language do you see?

Can you attach a screenshot?

more options

Hi cor-el, Sorry for the delay. I've attached a screenshot.

more options

What language it is that is showing? And does anything else on that site have that same issue? Also I noticed unless you have Chrome, FF doesn't translate language AFAIK something I use Chrome for.

more options

It is possible that the website obscures some data in the table for some reason (security/privacy). Such behavior might be affected to your login state to this website.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

Hi WestEnd, I have no idea what language that is. It appears on any Word or Excel file that opens in that site's editor but it only happens in Firefox in normal mode on this one computer. If I open the same exact URL in Firefox in Safe Mode, or use Chrome or Internet Explorer, it displays in English normally. On any other computer I tried using Firefox it displayed normally. It seems to me that some hidden add-on might be causing this but I can't find any add-ons installed and creating a new profile didn't help.

Hi cor-el, This issue only appears in Firefox, and only on this single computer, so it doesn't seem to me like it would be an issue with the site or the login. Running Firefox in Safe Mode displays the site properly in English, which is why I was thinking it had to be an add-on.

more options

Can you attach a screenshot (Safe Mode) to show how that page should display?

It is possible that there is a problem with the font that is used.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the CSS rule that specifies the font-family, but about the font that Firefox actually uses as shown in the Font tab.


You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

Hi cor-el, Here's a screenshot of the document when running Firefox in Safe Mode. I will test those two things today and let you know. Thank you.