搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Since update my text is grainy 2-9-18

  • 5 回覆
  • 1 有這個問題
  • 25 次檢視
  • 最近回覆由 cor-el

more options

2-8-18 My computer did a windows update, and my firefox did an update. Since all the text on my firefox is grainy, and weird looking. I wouldn't care but it is hurting my eyes to look at it. I've looked for answers on your support page but I'm not coming up with anything that is working. Please help me. I work from home with my firefox and I've always loved it. But this is not going to work.

所有回覆 (5)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

No that did not do anything. Attached is a screen shot of my screen. Logo's and photos are working fine. But the text on any website, typed, anything all look really strange. Grainy. "l, B, N, M, T," examples if you look anything that has a line has a double line in the points. I'm really confused.

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

more options

Nope that was already checked. Didn't fix anything.

more options

You can check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.


Firefox 52+ has changed from Cairo to Skia for canvas/content rendering.

You can modify these gfx.*.azure.backends prefs on the about:config page to revert to the old font rendering swap the skia,cairo order to cairo,skia or remove the skia and leave cairo to see if that has effect.

  • gfx.canvas.azure.backends = direct2d1.1,cairo,skia
  • gfx.content.azure.backends = direct2d1.1,cairo,skia

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

If this didn't work then undo/reverse the change and reset the prefs you modified via the right-click context menu to the default value.