搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I am unable to open the PayPal payment page from eBay after the last update

  • 9 回覆
  • 5 有這個問題
  • 481 次檢視
  • 最近回覆由 ekendraed

more options

After the most recent update to Firefox, I am unable to open the PayPal payment option page from within eBay. I was able to do this previously.

I get this error message;

" Don't see the secure PayPal browser? 

We'll help you re-launch the window to complete the purchase"

I have no problems with Chrome, Microsoft Edge and Chrome for Android.

Hope you can find a solution to this problem.

Thanks

所有回覆 (9)

more options

Screen shot of the error message? I myself have no issue with Paypal from FF57+ to FF58 without problem.

more options

Accessed PayPal via eBay.co.uk on fully updated Arch Linux. Originally worked with Firefox 57, but failed on some subsequent update. Can't give screenshot because, apart from OP's error message, nothing happens and nothing to see. Not the sort of thing you can experiment with, as you're trying to make a one-off payment and can't risk screwing up the process!

由 stninian 於 修改

more options

Check for a shield icon toward the left end of the address bar that would indicate Firefox's Tracking Protection feature is blocking something in the page. More info: What happened to Tracking Protection?.


Issues with third party payment sites where data has to be sent back and forth often are caused by one of these:

(1) Redirect block. To clear that, either:

Firefox 55 and earlier:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. Then on the right side, with the "General" mini-tab active, make sure the following is not selected (box is not checked): "Warn me when websites try to redirect or reload the page"

Firefox 56+:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box above the list, type or paste access and pause while the list is filtered

(C) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

(2) Third party cookie restriction. For more on these settings, see: Websites say cookies are blocked - Unblock them.

(3) Extension that filters content (e.g., ad blocker, anti-tracking, script block).

Usually these have a toolbar button to manage how they are affecting the page.

You also can view, disable, and often remove extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that looks like it may block content in pages? You could try the Options button in that case, or Disable.

Any improvement?

由 jscher2000 於 修改

more options

jscher2000 said

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
In the left column, click Advanced. Then on the right side, with the "General" mini-tab active, make sure the following is not selected (box is not checked): "Warn me when websites try to redirect or reload the page"

Don't seem to have that preference (FF 58.0.1, Linux). But many thanks for other detailed suggestions - will try when next purchasing from eBay. They certainly make sense.

more options

I'm sorry, I pasted an old list. The new way to check the redirect block in Firefox 56+ is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

more options

For Westend

The problem appears to be specific to Firefox 58.0.1 as I did not have the issue with Firefox 57. I don't have the problem with Chrome, Chrome for Android and Microsoft Edge

The screen shot is attached

由 ekendraed 於 修改

more options

Hi ekendraed, are you using a "High Contrast" theme in Windows? I wonder whether it would help to set Firefox not to adapt web pages to that theme.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog:

more options

I am using the Dark Background and Light Text theme.

I disabled it, reloaded Firefox but the problem persists. The PayPal RADIO button seems grayed out.

Thank you for your response

由 ekendraed 於 修改

more options

With the recent update to Firefox the issue I had with PayPal is now gone.

I was successfully able to access the PayPal page from Firefox and make my payment.

Thank you for resolving this problem