搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Sound from browser is "scratchy"

  • 3 回覆
  • 2 有這個問題
  • 12 次檢視
  • 最近回覆由 Shadow110

more options

Hello, this started out of nowhere (I didn't changed any software or hardware, only default OS updates). All audio output, whether playing videos on youtube or songs from whatever online audio stream or even when playing downloaded music through the browser (offline) gets the sound to be scratchy.

Volume is fine. No other distortion is perceivable. Playing the same audio or any movie through other applications (VLC, native Movie etc) generates a clean sound.

On this same PC I also have a Windows 7 Ultimate installed, whose all sounds generated from browser (including Firefox Quantum and Chrome) and other programs alike are clean.

My system specs: - Debian 9.3 stable (stretch) - 4GB RAM - 140gb available (shared HD with other OS) - GT220 with proprietary NVIDIA driver installed. - Hello, this started out of nowhere (I didn't changed any software or hardware, only default OS updates). All audio output, whether playing videos on youtube or songs from whatever online audio stream or even when playing downloaded music through the browser (offline) gets the sound to be scratchy. Volume is fine. No other distortion is perceivable. Playing the same audio or any movie through other applications (VLC, native Movie etc) generates a clean sound.

On this same PC I also have a Windows 7 Ultimate installed, whose all sounds generated from browser (including Firefox Quantum and Chrome) and other programs alike are clean. I can spill more info if it helps.

My system specs: - Debian 9.3 stable (stretch) - 4GB RAM - 140gb available with 22gb still available/empty (shared HD with other OS) - Pentium(R) Dual-Core CPU E5300 @ 2.60GHz - Intel NM10/ICH7 Family High Definition Audio Controller - VGA Cable connecting GPU to monitor (so no HDMI or adapters here) - Sound box connected to standard audio jacks (in motherboard)

What I tried so far that did not helped: - Restarted several times and also left the computer off for a day. - Downloaded Chromium (from package manager) and Firefox Quantum (directly from website), both also produced scratched sounds. - Checked and installed general updates. - Checked cables and other physical stuff (well, other apps generate a clean sound, so I doubt it is a physical issue). - Googling and binging around, all I find are "no sound" problem threads that I could not use their troubleshooting methods to fix my stuff.

This already lasts for more or less two weeks. Any insights?

所有回覆 (3)

more options

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST

more options

Hi, turned out it was a problem with my OS settings, different volumes (130%) to different audio outputs.

more options

I am glad to hear that your problem has been resolved. If you haven't already, *Please select the answer that solves the problem*YOURS. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.