搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox window offsets slightly on startup

  • 12 回覆
  • 1 有這個問題
  • 15 次檢視
  • 最近回覆由 mwcarew

more options

https://gyazo.com/536cee4df71823cdc22d998668e44f16

Whenever I start Firefox after snapping it to the left side of my monitor, the window is offset slightly on the left and bottom. The same thing happens if I snap the window to the right edge of my monitor - Firefox starts back up slightly moved from the bottom and right then.

Not a big issue but bothering me nonetheless.

所有回覆 (12)

more options

To clarify also, the window shrinks a tad from the bottom but maintains its height at a top but actually shifts slightly to the right.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Thanks for that. Tried it. Safe mode seems to have its own set window position and doesn't save it at all.

more options

If the problem is not there, then try this;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

I'm on GeForce driver 388.59 from 12/7/17 and am up to date. The disabling of the hardware acceleration did not work.

more options

Then I suggest checking Microsoft out for fixes as that is there thing. Am sure Firefox is not the only window not to do this. Will say it is a Windows 10 issue.

more options

I'll give that a shot, but I will add that I only seem to have the issue with Firefox and Visual Studio Code. VSCode only has issues with the bottom of the window. Google Chrome, Hyper.js, Discord, VLC Player, and Steam don't seem to have issues.

I've also tried disabling Aero Snap and get the same window behavior on startup.

more options

Did this happen before Patch Tuesday or after Patches ? _____________________________________________________________________ Was doing a quick read, had to do with not working suggested SFC : I suggest DISM, because you can....same but diff.

Repair System Registry and Files

(FOR DOING Above & Below - WINDOWS All OTHER VERSIONS - Use Search To Find Command Prompt ** Enter CMD.exe to Find COMMAND PROMPT Then Right Click & RUN AS ADMIN)

To run the SFC command use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt (Admin). Type "SFC /SCANNOW" (without quotes or copy/paste) and press Enter. For more information on using SFC, please refer to the Microsoft KB: Use the System File Checker tool to repair missing or corrupted system files

Run the Windows Deployment Image Servicing and Management (DISM) and System File Checker (SFC) tools as Administrator. The DISM and SFC tools scan the integrity of the Windows image and all protected system files replaces corrupted, damaged and incorrect versions. (FOR DOING Above & Below - WINDOWS All OTHER VERSIONS - Use Search To Find Command Prompt ** Enter CMD.exe to Find COMMAND PROMPT Then Right Click & RUN AS ADMIN) Type "DISM /Online /Cleanup-Image /RestoreHealth" (without quotes or copy/paste) and press Enter.

Windows 10 To run the DISM command use the Windows key + X keyboard shortcut to open the Power User menu, then select Command Prompt (Admin). Type "DISM /Online /Cleanup-Image /RestoreHealth" (without quotes or copy/paste) and press Enter. Reboot After.

Note : SFC fixes files locally using files found on your system. Note : DISM goes up to Microsoft for new ones.

Please let us know if this solved your issue or if need further assistance

more options

Thank you both very much for your help by the way. Ran the system scan and deployment image stuff. No issues.

I put an issue up for VSCode on Github and will link if anything comes up. No idea if it'd be a similar issue.

由 mwcarew 於 修改

more options

Oh! Forgot to add I only installed Firefox yesterday. Wasn't on it before the patch.

more options

mwcarew said

Oh! Forgot to add I only installed Firefox yesterday. Wasn't on it before the patch.

First time install would make a small FF Browser window close to the upper left of the screen. Are you sure your not having Resolution scaling issues cause everything to shift? Also not setting your Display to Native resolution can shift Icons and Windows around as well.

more options

How would I know if I'm having resolution scaling problems? And I'm using my monitor's native resolution at 3440x1440. No icons and windows are switching around save for VSCode and Firefox. VSCode will shift slightly off the bottom but then be fine saved in that position until I try to resize it to cover the bottom again. Firefox offsets from the side and bottom and then is fine also until I try to stretch it to the edges again. No other apps seem to be having the issue.