搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to enable google suggestion in firefox 57 under ubuntu 14

  • 5 回覆
  • 8 有這個問題
  • 45 次檢視
  • 最近回覆由 jscher2000

more options

After upgrading to Firefox 57, the search box doesn't show suggestion if the search engine is Google. Search suggestion works if yahoo or bing are selected. I uploaded a couple of images showing what the issue is. I have the "Provide search suggestions" checkbox enabled of course. Switching from google to yahoo/bing in the "Default Search Engine" menu make the suggestion work, but if I switch back to google the issue resurfaces.

附加的畫面擷圖

被選擇的解決方法

Hi nickthegeek, thanks for the update. I think a similar fix is coming to all Ubuntu users based on this:

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1733970

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

Do you have any anti-tracking extensions that might be blocking background requests to Google?

If you can't think of anything like that, and if your Firefox is repackaged by your distribution, perhaps your Google search plugin doesn't include suggestions. Apologies about how obscure this is, but investigating that will take a bit of work. I would like you to look inside a compressed file to see whether your Google search plugin includes the suggestions URL. Here's how:

(1) Open this decompressor page on my website:

https://www.jeffersonscher.com/res/searchjson.html

(2) Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, next to Profile Folder, click the "Open Directory" button (on other OS, "Open Folder" or "Show in Finder").

Make sure you can see the white box on the decompressor page behind the file viewer.

(3) In the profile folder, find search.json.mozlz4 and drag it to the decompressor page and drop it there

(4) Assuming all goes well, the page should enable the Save Uncompressed JSON (search.json) button. Click that and either save the file or open it directly into Firefox. If you save the file, then open it in Firefox.

(5) Firefox should show the raw data for a couple moments than show a structured view. (If you use NoScript, you need to enable scripting in local files.)

(6) Use Find to look for google.com and in particular, the part of the file that looks like the attached screenshot. Does your Google search plugin include that section?

由 jscher2000 於 修改

more options

See also:

  • chrome://browser/locale/searchplugins/google.xml
more options

jscher2000 said

Do you have any anti-tracking extensions that might be blocking background requests to Google? If you can't think of anything like that, and if your Firefox is repackaged by your distribution, perhaps your Google search plugin doesn't include suggestions. Apologies about how obscure this is, but investigating that will take a bit of work. I would like you to look inside a compressed file to see whether your Google search plugin includes the suggestions URL. Here's how: (1) Open this decompressor page on my website: https://www.jeffersonscher.com/res/searchjson.html (2) Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return
In the first table on the page, next to Profile Folder, click the "Open Directory" button (on other OS, "Open Folder" or "Show in Finder"). Make sure you can see the white box on the decompressor page behind the file viewer. (3) In the profile folder, find search.json.mozlz4 and drag it to the decompressor page and drop it there (4) Assuming all goes well, the page should enable the Save Uncompressed JSON (search.json) button. Click that and either save the file or open it directly into Firefox. If you save the file, then open it in Firefox. (5) Firefox should show the raw data for a couple moments than show a structured view. (If you use NoScript, you need to enable scripting in local files.) (6) Use Find to look for google.com and in particular, the part of the file that looks like the attached screenshot. Does your Google search plugin include that section?

Thanks for your reply. I do have that section. The only difference is in the URL and the client parameter: I have it set at "ubuntu" (instead of firefox), and the resulting URL is: https://www.google.com/complete/search?client=ubuntu&q={searchTerms}. I suspect that might be the culprit. How can I change it?

more options

Thanks to the input given, I managed to find a (dirty) solution. I also installed the italian language support in the meanwhile (don't know if it had any effect or not, but after advancing to FF57, my italian settings were gone).

However, I edited any google.xml file in the /usr/lib/firefox/distribution/searchplugins/locale/ subdirectories (I had en-US, en-GB, it) changing ubuntu with firefox both in the client parameter and the URL. I also manually changed the search.json.mozlz4 file. After all, google suggestion started working.

more options

選擇的解決方法

Hi nickthegeek, thanks for the update. I think a similar fix is coming to all Ubuntu users based on this:

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1733970