X
點擊此處開啟此網站的行動版。

技術支援討論區

How do I change the toolbar font?

已張貼

A few years ago, when I first installed Mozilla FireFox on my Windows Vista machine, the first thing I noticed was how tiny the url and toolbar font was. No other application I've ever used on my laptop ever had text so small - it was barely legible. I googled the problem and found a simple way to fix this issue - install "Theme font and size changer" - sorted - until TODAY!! - "Theme font and size changer" is no longer supported and so I'm back to having to use a magnifying glass to read to read the toolbar. I thought never mind, there must be an equally simple way to make the text bigger. Having trawled the web, I've found many people with the same issue but no fix other than "Theme font and size changer" - which no longer works with the latest version of Firefox. So my question is quite simple - how the heck do I increase the text size, NOT of the web page - which is fine, but the top TOOLBAR/URL (and dropdown) menu. It has to be easy - but HOW ???!!!

Thankyou ;-)

A few years ago, when I first installed Mozilla FireFox on my Windows Vista machine, the first thing I noticed was how tiny the url and toolbar font was. No other application I've ever used on my laptop ever had text so small - it was barely legible. I googled the problem and found a simple way to fix this issue - install "Theme font and size changer" - sorted - until TODAY!! - "Theme font and size changer" is no longer supported and so I'm back to having to use a magnifying glass to read to read the toolbar. I thought never mind, there must be an equally simple way to make the text bigger. Having trawled the web, I've found many people with the same issue but no fix other than "Theme font and size changer" - which no longer works with the latest version of Firefox. So my question is quite simple - how the heck do I increase the text size, NOT of the web page - which is fine, but the top TOOLBAR/URL (and dropdown) menu. It has to be easy - but HOW ???!!! Thankyou ;-)

額外的系統細節

已安裝的外掛程式

  • Amazon MP3 Downloader Plugin 1.0.18
  • Citrix Online App Detector Plugin
  • OcxWebPlugin r1
  • Shockwave Flash 27.0 r0
  • 5.1.50906.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

更多資訊

patrickmc
  • Administrator
  • Moderator
35 個解決方法 224 個答案

Hello loftboy,

Thanks for contacting Mozilla Support.

It looks like you are on the ESR version of Firefox which does not have the latest version of that Add-on. Vista is no longer supported by Microsoft and Mozilla only provides the ESR version of Firefox for this OS.

In order to get the latest version of Firefox you'll need to update your OS to Windows 10 or a Linux distribution.

Cheers, Patrick

Hello loftboy, Thanks for contacting Mozilla Support. It looks like you are on the ESR version of Firefox which does not have the latest version of that Add-on. Vista is no longer supported by Microsoft and Mozilla only provides the ESR version of Firefox for this OS. In order to get the latest version of Firefox you'll need to update your OS to Windows 10 or a Linux distribution. Cheers, Patrick

提出問題者

Hi Patrick,

Thanks for your welcome and history. No way am I installing Windows 10 on my current machine - it's way to old/reliable to contemplate such a move! I can just about read the toolbar text - I've no idea why it was ever designed to be SO small - but it is what it is. But I'm at a complete loss as to why it cannot be changed - surely there must be a way?

Hi Patrick, Thanks for your welcome and history. No way am I installing Windows 10 on my current machine - it's way to old/reliable to contemplate such a move! I can ''just about'' read the toolbar text - I've no idea why it was ever designed to be SO small - but it is what it is. But I'm at a complete loss as to why it cannot be changed - surely there must be a way?

提出問題者

The fact that the text size of the main source of navigation in Firefox cannot be changed really is quite bizarre, and frankly unbelievable. Once again, surely there has to be a simple way to increase the text size to something more legible?

The fact that the text size of the main source of navigation in Firefox cannot be changed really is quite bizarre, and frankly unbelievable. Once again, surely there has to be a simple way to increase the text size to something more legible?
Happy112 561 個解決方法 5694 個答案

Hi  !

Would you give this a try please :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type and look for the preference :

layout.css.devPixelsPerPx

and change its value to 1.25 or, if it's still too small, to 1.5

Note : don't use a value lower than 1.0, for things would become way too small too adjust  !

The value of '-1.0' is a special flag to Firefox to follow the system's Text Size setting. If you want to go back to that value, then right-click the preference and choose 'Reset', rather than to do it manually.

After you've made a change, close and the restart Firefox, in order for the change to take effect.

Hi ! Would you give this a try please : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type and look for the preference : '''layout.css.devPixelsPerPx''' and change its value to '''1.25''' or, if it's still too small, to '''1.5''' Note : don't use a value lower than '''1.0''', for things would become way too small too adjust ! The value of '-1.0' is a special flag to Firefox to follow the system's Text Size setting. If you want to go back to that value, then right-click the preference and choose 'Reset', rather than to do it manually. After you've made a change, close and the restart Firefox, in order for the change to take effect.

提出問題者

Hi Happy,

Many Thanks for your reply. Whilst googling this problem I did come across your suggested solution. Having tried this (and it does work - to an extent) I found that the whole web pages are "zoomed" as well - which is not desirable. Unfortunately, the toolbar text remains a skinny 1 pixel width - which is the main thing I need to sort...

Hi Happy, Many Thanks for your reply. Whilst googling this problem I did come across your suggested solution. Having tried this (and it does work - to an extent) I found that the whole web pages are "zoomed" as well - which is not desirable. Unfortunately, the toolbar text remains a skinny 1 pixel width - which is the main thing I need to sort...
Happy112 561 個解決方法 5694 個答案

Bummer  !

Maybe you'd like to do what the users in this thread did : contact the developer :

https://support.mozilla.org/en-US/questions/1184537

Might help  !

Bummer ! Maybe you'd like to do what the users in this thread did : contact the developer : https://support.mozilla.org/en-US/questions/1184537 Might help !

提出問題者

My sentiments exactly - BUMMER !! But yes - I'll contact the developer - many thanks ;-)

My sentiments exactly - BUMMER !! But yes - I'll contact the developer - many thanks ;-)

提出問題者

I've contacted the developer of Theme Font & Size Changer... and thanked him for his much appreciated good work - not his fault his work is no longer supported. However, what I'd really like to know is why the toolbar/dropdown menu text was designed to be so small in the first place? I have 2 laptops running different operating systems and on each machine there are no other applications where the text is so small.

I've contacted the developer of Theme Font & Size Changer... and thanked him for his much appreciated good work - not his fault his work is no longer supported. However, what I'd really like to know is why the toolbar/dropdown menu text was designed to be so small in the first place? I have 2 laptops running different operating systems and on each machine there are no other applications where the text is so small.
Happy112 561 個解決方法 5694 個答案

loftboy said

However, what I'd really like to know is why the toolbar/dropdown menu text was designed to be so small in the first place?

Not going to lie to you : I haven't a clue.

Quite frankly : I hadn't even noticed. Just to check if there is a huge difference between the toolbar/dropdown menus in Firefox and Edge, I went to check : I don't see any significant difference. Honest.

But as you are definately not the only one complaining about this, I can only hope that one of my fellow contributors will come up with the perfect solution for you, for this is way over my head (so sorry ..... ).

''loftboy [[#answer-1032152|said]]'' <blockquote> However, what I'd really like to know is why the toolbar/dropdown menu text was designed to be so small in the first place? </blockquote> Not going to lie to you : I haven't a clue. Quite frankly : I hadn't even noticed. Just to check if there is a huge difference between the toolbar/dropdown menus in Firefox and Edge, I went to check : I don't see any significant difference. Honest. But as you are definately not the only one complaining about this, I can only hope that one of my fellow contributors will come up with the perfect solution for you, for this is way over my head (so sorry ..... ).

提出問題者

No apology required ;-) However, are you saying that the toolbar/URL etc font in the attached image looks perfectly fine to you ?

No apology required ;-) However, are you saying that the toolbar/URL etc font in the attached image looks perfectly fine to you ?
Happy112 561 個解決方法 5694 個答案

loftboy said

However, are you saying that the toolbar/URL etc font in the attached image looks perfectly fine to you ?

Cross my heart and hope to die :   Yes.

I wouldn't mind if the font was bigger,   but it's not a must for me.

But again : you're not the only one who's not happy with this font. Somebody is bound to come up with the perfect solution for you (fingers crossed).

''loftboy [[#answer-1032613|said]]'' <blockquote> However, are you saying that the toolbar/URL etc font in the attached image looks perfectly fine to you ? </blockquote> Cross my heart and hope to die : &nbsp; Yes. I wouldn't mind if the font was bigger, &nbsp; but it's not a must for me. But again : you're not the only one who's not happy with this font. Somebody is bound to come up with the perfect solution for you (fingers crossed).

提出問題者

I think we're getting close to the answer of why the font was purposely set so small - the code was written by youngsters who can clearly read the screen, without glasses, from a distance of around 15" with no problem at all. These folks are most likely thinking why the heck is the webpage text so frickin' HUGE ?!! Answer - so folks over a certain age - like me - can actually read it ! Font size aside - the font itself is crap - totally unispiring and bland - no wonder so many folks are missing TF&SC functionality!

I think we're getting close to the answer of why the font was purposely set so small - the code was written by youngsters who can clearly read the screen, without glasses, from a distance of around 15" with no problem at all. These folks are most likely thinking why the heck is the webpage text so frickin' HUGE ?!! Answer - so folks over a certain age - like me - can actually read it ! Font ''size'' aside - the font itself is crap - totally unispiring and bland - no wonder so many folks are missing TF&SC functionality!
jscher2000
  • Top 10 Contributor
8695 個解決方法 71071 個答案

No need to criticize the youth, they're going to support us in our retirement. ;-)

I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character.

What about using an OLD version of the add-on from the Firefox 52 days, such as:

https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1

Then you can set the extension not to auto-update here:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one.

Can you get it back to normal?

No need to criticize the youth, they're going to support us in our retirement. ;-) I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character. What about using an OLD version of the add-on from the Firefox 52 days, such as: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1 Then you can set the extension not to auto-update here: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one. Can you get it back to normal?
Happy112 561 個解決方法 5694 個答案

Oh boy, now you sound angry. And angry men scare the bejeebers out of me, so I'm gonna do a runner .....

I sure hope that somebody will come to your rescue with the perfect solution and put a smile on your face  !

Edit :

While I was typing my post, somebody already came to your rescue .....

Oh boy, now you sound angry. And angry men scare the bejeebers out of me, so I'm gonna do a runner ..... I sure hope that somebody will come to your rescue with the perfect solution and put a smile on your face ! Edit : While I was typing my post, somebody already came to your rescue .....

由 Happy112 於 修改

提出問題者

Guy's - I'm not angry - just a tad frustrated - no doubt like a few others here ;-) I warmly remember the days when I could read newsprint without glasses ;-) As it's Friday night here in the UK I'm going to chill with a nice glass of red and revisit the issue in a day or two. I think maybe my first port of call will be to my local pharmacy to buy some new higher mag specs! Meanwhile - peace to each and all of you guys - it's only a browser ;-)

Guy's - I'm not angry - just a tad frustrated - no doubt like a few others here ;-) I warmly remember the days when I could read newsprint without glasses ;-) As it's Friday night here in the UK I'm going to chill with a nice glass of red and revisit the issue in a day or two. I think maybe my first port of call will be to my local pharmacy to buy some new higher mag specs! Meanwhile - peace to each and all of you guys - it's only a browser ;-)

提出問題者

jscher2000 said

No need to criticize the youth, they're going to support us in our retirement. ;-) I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character. What about using an OLD version of the add-on from the Firefox 52 days, such as: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1 Then you can set the extension not to auto-update here:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return
In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one. Can you get it back to normal?

Forgive me - I wasn't criticising youth - just suggesting an explanation for the tiny font ;-) As for there being a problem with my system font - my other laptop, which is running a completely different OS has just updated to the latest version of FireFox and is exhibiting exactly the same, tiny font issue. As a luddite, I understood the problem has arisen not from TS&TC but from the latest FireFox update?

''jscher2000 [[#answer-1032770|said]]'' <blockquote> No need to criticize the youth, they're going to support us in our retirement. ;-) I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character. What about using an OLD version of the add-on from the Firefox 52 days, such as: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1 Then you can set the extension not to auto-update here: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one. Can you get it back to normal? </blockquote> Forgive me - I wasn't criticising youth - just suggesting an explanation for the tiny font ;-) As for there being a problem with my system font - my other laptop, which is running a completely different OS has just updated to the latest version of FireFox and is exhibiting exactly the same, tiny font issue. As a luddite, I understood the problem has arisen not from TS&TC but from the latest ''FireFox'' update?
jscher2000
  • Top 10 Contributor
8695 個解決方法 71071 個答案

Hi loftboy, Theme Font Size Changer has reduced functionality to what it can do in Firefox 57, and that is leaving you looking at the font Firefox is picking up from your OS. Since you run the Extended Support Release of Firefox 52 you can roll back Theme Font Size Changer to a version that worked for you before.

Hi loftboy, Theme Font Size Changer has reduced functionality to what it can do in Firefox 57, and that is leaving you looking at the font Firefox is picking up from your OS. Since you run the Extended Support Release of Firefox 52 you can roll back Theme Font Size Changer to a version that worked for you before.

由 jscher2000 於 修改

提出問題者

Aha !! - So how do I do that - exactly ?

Aha !! - So how do I do that - exactly ?
jscher2000
  • Top 10 Contributor
8695 個解決方法 71071 個答案

loftboy said

Aha !! - So how do I do that - exactly ?

https://support.mozilla.org/questions/1185462#answer-1032770

''loftboy [[#answer-1033044|said]]'' <blockquote> Aha !! - So how do I do that - exactly ? </blockquote> https://support.mozilla.org/questions/1185462#answer-1032770

提出問題者

jscher2000 said

No need to criticize the youth, they're going to support us in our retirement. ;-) I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character. What about using an OLD version of the add-on from the Firefox 52 days, such as: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1 Then you can set the extension not to auto-update here:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return
In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one. Can you get it back to normal?

The problem stems from the fact that Mozilla has changed the browsers structure so that none of the previous versions of Theme Font & Size Changer will work! So it's simply impossible to use previous versions of Theme Font & Size Changer! On my other machine, which has updated to FF57, there is a "Themes" option which I've used to good effect, but sadly this is missing from my machine which has FF ESR on it. I've resigned myself to the fact I'll have to buy some new reading glasses and hope that the TF&SC developers come up with a new version that is compatible with the latest FF releases.

''jscher2000 [[#answer-1032770|said]]'' <blockquote> No need to criticize the youth, they're going to support us in our retirement. ;-) I think there is an issue with your system font, which is what Firefox uses in the toolbar area. I'm pretty sure the vertical bar is supposed to be ... but the current font may not support the combined ... character. What about using an OLD version of the add-on from the Firefox 52 days, such as: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/?page=1#version-52.1 Then you can set the extension not to auto-update here: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then find Theme Font & Size Changer on the right side and click either its Options button or its More link. That should take you to a page where you can scroll down and turn off auto-updates. To change versions, you can use the above Versions page link to try a different one. Can you get it back to normal? </blockquote> The problem stems from the fact that Mozilla has changed the browsers structure so that ''none'' of the previous versions of Theme Font & Size Changer will work! So it's simply impossible to use previous versions of Theme Font & Size Changer! On my other machine, which has updated to FF57, there is a "Themes" option which I've used to good effect, but sadly this is missing from my machine which has FF ESR on it. I've resigned myself to the fact I'll have to buy some new reading glasses and hope that the TF&SC developers come up with a new version that is compatible with the latest FF releases.