搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Text in address bar gets highlighted when switching languages

  • 2 回覆
  • 3 有這個問題
  • 3 次檢視
  • 最近回覆由 YoniV

more options

When I switch languages in the address bar, the text gets highlighted automatically, so when I continue typing it deletes what was previously there. I'm using Linux (Solus Budgie), and it didn't use to behave like that when I used Windows. But even though it changed when I switched to Linux, I don't think it is related directly to the OS, but rather the default flag settings or something like that. I suspect that, because I also needed to change some other settings such as restoring the middle-wheel scrolling functionality and making the address bar auto-highlight text when I first click the address bar (rather than double-clicking it).

This one's really annoying. I can't get used to it, so I keep messing up my searches. Is there a way to change this behaviour? Something in "about:config" for example?

Thanks

所有回覆 (2)

more options

What shortcut key or other way are you using to switch the language?


There are browser.urlbar.*select prefs that you can check on the about:config page.

more options

I'm using Alt+Shift. Which setting are you refering to? When I search for browser.urlbar.*select I get only the two that are responsible for a) auto-highlighting when first clicked ("...clickSelectAll"); and b) highlighting when double-clicking ("...doubleClickSelectAll"). The former is set to "true" and the latter to "false".

由 YoniV 於 修改