搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

about:blank doesn't work anymore - how to blank screen?

more options

I have my home page set to about:blank. For many years, it worked. To blank my browser screen, I could hit the Home icon and it would blank my screen. Since a recent update (about 2 or 3 updates ago), this stopped working. Now, when I hit the Home button, the URL gets cleared but whatever was being displayed remains. Entering about:blank at the URL line doesn't work either.

I have my home page set to about:blank. For many years, it worked. To blank my browser screen, I could hit the Home icon and it would blank my screen. Since a recent update (about 2 or 3 updates ago), this stopped working. Now, when I hit the Home button, the URL gets cleared but whatever was being displayed remains. Entering about:blank at the URL line doesn't work either.

被選擇的解決方法

The developer of uBlock Origin is regularly updating: https://addons.mozilla.org/firefox/addon/ublock-origin/

從原來的回覆中察看解決方案 👍 3

所有回覆 (9)

more options

In the 3-bar menu (or 'Tools') => General => under 'Startup' => When Firefox starts : did you choose 'Show a blank page'  ?


Separate issue : Your system details show two versions of Shockwave Flash, which can cause major problems. So, please uninstall them .

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Then re-install the latest version, which is 27.0.0.130

You can download te latest version from here : https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.

more options

Hi Enigma.

I do have the setting you asked about. I also uninstalled and reinstalled flashplayer. The problem persists.

As I said before, the issue began immediately after firefox updated a time or two ago.

Does this work on your system?

more options

If it open a new tab (Ctrl+t) and type about:blank and press Enter, I get a totally blank page.

If I change my home page address to about:blank and then use Alt+Home that also works.

Could it be a problem (incompatibility) with one of your extensions? A common way to check that is to test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Diagnose Firefox issues using Troubleshoot Mode)

more options

Thanks for you and Enigma for helping me out here.

In Safe Mode it works properly. It appears to be AdBlocker Ultimate causing this.

I will switch to another one.

more options

選擇的解決方法

The developer of uBlock Origin is regularly updating: https://addons.mozilla.org/firefox/addon/ublock-origin/

more options

I had the same problem, about:blank set as my homepage but Firefox would not go there. I disabled Adblock Plus and it instantly began working again.

more options

FYI, this problem apparently is limited to Firefox 55-56. It has not been reported in Firefox 57, due out this coming week in the big Quantum update.

more options

I had this issue too in Firefox 57, where the about:blank page contains information on it.

I looked at the settings in Options > General > Startup under "When Firefox Starts", and it shows that I have selected the radio button next to "Show a blank page".

However, when Firefox opens about:blank, I notice that there is now a cog wheel (same icon as the Support menu) in the upper right hand corner. This allows you to customize the tab.

By default, it now looks like Firefox adds the following features to the about:blank page:

- Search - Top Sites - Recommended by Pocket - Highlights - Snippets

Unchecking each of these boxes in the Options tab removes them completely, and you get a correct view of what 'about:blank' should be (emphasis on the word BLANK)

Thanks, Stephen

more options

Hi Stephen, it could be that the blank page setting does not work the way it used to because when Firefox uses the Activity Stream layout for the new tab page, it will also use that layout on the built-in home page. There is a setting to uncouple the two pages, but it's a little harder to access:

To remove the "Activity Stream" design from the home page and return to the previous behavior:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste newt and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.aboutHome.enabled preference to switch the value from true to false