X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox doesn't recognize my ssl. It did previously?

已張貼

I installed an SSL certificate on my website. Firefox recognized it previously and all was well. Now it says my site is not secure in the upper address bar, and it also doesn't play the sites music?...Ran Malwarebytes....nothing....ran security essentials.....nothing....any ideas?

I installed an SSL certificate on my website. Firefox recognized it previously and all was well. Now it says my site is not secure in the upper address bar, and it also doesn't play the sites music?...Ran Malwarebytes....nothing....ran security essentials.....nothing....any ideas?

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 27.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157316 個答案

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

You can check the server.

What does it say if you click the Control Center 'i' icon?

It is possible that there is insecure content loaded via an open HTTP connection.

You can check the Web Console (Tools -> Web Developer) for messages about the presence of mixed or unsafe content.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? You can check the server. *https://www.ssllabs.com/ssltest/ What does it say if you click the Control Center 'i' icon? It is possible that there is insecure content loaded via an open HTTP connection. You can check the Web Console (Tools -> Web Developer) for messages about the presence of mixed or unsafe content. *https://developer.mozilla.org/en/Tools/Web_Console

提出問題者

Using the ssl test....it scores an A-......the site previously showed it as secure and everything was fine last week with Firefox....I check it on another computer....it shows as secure......so the certificate is just fine.....it's just Firefox on MY computer showing it as not secure.

Using the ssl test....it scores an A-......the site previously showed it as secure and everything was fine last week with Firefox....I check it on another computer....it shows as secure......so the certificate is just fine.....it's just Firefox on MY computer showing it as not secure.
jscher2000
  • Top 10 Contributor
8635 個解決方法 70627 個答案

Photo10758 said

I installed an SSL certificate on my website. Firefox recognized it previously and all was well. Now it says my site is not secure in the upper address bar, and it also doesn't play the sites music?

Do you mean there is a warning on the padlock? If you click that to show the drop-panel, is there any additional information?

''Photo10758 [[#question-1176416|said]]'' <blockquote> I installed an SSL certificate on my website. Firefox recognized it previously and all was well. Now it says my site is not secure '''in the upper address bar''', and it also doesn't play the sites music? </blockquote> Do you mean there is a warning on the padlock? If you click that to show the drop-panel, is there any additional information?

提出問題者

no...the padlock is grey with a red line thru it....if you click on the "i" with the circle around it....it simply states that the site is not secure. I have attached a snippet of what it shows. Let me say again....last week, Firefox showed it as secure....and on ANY other computer....using Firefox....it shows as secure.......also I solved the music problem.....so now it's just this.

no...the padlock is grey with a red line thru it....if you click on the "i" with the circle around it....it simply states that the site is not secure. I have attached a snippet of what it shows. Let me say again....last week, Firefox showed it as secure....and on ANY other computer....using Firefox....it shows as secure.......also I solved the music problem.....so now it's just this.

由 Photo10758 於 修改

jscher2000
  • Top 10 Contributor
8635 個解決方法 70627 個答案

In your screenshot, there isn't an https:// at the beginning of the address. Firefox hides http:// but it never hides https:// so try adding that yourself and see whether it works.

In your screenshot, there isn't an https:// at the beginning of the address. Firefox hides http:// but it never hides https:// so try adding that yourself and see whether it works.
cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157316 個答案

Using the secure version with HTTPS should work.

I tested it and the website loads without problems to the secure version.

You may need to clear cache and cookies or use "Forget About This Site" (last resort) if you keep having issues.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Using the secure version with HTTPS should work. *https://highlandphotostudio.com I tested it and the website loads without problems to the secure version. You may need to clear cache and cookies or use "Forget About This Site" (last resort) if you keep having issues. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

提出問題者

As stated previously....it shows secure for me on other computers using Firefox as well....just on my main computer it doesn't show as secure.....I've deleted history/cache and also forgot the site....still the same problem....once again....last week, it showed as secure....now it doesn't....rather frustrating.....

As stated previously....it shows secure for me on other computers using Firefox as well....just on my main computer it doesn't show as secure.....I've deleted history/cache and also forgot the site....still the same problem....once again....last week, it showed as secure....now it doesn't....rather frustrating.....
jscher2000
  • Top 10 Contributor
8635 個解決方法 70627 個答案

Photo10758 said

As stated previously....it shows secure for me on other computers using Firefox as well....just on my main computer it doesn't show as secure.

Even if you add https to the address? As pointed out before, your previous screenshot used an insecure http address (see attached).

''Photo10758 [[#answer-1009418|said]]'' <blockquote> As stated previously....it shows secure for me on other computers using Firefox as well....just on my main computer it doesn't show as secure. </blockquote> Even if you add https to the address? As pointed out before, your previous screenshot used an insecure http address (see attached).

提出問題者

that IS quite strange!....yes...if I put in the https:// it shows as secure.....have no idea what/why it changed from last week....when ever before I just typed in www.highlandphotostudio.com it would go right to the secure site.....doesn't make much sense to me!

that IS quite strange!....yes...if I put in the https:// it shows as secure.....have no idea what/why it changed from last week....when ever before I just typed in www.highlandphotostudio.com it would go right to the secure site.....doesn't make much sense to me!
jscher2000
  • Top 10 Contributor
8635 個解決方法 70627 個答案

Usually you need to set up a special rule on your site to redirect from http to https. Perhaps you had that before but it got turned off for some reason?

I can't tell what platform you're using for the site, but if it's a service, I'd check with them on whether it's a feature of the platform, and if it's a template, I'd check with the template vendor on whether it's a variable you need to set. Otherwise, it might be in the web hosting control panel, or you may need to create an .htaccess file.

Usually you need to set up a special rule on your site to redirect from http to https. Perhaps you had that before but it got turned off for some reason? I can't tell what platform you're using for the site, but if it's a service, I'd check with them on whether it's a feature of the platform, and if it's a template, I'd check with the template vendor on whether it's a variable you need to set. Otherwise, it might be in the web hosting control panel, or you may need to create an .htaccess file.
jscher2000
  • Top 10 Contributor
8635 個解決方法 70627 個答案

One other thought:

When you go into the administrative area of some websites, the server sends Firefox an HTTP Strict Transport Security (HSTS) header instructing Firefox to always used HTTPS in the future. That is saved in a file in your current profile, and Firefox doesn't limit it to the administrative area; it applies it to all pages on the server. If you were to delete that file manually (unlikely) or use Firefox's Refresh feature, then those instructions would be lost and Firefox would no longer take it on itself to switch from HTTP to HTTPS.

Ordinary (non-admin) visitors would not get this instruction. Therefore, to give all users a secure experience, it's best to figure out how to redirect them on their first visit to a page on your platform.

One other thought: When you go into the administrative area of some websites, the server sends Firefox an HTTP Strict Transport Security (HSTS) header instructing Firefox to always used HTTPS in the future. That is saved in a file in your current profile, and Firefox doesn't limit it to the administrative area; it applies it to all pages on the server. If you were to delete that file manually (unlikely) or use Firefox's Refresh feature, then those instructions would be lost and Firefox would no longer take it on itself to switch from HTTP to HTTPS. Ordinary (non-admin) visitors would not get this instruction. Therefore, to give all users a secure experience, it's best to figure out how to redirect them on their first visit to a page on your platform.