搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I am having trouble loading page that contains audio tags

  • 9 回覆
  • 5 有這個問題
  • 159 次檢視
  • 最近回覆由 FredMcD

more options

When I try to load the following page in Firefox, I get the message “A web page is slowing down your browser. What would you like to do?”

http://www.bruceblinn.com/photography/Villages/Birds/index.html

This page loads fine in IE and Chrome, and it used to load fine in Firefox about 6 months ago.

It appears that the page is loading, but very slowly. This page contains several HTML audio tags. If I remove the audio tags, the page loads fine in Firefox, so I believe they are the cause of the slow loading. If I interrupt it while loading, a few of the audio controls may be visible, but they are very wide and the play and pause buttons take a very long time to respond.

I tried clearing cookies and cache. I tried restarting in safe mode. I tried refreshing Firefox settings.

I am using Firefox 55.0.3 (32-bit) on Windows 10 version 1703

被選擇的解決方法

I see this issue only with Firefox 55. Firefox 54 and Firefox 56 (beta) and later load the website without any problems. Like you assume it looks that Firefox 55 has a problem with the audio tags and seems to spend a lot of time trying to adjust the audio player controls and doesn't make any progress because of this. The audio player bar shows as a very wide bar when I load the and collapses to zero when I stop the script.

  • view-source:chrome://global/content/bindings/videocontrols.xml

Try to remove the padding of the audio tag as set via birds.css. That seems to be working for me.

audio {
	background-color: rgb(122,177,224);	/* Light blue */
	border:	1px solid rgb(0,0,120);
	/* padding: 2px; */ /* disable padding*/
}

See also:

  • bug 1391791 - Audio (controls) element blows up in width if a padding is set

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

從原來的回覆中察看解決方案 👍 1

所有回覆 (9)

more options

Nice web site.

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

more options

I tried removing all the JavaScript from the web page, but I still get the message and it still takes forever to load.

I still think there is something wrong with the audio control because when I stop the page from loading, only a few of the audio controls are displayed and they do not look right or work correctly.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

I tried safe mode but that did not help.

more options

選擇的解決方法

I see this issue only with Firefox 55. Firefox 54 and Firefox 56 (beta) and later load the website without any problems. Like you assume it looks that Firefox 55 has a problem with the audio tags and seems to spend a lot of time trying to adjust the audio player controls and doesn't make any progress because of this. The audio player bar shows as a very wide bar when I load the and collapses to zero when I stop the script.

  • view-source:chrome://global/content/bindings/videocontrols.xml

Try to remove the padding of the audio tag as set via birds.css. That seems to be working for me.

audio {
	background-color: rgb(122,177,224);	/* Light blue */
	border:	1px solid rgb(0,0,120);
	/* padding: 2px; */ /* disable padding*/
}

See also:

  • bug 1391791 - Audio (controls) element blows up in width if a padding is set

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

由 cor-el 於 修改

more options

That worked great. Thank you so much!

由 bblinn 於 修改

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

I'm facing this issue on Firefox 52 ESR and on Firefox 56, but only on Windows. On Mac, any Firefox version opens up my page smoothly and everything works fine. My webpage has a lot of Audio tags embedded inside table cells (refer screenshot).

As suggested by cor-el, I checked if there's any padding on the Audio element but there was none. However the parent <td> had some padding. I removed it but no luck.

more options

mehtajp22 Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.