搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed

  • 11 回覆
  • 25 有這個問題
  • 1721 次檢視
  • 最近回覆由 RedSilverfish

more options

I'm still getting the "Secure Connection Failed" error on various sites.

Only in Firefox. Internet Explorer and Chrome both load the sites correctly.

Tried to connect to https://www.ghacks.net/2016/12/19/remove-g-button-android-keyboard/

  An error occurred during a connection to www.pcmag.com. Peer received a valid certificate, but access was denied. Error code: SSL_ERROR_ACCESS_DENIED_ALERT
  The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
  Please contact the website owners to inform them of this problem.

Restarting in safe mode does not fix the problem.

Changing security.tls.version.max and security.tls.version.min to 0 and restarting does not solve the problem.

Trying with a new profile with no extensions or other changes from the default had no effect.

Firefox 56.0b7 (64-bit) for Windows.

所有回覆 (11)

more options
more options

I've tried the suggestions in those articles with no effect.

I've got no security software that I know of intercepting the secure connections, and again, the site loads properly with IE and Chrome.

more options

Try this link; https://www.pcmag.com/

more options

The problem with the pcmag site was effecting all browsers and all PC's at my location. It was caused by our internal internet gateway.

That is not the case with the current issue. Other browsers on the same PC can access the site properly, just not under FireFox.

more options

You may have corrupt cert8.db file. cert8.db stores all your security certificate settings

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

You can click the "Advanced" button to expand this section and show extra details. You can click the blue error message to expand this section. If the certificate is not trusted (SEC_ERROR_UNKNOWN_ISSUER) then click "Copy text to clipboard" and paste the base64 encoded certificate chain text in a reply. That will allow us to check details like the issuer of the certificate.

more options

I created a new, empty profile so there is no cert8.db file.

I do not have an "Advanced" button, just a "Try Again" button.

See attached screenshot.

由 PeterSteinberg 於 修改

more options
more options

This is basically the same answer you posted on 1-Sep which did not work.

more options

What security software do you have?

A Google search comes up with issues related to ESET.


Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

I'm using Firefox Nightly 58.0.1 and it works perfectly. You can try updating it to the newest version of Firefox (See the screenshot).

Note: You don't have to download Firefox Nightly.

If that doesn't work, also try disabling all your security and anti-virus softwares.