X
點擊此處開啟此網站的行動版。

技術支援討論區

FireFox will not start up

已張貼

Firefox magically stopped working tonight. Based on reading help files and past forum posts, here are things I've tried with no luck:

Note: Running Windows 7

- Rebooted (of course) - Uninstalled through the task manager and reinstalled. - Uninstalled and deleted the C:/Program Files/Mozilla Firefox directory and reinstalled - Once reinstalled, attempted to start in safe mode via holding down Shift while loading - Attempted to start in safe mode by attempting to type many things in the run window:

        Firefox -safe-mode
        Firefox /safe
        "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode

- Attempted to add a new profile by typing in the Run window (after reinstalling):

        "C:\Program Files\Mozilla Firefox\firefox.exe" -P 

None of these solutions have had any results. No matter what I do, no Firefox related windows will come up and I get no error messages of any kind. Most of the time I at least get a busy cursor for a second and a firefox.exe process will start. I've kept the Task Manager open through most of the attempts and killed firefox.exe between all different attempts. Most everything I do will still open a process (I have two of them still running right now) and I kill all of them in between attempts, not to mention shutting down. I even did a hard battery pull on my laptop just to be sure. I'm not making any headway. If I could at least get an error message that would be nice, but I get nothing at all. Any other suggestions?

Firefox magically stopped working tonight. Based on reading help files and past forum posts, here are things I've tried with no luck: Note: Running Windows 7 - Rebooted (of course) - Uninstalled through the task manager and reinstalled. - Uninstalled and deleted the C:/Program Files/Mozilla Firefox directory and reinstalled - Once reinstalled, attempted to start in safe mode via holding down Shift while loading - Attempted to start in safe mode by attempting to type many things in the run window: Firefox -safe-mode Firefox /safe "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode - Attempted to add a new profile by typing in the Run window (after reinstalling): "C:\Program Files\Mozilla Firefox\firefox.exe" -P None of these solutions have had any results. No matter what I do, no Firefox related windows will come up and I get no error messages of any kind. Most of the time I at least get a busy cursor for a second and a firefox.exe process will start. I've kept the Task Manager open through most of the attempts and killed firefox.exe between all different attempts. Most everything I do will still open a process (I have two of them still running right now) and I kill all of them in between attempts, not to mention shutting down. I even did a hard battery pull on my laptop just to be sure. I'm not making any headway. If I could at least get an error message that would be nice, but I get nothing at all. Any other suggestions?

被選擇的解決方法

Nothing whatsoever? What Firefox version were you running?

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

從原來的回覆中察看解決方案 2

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

更多資訊

FredMcD
  • Top 10 Contributor
4308 個解決方法 60487 個答案

選擇的解決方法

Nothing whatsoever? What Firefox version were you running?

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Nothing whatsoever? What Firefox version were you running? [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

提出問題者

You are my hero. I was running 55.0.3 after the reinstall, not sure if that's the version I was on when the problem started, though. Using your link I installed 54.0.1 and it came up perfectly, profile and all. Thank you!

You are my hero. I was running 55.0.3 after the reinstall, not sure if that's the version I was on when the problem started, though. Using your link I installed 54.0.1 and it came up perfectly, profile and all. Thank you!
FredMcD
  • Top 10 Contributor
4308 個解決方法 60487 個答案

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

提出問題者

Snooj said

You are my hero. I was running 55.0.3 after the reinstall, not sure if that's the version I was on when the problem started, though. Using your link I installed 54.0.1 and it came up perfectly, profile and all. Thank you!

Followup note for anyone else that experiences this: Make sure to turn off auto-updates. The next time I tried to load FF, it wouldn't work again. Turns out it updated me back to 55.0.3 in the background and revitalized the problem. One more uninstall and re-running the 54.0.1 installer solved it again for me.

''Snooj [[#answer-1000894|said]]'' <blockquote> You are my hero. I was running 55.0.3 after the reinstall, not sure if that's the version I was on when the problem started, though. Using your link I installed 54.0.1 and it came up perfectly, profile and all. Thank you! </blockquote> Followup note for anyone else that experiences this: Make sure to turn off auto-updates. The next time I tried to load FF, it wouldn't work again. Turns out it updated me back to 55.0.3 in the background and revitalized the problem. One more uninstall and re-running the 54.0.1 installer solved it again for me.
FredMcD
  • Top 10 Contributor
4308 個解決方法 60487 個答案

Well done.

Well done.