X
點擊此處開啟此網站的行動版。

技術支援討論區

the word 'write' appears in my popup

已張貼

On my web page ( http://PSPLFriends.org/Photos_2016.htm ), I have a link to a popup, which is "imported" from a .js file (Photos_popup.js) Click the "Click here" line beneath the row of years in the "Photos from..." box to see the pop-up (I had to disable the Firefox pop-up blocker (Tools) option to display it).

For some reason, Firefox prepends the word 'write' at the top of the popup (see image).

No other functionality is affected, and it displays just fine, otherwise.

Neither Explorer nor Edge do this. I have no other browsers to test it with. My target audience prefers Firefox, but the site was originally designed for Explorer. I did my best to accommodate both, but, obviously, something is different between the two. I never noticed this issue during my tests, although I haven't checked it in years. The code is about 10 years old, and rarely changes. My recent changes were attempted "fixes" for this issue, but which changed absolutely nothing.

Style issues aside (no snarky comments about my stone age code, thank you very much!), ;) can anyone see a reason for this happening and recommend a simple fix?

On my web page ( http://PSPLFriends.org/Photos_2016.htm ), I have a link to a popup, which is "imported" from a .js file (Photos_popup.js) Click the "Click here" line beneath the row of years in the "Photos from..." box to see the pop-up (I had to disable the Firefox pop-up blocker (Tools) option to display it). For some reason, Firefox prepends the word 'write' at the top of the popup (see image). No other functionality is affected, and it displays just fine, otherwise. Neither Explorer nor Edge do this. I have no other browsers to test it with. My target audience prefers Firefox, but the site was originally designed for Explorer. I did my best to accommodate both, but, obviously, something is different between the two. I never noticed this issue during my tests, although I haven't checked it in years. The code is about 10 years old, and rarely changes. My recent changes were attempted "fixes" for this issue, but which changed absolutely nothing. Style issues aside (no snarky comments about my stone age code, thank you very much!), ;) can anyone see a reason for this happening and recommend a simple fix?
附加的畫面擷圖

由 skaizun 於 修改

被選擇的解決方法

Hmm, I don't see "write" when I click the very tiny link at the bottom of the Photos box on your page.

In your screenshot, I see Adblock Plus. As a quick test of whether one of your extensions is causing this issue, could you test the page in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)


You also might view the source of the popup (Ctrl+u) to see whether any tags surround write or there are any other clues about its reason for being.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 26.0 r0

應用程式

  • Firefox 54.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/54.0.1/WINNT/en-US/

擴充套件

  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Ebates: The Free Cash Back Shopping Assistant 4.17.0.0 ({35d6291e-1d4b-f9b4-c52f-77e6410d1326})
  • Firefox Screenshots 6.6.0 (screenshots@mozilla.org)
  • Flash Control 2.1.4 (jid1-sNL73VCI4UB0Fw@jetpack)
  • LinkChecker 0.6.7.1-signed.1-signed ({49f3fc85-dcfe-4e42-9301-226ebe658509})
  • McAfee WebAdvisor 5.0.559.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Multi-process staged rollout 1.50 (e10srollout@mozilla.org)
  • NewScrollbars (aka NoiaScrollbars) 1.2.8 (NoiaScrollbars@ArisT2_Noia4dev)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Popup Blocker (strict) 0.3.3 ({de22fd49-c9ab-4359-b722-b3febdc3a0b0})
  • Print Edit 18.3 (printedit@DW-dev)
  • Strict Pop-up Blocker 0.2.1-signed.1-signed (jid1-P34HaABBBpOerQ@jetpack)
  • uBlock Origin 1.13.8 (uBlock0@raymondhill.net)
  • Web Compat 1.1 (webcompat@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD Radeon R5
  • adapterDescription2:
  • adapterDeviceID: 0x9851
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 06bf1028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.413
  • driverDate: 8-6-2015
  • driverDate2:
  • driverVersion: 15.201.1101.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'description': u'Direct2D', u'name': u'DIRECT2D'}, {u'status': u'disabled', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'default'}], u'description': u'GPU Process', u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'description': u'WebRender', u'name': u'WEBRENDER'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic MOZ_debug_get OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl1Renderer: Google Inc. -- ANGLE (AMD Radeon R5 Direct3D9Ex vs_3_0 ps_3_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.2a250c8a0e15)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000beda) EGL_VERSION: 1.4 (ANGLE 2.1.0.2a250c8a0e15) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4269 個解決方法 59875 個答案

有幫助的回覆

Correct link is; http://psplfriends.org/Photos_2016.htm

How/where do you open that window?

Correct link is; http://psplfriends.org/Photos_2016.htm How/where do you open that window?
jscher2000
  • Top 10 Contributor
8792 個解決方法 71910 個答案

選擇的解決方法

Hmm, I don't see "write" when I click the very tiny link at the bottom of the Photos box on your page.

In your screenshot, I see Adblock Plus. As a quick test of whether one of your extensions is causing this issue, could you test the page in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)


You also might view the source of the popup (Ctrl+u) to see whether any tags surround write or there are any other clues about its reason for being.

Hmm, I don't see "write" when I click the very tiny link at the bottom of the Photos box on your page. In your screenshot, I see Adblock Plus. As a quick test of whether one of your extensions is causing this issue, could you test the page in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]]) ---- You also might view the source of the popup (Ctrl+u) to see whether any tags surround write or there are any other clues about its reason for being.

提出問題者

Jscherr2000: When I restarted in "Safe Mode," I was stunned to see that the word "write" had disappeared! When I restarted in "full" mode, it was also gone! I rebooted my computer, and it's still gone!!! The only thing I can think of is either Firefox didn't refresh my fixed versions (i.e., it kept using the original script and photo page), or, you are correct in that the add-ons affected it in some way. But, if the latter case is true, then why didn't it recur when I restarted Firefox? So, the former must be the case. I appreciate the help, though! I never would have figured it out, otherwise! (I knew how to run in Safe Mode, but, couldn't conceive of that being an issue; I still don't believe it, AdBlock notwithstanding). Thanks, though! :)

''Jscherr2000:'' When I restarted in "Safe Mode," I was stunned to see that the word "write" had disappeared! When I restarted in "full" mode, it was also gone! I rebooted my computer, and it's still gone!!! The only thing I can think of is either Firefox didn't refresh my fixed versions (i.e., it kept using the original script and photo page), or, you are correct in that the add-ons affected it in some way. But, if the latter case is true, then why didn't it recur when I restarted Firefox? So, the former must be the case. I appreciate the help, though! I never would have figured it out, otherwise! (I knew how to run in Safe Mode, but, couldn't conceive of that being an issue; I still don't believe it, AdBlock notwithstanding). Thanks, though! :)

由 skaizun 於 修改

提出問題者

''FredMcD said

Correct link is; http://psplfriends.org/Photos_2016.htm How/where do you open that window?

There was nothing wrong with the link, itself; domain name capitalizations rarely matter. It was the close-parenthese that caused the issue, by appending itself onto that page's URL (i.e., not the pop-up link). Normally, I put a space after the open-parenthese and before the close-parenthese to avoid such issues, but, in this case, I simply forgot to do so! I fixed the original message, accordingly, so, the problem you mentioned is no more!

As for "how/where do you open that window," I added that info to the original message. Silly of me to forget to mention it, but, I just assumed that folks would see the "click here..." line in the "years" box at the top-center of the page, and figure that was it!

Thanks for pointing out these issues! :)

''''FredMcD [[#answer-1000513|said]]'' <blockquote> Correct link is; http://psplfriends.org/Photos_2016.htm How/where do you open that window? </blockquote> '' There was nothing wrong with the link, itself; domain name capitalizations rarely matter. It was the close-parenthese that caused the issue, by appending itself onto that page's URL (i.e., not the pop-up link). Normally, I put a space after the open-parenthese and before the close-parenthese to avoid such issues, but, in this case, I simply forgot to do so! I fixed the original message, accordingly, so, the problem you mentioned is no more! As for "how/where do you open that window," I added that info to the original message. Silly of me to forget to mention it, but, I just assumed that folks would see the "click here..." line in the "years" box at the top-center of the page, and figure that was it! Thanks for pointing out these issues! :)

由 skaizun 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17578 個解決方法 158993 個答案

Note that you can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Note that you can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac)

提出問題者

cor-el: Thanks for the info. I didn't know about the bypass-cache trick, but, I wouldn't have thought that was the problem, per the above responses.

P.S. How's your cousin, Kal-el, doing? ;)

cor-el: Thanks for the info. I didn't know about the bypass-cache trick, but, I wouldn't have thought that was the problem, per the above responses. P.S. How's your cousin, Kal-el, doing? ;)