搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My website has been slow since Vr. 52

  • 13 回覆
  • 1 有這個問題
  • 45 次檢視
  • 最近回覆由 philipp

more options

I've been building a website for the last 5 month for myself and it's quite intensive in code, especially with SVG animations and such.

I started coding in December of last year, and was using firefox as my base browser and everything was going smoothly. Until however March 13th when V52 of Firefox was released and my browser updated automatically. The site became extremely sluggish (Still functional) but nothing would animate on time. On average there would be 15-20 seconds delays on functions running.

I've had to switch to Chrome to continue my development of the website, but I am still determined to understand why my site no longer works in Firefox. I downloaded Firefox Version 51.0.1 to make sure the site works, and it runs smooth and as it suppose to.

Is it possible to send a link to one of your team developers to look into this further?

I would appreciate any help I can get.

所有回覆 (13)

more options

This may be your problem,

Firefox v52+ disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

Hi FredMcd,

I am however not using any of those plugins you've listed above.

Only JS, HTML, CSS. Pure code.

more options

vridaw said in a private message

Hey FredMcD,

As you've just answered my post, I thought I'd share the website so you can see the problem first hand.

You can load the above link in Chrome or Firefox 51 to see it functioning properly, and then please open it in the latest FF to see the problem.

Any insight is greatly appreciated.

Cheers

由 FredMcD 於 修改

more options

Please make all replies here. This could help others, and lets others give their own responses.


I opened the link. That I saw was a 'clear' area bouncing around while dots connected by lines moved around. Nothing was seen outside the 'clear' area.

more options

Please refresh, I apologize.

more options

Any insight on what changed from V 51 to V52 might help me diagnose this problem.

Again, the site works 100% perfectly in FF 51.

more options

hi, unfortunately there are thousands of code changes between firefox versions so it's not feasible to guess what's at the root here. is it a site that's publicly available and that you can share the link for?

more options

Hi Phil,

Yes you can view the website here.

Please note if it doesn't load on the first try, refresh the page and it should put you through.

Appreciate the help.

more options

It was slow on my initial test, but after I restarted Firefox, it ran normally vs. Chrome. Possibly a memory use issue on 32-bit Firefox?

cor-el has mentioned a change in the graphics rendering engine in Firefox 52 that could be relevant. I'll copy/paste since I haven't researched this myself:

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering.

To try switching back:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste skia and pause while the list is filtered

(3) Double-click the gfx.canvas.azure.backends preference and reverse the order of the last two words, in other words:

FROM: direct2d1.1,skia,cairo

TO: direct2d1.1,cairo,skia

(4) Repeat with gfx.content.azure.backends

(5) Exit Firefox and start it up again to effectuate the change

Does that make any difference on yours?

more options

My current version of FF is 53 and the value of "gfx.canvas.azure" is "direct2d1.1,cairo" It does not have skia by default.

I did go ahead and test the switching the order for "gfx.content" and came up with negative results. Still the same result (Animations sluggish, not running on time)

Thanks for your reply jscher2000.

more options

vridaw said

My current version of FF is 53 and the value of "gfx.canvas.azure" is "direct2d1.1,cairo" It does not have skia by default.

That's strange, I don't know why that would be.

Anyway, perhaps it's a new Firefox-Nvidia incompatibility. I can't test that myself.

more options

I don't know if this means anything;

I was watching the 'show' when I decided to restart Firefox. I use Restart https://addons.mozilla.org/en-US/firefox/addon/re-start/

The computer locked up. I had to do a hard reboot. No error messages or crash report.

more options

i also had a look at the site (nice work btw) but didn't notice any obvious slowdowns after firefox 52 - maybe i'm missing something obvious because i don't have the eyes of a designer or the problem is dependant on some sort of config/system environment.

can you test if the same slowdown is reproducible in a new profile as well?: Profile Manager - Create, remove, or switch Firefox profiles

if yes, then using the mozregression tool from http://mozilla.github.io/mozregression/install.html is one way that could help you narrowing down the range of the regression. it will download and open various nightly development builds and ask you to judge if it was good or bad - until it finds the exact "pushlog" containing the code change(s) triggering the regression. equipped with that information you could then file a bug for this problem at bugzilla.mozilla.org.

please don't hesitate to ask if anything is unclear during the procedure