搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Streetview freezes FF53 for 3 sec., troubleshooting doesn't help, except Safe mode

  • 8 回覆
  • 2 有這個問題
  • 21 次檢視
  • 最近回覆由 omotrl

more options

All extensions disabled, hardware acceleration turned off, default theme is used, yet when I turn on streetview (by Yandex), Firefox freezes for about 3 seconds as soon as a blurred streetview image appears. The freeze doesn't happen only in Safe Mode. What can be causing it?

被選擇的解決方法

Would you give this a try please :

3-bar menu => Options => Advanced => General tab :

Under 'Browsing' :   uncheck   'Use hardware acceleration when available'.

If that doesn't make a difference, would you take a look at this article :

Upgrade your graphics drivers to use hardware acceleration and WebGL

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

You can try to create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks for advice. I just clean-installed Firefox, having deleted the Application folder data and profiles folder, and checked for the problem without instaling any add-ons or changing any settings. The problem persists. Again the Safe mode is the only remedy.

more options

選擇的解決方法

Would you give this a try please :

3-bar menu => Options => Advanced => General tab :

Under 'Browsing' :   uncheck   'Use hardware acceleration when available'.

If that doesn't make a difference, would you take a look at this article :

Upgrade your graphics drivers to use hardware acceleration and WebGL

more options

Indeed I forgot to disable hardware acceleration in the newly installed Firefox. When I did that, it solved the problem. For some reason, though, I decided to clean-reinstall Firefox again. This time disabling hardware acceleration didn't help by itself, but when I also disabled WebGL it worked. Weird. Thank you for your help!

more options

omotrl said

Thank you for your help!

My pleasure,   and :   well done   !

more options

Just a short note about your extensions list.

I see in your extensions list that you have Go Parent Folder 2.9.1.1 and Show Parent Folder 2.1.1. Alice has withdrawn all her extensions, so I would advice to backup any extensions you have from Alice so you can reinstall them in case you need to refresh Firefox.


This could be a problem with the JavaScript JIT compiler since you already have disabled hardware acceleration and your extensions.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no lightweight theme)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options/Preferences -> Advanced -> General)
  • plugins are not affected
  • preferences are not affected
more options

So how is JavaScript JIT compiler disabled, by disabling WebGL?