X
點擊此處開啟此網站的行動版。

技術支援討論區

Drop Down Menus Don't Stay Open...

已張貼

After the most recent Firefox update, the drop down menus on web pages will not stay open. They close instantly, which makes it difficult to choose my selections. I do have some add-ons, but everything was working before the last update. If anyone know what may be causing this, your input will be greatly appreciated. Thanks in advance.

After the most recent Firefox update, the drop down menus on web pages will not stay open. They close instantly, which makes it difficult to choose my selections. I do have some add-ons, but everything was working before the last update. If anyone know what may be causing this, your input will be greatly appreciated. Thanks in advance.

被選擇的解決方法

The menus that were not working are the ones you have to click on. The hover type work fine. I decided to go ahead and try a USB mouse. The problem was not there. So, I removed my regular mouse from the system (deleted it), then paired it again.

So far it is working properly. I hate problems like this that make absolutely no sense. Thanks for all the input.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 26.0 d0

應用程式

  • Firefox 53.0.3
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/53.0.3/Darwin/en-US/

擴充套件

  • Adblock Plus 2.8.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Classic Theme Restorer 1.6.6 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Download YouTube Videos as MP4 1.8.10 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • Element Hiding Helper for Adblock Plus 1.4 (elemhidehelper@adblockplus.org)
  • F.B Purity - Cleans up Facebook (WX) 19.0.1 (fbpElectroWebExt@fbpurity.com)
  • Google Analytics Opt-out Add-on (by Google) 1.0.7 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • New Tab Override (browser.newtab.url replacement) 6.0.1 (newtaboverride@agenedia.com)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Video DownloadHelper 6.3.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Flashblock 1.5.20 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x9440
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • crashGuards: []
  • currentAudioBackend: audiounit
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'TileHeight': 512, u'TileWidth': 512, u'AzureFallbackCanvasBackend': u'none', u'ApzWheelInput': 1, u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webgl2Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2 * Exhausted GL driver options.
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 4870 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4272 個解決方法 59920 個答案

有幫助的回覆

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

提出問題者

The problem persists in Safe Mode.

The problem persists in Safe Mode.
FredMcD
  • Top 10 Contributor
4272 個解決方法 59920 個答案

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ '''Do Not''' remove the profiles folder. Look for, and rename any '''Mozilla''' or '''Firefox''' program folders by adding .old to them. Do not rename the '''Mozilla Thunderbird''' folder if there is one. After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
cor-el
  • Top 10 Contributor
  • Moderator
17584 個解決方法 159079 個答案

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

I created a new profile and the problem persists.

I created a new profile and the problem persists.
Happy112 561 個解決方法 5694 個答案

Hi   !
Let's give this a try :
3-bar menu => Options => Advanced => General tab Under   'Browsing' Uncheck :   'Use hardware acceleration when available'

Ant difference   ?

Hi &nbsp; !<BR> Let's give this a try :<BR> 3-bar menu => Options => Advanced => General tab Under &nbsp; 'Browsing' '''Un'''check : &nbsp; 'Use hardware acceleration when available' Ant difference &nbsp; ?

提出問題者

Use hardware acceleration unchecked - problem still persists.

Use hardware acceleration unchecked - problem still persists.
Happy112 561 個解決方法 5694 個答案

Stab in the dark,   but if you're using a mouse : Check it's settings or :   unplug it, wait a while and plug it back in. (or try a different mouse)

Stab in the dark, &nbsp; but if you're using a mouse : Check it's settings or : &nbsp; unplug it, wait a while and plug it back in. (or try a different mouse)

提出問題者

I doubt my mouse is causing the problem. Nothing changed on my system, except for the Firefox update. My mouse is bluetooth and runs off the internal bluetooth system.

I doubt my mouse is causing the problem. Nothing changed on my system, except for the Firefox update. My mouse is bluetooth and runs off the internal bluetooth system.
Happy112 561 個解決方法 5694 個答案

You haven't mentioned trying FredMcD's suggestions   ......  (?)


As a last resort,   but   last   resort only :

Refresh Firefox - reset add-ons and settings

You haven't mentioned trying FredMcD's suggestions &nbsp; ...... &nbsp;(?) ----------------------------------------------------------------------------------------------------------- As a last resort, &nbsp; but &nbsp; ''last'' &nbsp; resort only : [https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refresh Firefox - reset add-ons and settings]
Happy112 561 個解決方法 5694 個答案

Are you using Adobe Flash Player 26 Beta version   ?

Your system details show :   'Shockwave Flash 26.0 d0 '

Are you using Adobe Flash Player 26 Beta version &nbsp; ? Your system details show : &nbsp; 'Shockwave Flash 26.0 d0 '

提出問題者

I am not running the beta version of Flash. I only use the current release versions and update them through System Preferences. I have not tried the Refresh Firefox option, as I do not have the time right now to redo all of my add-ons.

I am not running the beta version of Flash. I only use the current release versions and update them through System Preferences. I have not tried the Refresh Firefox option, as I do not have the time right now to redo all of my add-ons.
FredMcD
  • Top 10 Contributor
4272 個解決方法 59920 個答案

Let's remove flash and install the current.

Flash: Grab the uninstaller from here:

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 25.0.0.171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Let's remove flash and install the current. Flash: Grab the uninstaller from here: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac Then reinstall the latest version. '''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' Flash Player '''Version: 25.0.0.171''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> ------------- See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Happy112 561 個解決方法 5694 個答案

WakkoWarner said

I am not running the beta version of Flash. I only use the current release versions and update them through System Preferences. I have not tried the Refresh Firefox option, as I do not have the time right now to redo all of my add-ons.

Do the refresh as a last resort only   -   let's see if installing the regular version of Adobe Flash Player does the trick first. Just curious :   how did you wind up with that Shockwave 26.0 d0   ?

''WakkoWarner [[#answer-971476|said]]'' <blockquote> I am not running the beta version of Flash. I only use the current release versions and update them through System Preferences. I have not tried the Refresh Firefox option, as I do not have the time right now to redo all of my add-ons. </blockquote> Do the refresh as a last resort only &nbsp; - &nbsp; let's see if installing the regular version of Adobe Flash Player does the trick first. Just curious : &nbsp; how did you wind up with that Shockwave 26.0 d0 &nbsp; ?

提出問題者

Uninstalling and reinstalling Flash did not work - the problem still persists. I ended up with that version through the Adobe updater. And everything was working fine with that version of Flash before the Firefox update.

Uninstalling and reinstalling Flash did not work - the problem still persists. I ended up with that version through the Adobe updater. And everything was working fine with that version of Flash before the Firefox update.

提出問題者

I just did the refresh and the problem persisted with no extensions installed.

I just did the refresh and the problem persisted with no extensions installed.
Happy112 561 個解決方法 5694 個答案

Bummer   ! There's only one thing you haven't tried yet :
FredMcD suggested   "Let’s do a full clean re-install;"

Bummer &nbsp; ! There's only one thing you haven't tried yet : <BR> FredMcD suggested &nbsp; ''"Let’s do a full clean re-install;"''
cor-el
  • Top 10 Contributor
  • Moderator
17584 個解決方法 159079 個答案

Are that CSS menus or JavaScript menus?

Do they open on hover or do you need to click with the mouse to open the drop-down menus?

Can you try a different mouse in case there is a problem with the mouse you currently use?

Are that CSS menus or JavaScript menus? Do they open on hover or do you need to click with the mouse to open the drop-down menus? Can you try a different mouse in case there is a problem with the mouse you currently use?

選擇的解決方法

The menus that were not working are the ones you have to click on. The hover type work fine. I decided to go ahead and try a USB mouse. The problem was not there. So, I removed my regular mouse from the system (deleted it), then paired it again.

So far it is working properly. I hate problems like this that make absolutely no sense. Thanks for all the input.

The menus that were not working are the ones you have to click on. The hover type work fine. I decided to go ahead and try a USB mouse. The problem was not there. So, I removed my regular mouse from the system (deleted it), then paired it again. So far it is working properly. I hate problems like this that make absolutely no sense. Thanks for all the input.
cor-el
  • Top 10 Contributor
  • Moderator
17584 個解決方法 159079 個答案

You're welcome and glad that you managed to fix it.

You're welcome and glad that you managed to fix it.