搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox will not print to Canon LBP7660C correctly

  • 1 回覆
  • 3 有這個問題
  • 201 次檢視
  • 最近回覆由 guigs

more options

Color Laser Printer; Canon LBP7660C, UFR II driver.

Windows 10 version 1607, build 14393.1066 (& the 5 or 6 prior to that)

Firefox v53.0 (& about the dozen before that).

ONLY Firefox, ALL other Windows 10 applications print correctly.

Have attempted all of the work arounds and suggestions, removing, reinstalling, totally purging all of Firefox, etc.

1) Ignores which tray to draw paper or envelopes from; always only wants the manual feed tray

2) Incorrectly scales printed objects & pages. For example, a return label from Amazon is printed about 1/4 the actual size. A web page is between 1/3 to 1/5 its actual size. An airline boarding pass (United, American, & Delta) is about 1//4 the correct size.

3) Ignores all graphics scale setting in the printer driver setup

4) Ignores settings for color/black & white/grayscale

5) Ignores settings for printing on one or two sides, always only prints on one side

And several more printing related issues.

Also incorrectly scales anything printed to Adobe Acrobat X, when opened & printed through Firefox, when opened from Acrobat directly, prints correctly.

ONLY Firefox. No other application has any of these issues.

Any help appreciated.

Thanks

被選擇的解決方法

There might be a saved Firefox printer profile. I would recommend resetting the printer preferences in Firefox. Fix printing problems in Firefox

If they do not reset after resetting print.print_printer, try a new profile.

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

There might be a saved Firefox printer profile. I would recommend resetting the printer preferences in Firefox. Fix printing problems in Firefox

If they do not reset after resetting print.print_printer, try a new profile.

more options

Thank you guigs!

I've tried this before to no avail, I only deleted the "print" items related to the Canon printer.

This time I deleted all "print" references. That appears to have done the trick.