X
點擊此處開啟此網站的行動版。

技術支援討論區

YouTube Keeps Buffering

已張貼

This is a recent problem that I haven't had before and none of the answers I've seen have solved my problem. Whenever I try to watch a YouTube video, it buffers for a long time. Sometimes I never get past an ad because it will stop two or three seconds in and the only way I can get it going again is to refresh the page. I have to constantly refresh to hopefully get a five second ad or one that I can skip in order to get to the actual video and when I get there, it starts buffering and at that point it either plays after a minute or two or it doesn't play at all. It does the same thing in safe mode. The only time I'm able to watch videos without this problem is in a private window.

I have uninstalled Firefox two times and refreshed multiple times, but nothing seems to be working. Every other website I get on works fine, but videos don't fully load on any of them. Can some please help me, I've been trying to figure this out for hours and I really don't want to use another browser.

This is a recent problem that I haven't had before and none of the answers I've seen have solved my problem. Whenever I try to watch a YouTube video, it buffers for a long time. Sometimes I never get past an ad because it will stop two or three seconds in and the only way I can get it going again is to refresh the page. I have to constantly refresh to hopefully get a five second ad or one that I can skip in order to get to the actual video and when I get there, it starts buffering and at that point it either plays after a minute or two or it doesn't play at all. It does the same thing in safe mode. The only time I'm able to watch videos without this problem is in a private window. I have uninstalled Firefox two times and refreshed multiple times, but nothing seems to be working. Every other website I get on works fine, but videos don't fully load on any of them. Can some please help me, I've been trying to figure this out for hours and I really don't want to use another browser.

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.23.20053
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 24.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

更多資訊

FredMcD
  • Top 10 Contributor
4310 個解決方法 60529 個答案
See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---------- Youtube currently uses the HTML5 player. https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

提出問題者

It says everything is up to date.

It says everything is up to date.

提出問題者

Is there a big difference between a private window and a normal one? My videos play fine in a pw, no buffering and they start right away. In fact, a normal Firefox window is the only one giving me problems with videos. Explore and Chrome work fine, but I don't like either of those browsers.

Is there a big difference between a private window and a normal one? My videos play fine in a pw, no buffering and they start right away. In fact, a normal Firefox window is the only one giving me problems with videos. Explore and Chrome work fine, but I don't like either of those browsers.
FredMcD
  • Top 10 Contributor
4310 個解決方法 60529 個答案
https://support.mozilla.org/en-US/kb/tracking-protection-pbm https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

提出問題者

Messing around with the privacy settings, I found out that it's the cookies that's giving me problems. When I set it to block cookies from YouTube the videos played fine, but as soon as I took it off the list my problem came back. Is there anything I can do for that?

Messing around with the privacy settings, I found out that it's the cookies that's giving me problems. When I set it to block cookies from YouTube the videos played fine, but as soon as I took it off the list my problem came back. Is there anything I can do for that?
FredMcD
  • Top 10 Contributor
4310 個解決方法 60529 個答案

I called for more help.

I called for more help.
cor-el
  • Top 10 Contributor
  • Moderator
17690 個解決方法 160050 個答案

It is possible that security software (anti-virus, firewall) is causing the problem. Try to disable security software temporarily to see if that makes a difference.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

It is possible that security software (anti-virus, firewall) is causing the problem. Try to disable security software temporarily to see if that makes a difference. ---- Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked