Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

always crashed those using the latest version

  • 21 回覆
  • 2 有這個問題
  • 73 次檢視
  • 最近回覆由 RubyDo

more options

Every now and then, about 15 min, my FF has been crashed again on Window 7 Ultimate albeit FF is the latest version. Also, I have run the malware scan and everything seems okay. Please help me to sort this out.

All Replies (20)

more options

I have recently uninstalled & deleted all old data of FF on my laptop to see whether it could help solve the issue but it does not. As well, all old Crash reports were gone. Any help would be greatly appreciated. Ruby Report ID Date Submitted bp-af42dc24-ed7f-424b-ba4e-211372170109 1/9/2017 10:18 AM bp-0f6036b0-8ab2-4d19-95d0-743fa2170109 1/9/2017 10:18 AM bp-c2d0427a-2710-4b20-971d-0f1912170109 1/9/2017 10:16 AM bp-c84b11ec-e36f-4072-9242-094852170108 1/8/2017 9:58 PM

由 RubyDo 於 修改

more options

bp-af42dc24-ed7f-424b-ba4e-211372170109 bp-0f6036b0-8ab2-4d19-95d0-743fa2170109 bp-c84b11ec-e36f-4072-9242-094852170108

Signature: OOM | large | NS_ABORT_OOM | nsACString_internal::SetCapacity

System Memory Use Percentage 78

Attention Sumo's there are 4 related bug reports: OOM ++++++++++++++++++++++++++++++++++++++++++++++ bp-c2d0427a-2710-4b20-971d-0f1912170109 Signature: mozilla::dom::CanvasRenderingContext2D::DrawImage

This is for Sumo's Related Bugs 1318283 RESOLVED FIXED Crash in mozilla::dom::CanvasRenderingContext2D::Fill

1313884 RESOLVED DUPLICATE Crash in mozilla::dom::CanvasRenderingContext2D::DrawImage


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

more options

Thanks so much FredMcD. I am wondering whether there is another way of running FF without entering the safe mode as I still prefer turning on my add-ons. But anyway, let see whether I still have any crash if I start FF in Safe Mode. Regards, Ruby

more options

What are you doing when these crashes happen?

Are you uploading (possibly large) files?

more options

Thanks for replying to my issue, cor-el. Yes, you're right, sometimes I was uploading videos to my Youtube channel (less than 500MB) & then crashes happened. But sometimes I was not uploading anything but crashes still happened. Regards, Ruby

more options

I have not tried this, but their downloader works great. http://www.dvdvideosoft.com/products/dvd/Free-YouTube-Uploader.htm

Free YouTube Uploader is the first and the best tool for uploading videos to YouTube without using the original YouTube web interface in batch mode.

more options

Thanks so much FredMcD. So you meant that I should upload my videos to my Youtube channel via Youtube Uploader instead of uploading via FF. The fact is that I have uploaded my videos (less than 2G) to my Youtube channel for the last 3 years but crashes have not occurred until recently. Thus I humbly suppose that there should be some issues with the latest FF version but not old version. Is there any way for me to upload my videos to my Youtube channel via FF without crashes? I still prefer uploading via FF really since I get used to the interface of FF. Regardless, I will try upload my videos with Youtube Uploader as per your advice. Kind regards, Ruby

由 RubyDo 於 修改

more options

If you can't get Firefox to work properly, you can use the uploader until the problem is resolved. I should also point out that the downloaders transfer data sometimes 10 times faster than Firefox on its own.

more options

Thanks FredMcD :) Please could you help me get my FF to work properly? I really do not know what the problem is with my FF. Or someone will help me fix the problem of FF soon hopefully. By the way, I have tried uploading videos to my Youtube channel by Youtube Uploader, its speed of uploading videos is similar to that of FF, sometimes a little slower, but it's working fine afterall. Kind regards, Ruby

more options

This may help narrow the problem down;

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Thanks FredMcD :) I have tried starting my FF in Safe Mode as the following instruction https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode Seems that there have been no crashes with this Safe Mode but unfortunately I have to turn off my add-ons which I really do not like. I do not know how to start my computer in Safe Mode, please advise me. Thanks. The majority of my time is just replying my working emails as I am a freelancer, watching movies online, downloading videos, uploading videos to my Youtube channels, reading news. I do not access to any websites other than these and I honestly think that they are safe to access. Kind regards, Ruby

由 RubyDo 於 修改

more options

RubyDo said

Seems that there have been no crashes with this Safe Mode

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Thanks for your instruction FredMcD :) My FF has only 1 add-on & I had been disable it before starting FF as per your instruction but crash still happened. Thus my add-on is not the cause of the crash. So that what I should do next to prevent crashes from happening? Starting FF with Safe Mode, I guess. Kind regards, Ruby

more options
Details: The application did not specify a crash reporting server

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Search for breakpad.reportURL and set its value to; https://crash-stats.mozilla.com/report/index/

Now search for browser.tabs.crashReporting.sendReport and set its value to true.

After, restart the browser. Then try sending the crash reports. After, post the reports here. They should start with BP.

由 FredMcD 於 修改

more options

Now as to the reason for the crashes,

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

more options

Thanks for your instruction FredMcD :) I could not set value of breakpad.reportURL to the following site as per your instruction since this is invalid site https://crash-stats.mozilla.com/report/index/ browser.tabs.crashReporting.sendReport . This has already been set to true Here are all the latest crash reports (seems that the reported crashes less than the actual crashes that have been occurred) Report ID Date Submitted bp-be947ca1-faa0-4af0-9395-88ff62170111 1/11/2017 10:17 AM bp-a6b98fa2-693b-4b37-a3d3-b8ee82170110 1/10/2017 10:55 PM bp-04545095-d0e5-4dcb-9d85-8e6ee2170110 1/10/2017 9:11 PM

Default has already been selected in Appearance before your instruction. Hope that my FF will be fixed soon. Thanks so much :) Kind regards, Ruby

more options

Product Firefox Release Channel release Version 50.1.0 Build ID 20161208153507 OS Windows 7 OS Version 6.1.7601 Service Pack 1

bp-be947ca1-faa0-4af0-9395-88ff62170111 Signature: OOM | small

Attention Sumo's there are 40 related bug reports

igdumdim32.dll = Intel Graphics Accelerator Drivers for Windows Vista(R)

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder ++++++++++++++++++++++++++++++++++++++++++++++++ bp-a6b98fa2-693b-4b37-a3d3-b8ee82170110 Signature: memcpy | NS_CopySegmentToBuffer

igdusc32.dll = Intel HD Graphics Drivers for Windows 8(R) = Intel Corporation

GrooveIntlResource.dll = Microsoft Office

This is for Sumo's Related Bugs 1294533 RESOLVED FIXED Crash in memcpy | NS_CopySegmentToBuffer rising in Firefox 49

542120 RESOLVED WORKSFORME crash uploading through XHR [@memcpy | NS_CopySegmentToBuffer(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*)] ++++++++++++++++++++++++++++++++++++++++++++++ bp-04545095-d0e5-4dcb-9d85-8e6ee2170110 Signature: igd10iumd32.dll | CContext::ID3D11DeviceContext1 _UpdateSubresource1_<T>

igd10iumd32.dll = NVIDIA D3D shim drivers = NVIDIA Corporation

igdusc32.dll = Intel HD Graphics Drivers for Windows 8(R) = Intel Corporation

GrooveIntlResource.dll = Microsoft Office

This is for Sumo's Related Bugs 1282562 NEW --- D2D crash in igd10iumd32.dll | CContext::ID3D11DeviceContext1_UpdateSubresource1_<T>

more options
more options

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Thanks FredMcD & cor-el :) Sorry for the late reply, our Internet has not been working these days. I have performed File Check & there were no corrupted files in my laptop. Please note that my FF was crashed again though I have started my FF with Safe Mode Report ID Date Submitted bp-299a8513-7277-4435-8ecf-77dfa2170117 1/17/2017 9:27 PM I could not update my graphics drivers (please see attachments) due to errors although I have run the update twice. Please advise what I should do next. Thanks and kind regards, Ruby

  1. 1
  2. 2