Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

What causes Firefox to Hog cpu?

  • 10 回覆
  • 2 有這個問題
  • 24 次檢視
  • 最近回覆由 cor-el

more options

Have recently purchased new computer running windows 10. Firefox is using extreme cpu. 100% most of the time and seldom less than 20%. To use computer have to shutdown Firefox. Have just installed Google Chrome and it behaves as you would expect. Seldom over 80% and dropping to nil. So problem is within Firefox. Prefer to use iot but currently unworkable.

All Replies (10)

more options

What's your computer system and Firefox version?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

more options

Windows 10. Firefox 32 bit. Updated yesterday. Problem there before and after update. Have tried safe mode - no difference. Shutting down Firefox and restarting it sometimes solves problem but it generally returns in time. I am doing this with Chrome which works as you would expect - Firefox unworkable.

more options

Does the about:performance page give you any suspects?

more options

What 'about:performance page' would that be? More info Pls.

more options

Type "about:performance" no quotes in the awesomebar.

It looks like this https://cdn.ghacks.net/wp-content/uploads/2015/08/firefox-performance-monitor.jpg

Do you see anything in red or orange?

more options

No. Blames 2 unread emails using about 8% when FF is chewing 60+% (all that is available).

more options

Sorry, The 2 unread emails were in red. Tried opening a few other tabs/pages but makes little difference. No explanation for chewing all available cpu.

more options

Well I guess no one cares. Not happy about it but have changed to Google Chrome.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Can you post your Firefox troubleshooting information.

What security software do you have?


Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can check for issues caused by plugins.

  • set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools -> Add-ons -> Plugins)
  • plugins are not affected by Firefox Safe Mode