搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm having trouble accessing a https website. It tells me the connection is not secure. I want to access it anyway. How can I override the block?

  • 5 回覆
  • 2 有這個問題
  • 26 次檢視
  • 最近回覆由 jscher2000

more options

I'd like to access to website even though the "connection is not secure" i.e. the lock on the left of the address bar has a yellow icon on it. The help page said this might be because it's a http site. It's actually a https site so it should be secure. But either way I'd like to override this. Thanks.

所有回覆 (5)

more options

Hi Patty27, a gray lock with a little triangle usually is a warning that Firefox has loaded some images using HTTP addresses into an HTTPS page. More info on how to investigate mixed content situations: Mixed content blocking in Firefox.

Are there any other indications that Firefox is blocking something?

more options

Well the page isn't showing up at all (blank white screen) so I assumed it was being blocked. I'm not sure what the problem is now. The page needs silverlight to run but silverlight is working fine

more options

I'll suggest the general things first:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site -- even a blank page -- try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?


Some users have turned off automatic redirection, which should display a warning bar but sometimes just halts without explanation. To check on that:

"3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Advanced, and on the right side, make sure the General mini-tab is selected. If there is a checkmark for "Warn me when websites try to redirect or reload the page" go ahead and uncheck that.


If no luck so far, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I tried all those things and no luck... Thanks anyway. Do you have any other suggestions?

more options

I don't have much else to go on...

Does Firefox display the plugin notification icon for Silverlight toward the left end of the address bar? (Looks like a small Lego block.) If so, please click that to make sure the site is allowed to use it.

Also, does it work in Safari or other browsers you might have installed?