搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Save as" - Downloadthemall

  • 19 回覆
  • 1 有這個問題
  • 83 次檢視
  • 最近回覆由 Happy112

more options

I had to reset Firefox the other day, and after restart I immediately notice that ALWAYS ASK for download location was no longer working, despite basic settings. After playing around with this for a few days, I noticed a similar post concerning ALWAYS ASK in connection with Downloadthemall. So, I added this add-on, and things went back to normal and the download box is now the FULL download box. However, if I disable Downloadthemall, ALWAYS ASK no longer works again, and same thing if I start in SAFE MODE, it no longer works. So, although I have found a temp patch for this problem (as long as this add-on is enabled), something is still wrong, as ALWAYS ASK, one would think, should still work in both safe and normal modes, without this add-on, right? Any help would be appreciated.

被選擇的解決方法

I finally found solution.

Delete mimeTypes.rdf

This was one of many ideas I had found to fix problem, but apparently did not test.

It works!

從原來的回覆中察看解決方案 👍 0

所有回覆 (19)

more options

Hi   !
You could try this:
Type in the address bar:   about:config (promise to be careful) Type and search for: browser.download.folderList click on it and set it's value to   2   (if it wasn't already, of course)

If this doesn't solve the problem,   you could try and reinstall   'Downloadthemall';   that seems to have worked for others with the same problem.

more options

Thanks, I already checked the value on this and it's already 2.

I have reinstalled Downloadthemall, and it does indeed fix problem, but I have no idea why.

The fact that ALWAYS ASK does not work in SAFE MODE is deeply troubling, don't you think so?

more options

Safe Mode is a troubleshooting mode:   when you ran in Safe Mode,  
was this   before   or   after   you reinstalled   'Downloadthemall'   ?
Apparantly reinstalling fixed the problem and it works fine when you run Firefox in   'normal mode',   and that's the main thing, right   ?

more options

Download them all (which I had essentially for YouTube videos) was on my PC BEFORE I reset Firefox, I believe.

I ran SAFE MODE

1) when I first detected problem 2) again before installing DTA 3) after installing DTA 4) after temporary disabling DTA

So, yes, the main thing is that Fireworks, but that it should require DTA to work in normal mode and cannot work normally without it, even in safe mode, means something is screwed up and I hope Firefox gets around to fixing it asap

more options

Jonathan147 said

So, yes, the main thing is that Fireworks, but that it should require DTA to work in normal mode and cannot work normally without it, even in safe mode, means something is screwed up and I hope Firefox gets around to fixing it asap

Let me see if I've got this right: It works fine   with   DTA,   but you want it to work   without   DTA,   and that's not happening,   despite the correct settings   ?
You're right:   it should work properly. Guess we'll have to keep looking for a solution   .......

more options

Quite right. It now NEVER WORKS IN SAFE MODE or after RESET, which cannot be right. And only works in normal mode with boost from 3rd party add-on. So that can't be how things work.

I am hoping that, like many things, this is a temp glitch and things will soon go back to normal.

How long problem has existed, I'm not sure, as I think I've had DTA installed for a long time, even if I no longer use it.

One user, with same problem, said it was due to a Microsoft update a few months back, which he removed then ALWAYS ASK worked again.

But if you yourself are on PC like me, and you don't have the problem and I do, well, that's strange.

Please note that my operating system is still 8.0 as I feared that 8.1 or 10 would kill my main software for my work, like Word 97.

more options

Would you take a look at the article   'Change what Firefox does when you click on or download a file'     -     the section:   'Adding download actions':
              http://mzl.la/1xKrLAq
(in case you've done that already:   sorry   ! )

more options

Jonathan147 said

One user, with same problem, said it was due to a Microsoft update a few months back, which he removed then ALWAYS ASK worked again.

Oh yeah,   those updates can turn your whole world upside-down   (voice from experience)   ........
But this doesn't apply to you, though   -   or does it   ?

more options

thanks for link, but I already checked out app settings, which are nonetheless overridden by more general settings under GENERAL/ALWAYS ASK.

As to Microsoft update, this was specifically posted as relates to ALWAYS ASK, but since poster only referred to update by its date instead of its reference name, like KB75544, it's very hard to tell which update he was talking about. I sent him a note to inquire, but haven't heard back from him.

I did have one other issue with Firefox as I could suddenly no longer copy and paste data from Firefox to Word 97. This problem was discussed with someone like yourself, and eventually required Firefox new update to get fixed, and now works normally.

My gut feeling is that the last update by Firefox got screwed up, about a week ago.

In any event, last problem, dealing with Word 97 was difficult to test, as most folks no longer have that program version, but in this case, can you replicate my problem or not??

more options

I'm not sure if this applies to your particular problem,   but here goes:

Some sites use   "rich text"  editors that capture your paste and reformat it behind the scenes.

(Sometimes you can tell the difference because rich text editors allow bold and italic while you compose, and/or they offer an HTML or Source view in the editor.  But in other cases, it may not be apparent.)

One common reason for problems with pasting into rich text editors is if you disable their ability to detect pastes in their scripts. Would you check this setting:

(1) In a new tab, type or paste  about:config   in the address bar and press Enter/Return.   Click the button promising to be careful.

(2) In the search box above the list, type or paste   CLIP   and pause while the list is filtered

(3) If the  dom.event.clipboardevents.enabled  preference is bolded and  "user set"  to   'false',  double-click it to restore the default value of   'true' .

Sure hope this will work for you   !   Good luck   !

more options

Thanks, but as I said, this problem, according to Mozilla support, was due to one of Firefox's update, I was told to wait until the next update and it would be fixed, which it was in the next update, and since, everything works fine, so I'm not going back into this problem.

However, I would be interested to know if you on your end ALWAYS ASK works correctly in SAFE MODE or does it revert to the short dialogue box form instead of the extended one? And you have DTA installed on your version of Firefox? And if so, does everyone?? And if this is the case, why isn't it part of the basic Firefox set up instead of being classified as an add-on??

more options

Jonathan147 said

However, I would be interested to know if you on your end ALWAYS ASK works correctly in SAFE MODE or does it revert to the short dialogue box form instead of the extended one? And you have DTA installed on your version of Firefox? And if so, does everyone?? And if this is the case, why isn't it part of the basic Firefox set up instead of being classified as an add-on??

'Always ask'   works fine for me and personally I have never felt the need to install   DTA. Sorry I haven't been much help to you   ......

more options

Thanks. I just checked in safe mode and it's still not working.

What would you suggest now?

1) refreshing for a 2nd time Firefox? 2) complete uninstall and clean install of Firefox? (a bit complicated, as you well know, as I'd lose a lot of stuff) 3) contact a specific support department directly at Mozilla? 4) wait and see what happens with next update? 5) just forget about it? (irksome, as you might understand) 6) other

thanks

more options

I've completely run out of ideas   (sorry   !)
Keeping my fingers crossed that somebody else comes up with the perfect solution for you   .......
Good luck   !

more options

選擇的解決方法

I finally found solution.

Delete mimeTypes.rdf

This was one of many ideas I had found to fix problem, but apparently did not test.

It works!

more options

Well done, you   !!!
Now, would you be a dear and mark   your   last post as   Chosen Solution,   so others will know and might benefit from it   ? Thank you   !

more options

Oh boy;   you inadvertently marked   my   post as   Chosen Solution   instead of   your   last post. Would you be a dear and recify that, please   ? I'd do it for you in a heartbeat,   but this is something only you can do   (or a moderator)   ......

more options

fixed, sorry, never did that before

more options

Jonathan147 said

fixed, sorry, never did that before

Thank you;   you rock   !!!