搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

SSL connection fails before browsing to a non-SSL site when using a proxy

  • 1 回覆
  • 2 有這個問題
  • 4 次檢視
  • 最近回覆由 Tonnes

more options

This is the same problem as https://support.mozilla.org/en-US/questions/1142423 but I now have a much clearer description of it.

Firefox 49.0.2 running on Windows 7, all extensions disabled. I've cleared all history (cache, site preferences, etc.) I have an HTTP proxy configured (Manual Proxy Configuration, "Use this proxy server for all protocols" checked).

If I browse to an HTTPS site after starting Firefox before browsing to an HTTP (non-SSL) site the status bar quickly changes between "Looking up (host)...", "Connecting to (host)..." and "Waiting for (host)..." several times and then shows the "Secure Connection Failed" page, as in the screenshot on https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

This happens on every HTTPS site I try, e.g. https://support.mozilla.org/, https://www.google.com/, https://www.pandora.com/, https://www.ycombinator.com/ (note that this last one does not use HSTS).

My proxy server requires HTTP authentication and Firefox does not even prompt for a username and password at this point. I control the proxy server and can see in its logs that there are no connection attempts yet.

If I browse to an HTTP site and enter the proxy credential when prompted I can then browse to HTTPS sites as normal. It doesn't have to be the same site, e.g. I can browse to http://www.yahoo.com/ and then https://www.microsoft.com/ will work. However, if I cancel the proxy credentials prompt the issue continues. It takes a successful HTTP connection to make HTTPS work.

This is the same problem as https://support.mozilla.org/en-US/questions/1142423 but I now have a much clearer description of it. Firefox 49.0.2 running on Windows 7, all extensions disabled. I've cleared all history (cache, site preferences, etc.) I have an HTTP proxy configured (Manual Proxy Configuration, "Use this proxy server for all protocols" checked). If I browse to an HTTPS site after starting Firefox before browsing to an HTTP (non-SSL) site the status bar quickly changes between "Looking up (host)...", "Connecting to (host)..." and "Waiting for (host)..." several times and then shows the "Secure Connection Failed" page, as in the screenshot on https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message This happens on every HTTPS site I try, e.g. https://support.mozilla.org/, https://www.google.com/, https://www.pandora.com/, https://www.ycombinator.com/ (note that this last one does not use HSTS). My proxy server requires HTTP authentication and Firefox does not even prompt for a username and password at this point. I control the proxy server and can see in its logs that there are no connection attempts yet. If I browse to an HTTP site and enter the proxy credential when prompted I can then browse to HTTPS sites as normal. It doesn't have to be the same site, e.g. I can browse to http://www.yahoo.com/ and then https://www.microsoft.com/ will work. However, if I cancel the proxy credentials prompt the issue continues. It takes a successful HTTP connection to make HTTPS work.

所有回覆 (1)

more options

Would you mind following up in your original question?

Additionally, you could try the solution mentioned in this question.