X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox very slow in Win 10

已張貼

Hi, I've always been using Firefox as a preferred browser. I recently got a new laptop with WIN10. Firefox has been unbearably slow in WIN10. Loading Google home URL (search screen) takes about 50 seconds; Yahoo home URL about 4 minutes. I tried just about everything that have been suggested by Firefox Help to address this issue including re-install; reset; safe mode just to name a few - to no avail. I then tried Internet Explorer to load same Google and Yahoo home URLs. They took less than 1 second and about 5 seconds respectively. I turned on Windows task manager and observed Wifi network throughput while accessing these URLs. I noted when I was running Firefox transfer rate rate ranged 30 kbps - 500 kbps (average around 100 kbps); while IE transfer rate ranged 100 kbps to 4.5 mbps. Being a new PC I have no Extensions nor any active Plugins. Does anyone have any idea idea what's happening, and help resolve this issue please. Thanks.

Hi, I've always been using Firefox as a preferred browser. I recently got a new laptop with WIN10. Firefox has been unbearably slow in WIN10. Loading Google home URL (search screen) takes about 50 seconds; Yahoo home URL about 4 minutes. I tried just about everything that have been suggested by Firefox Help to address this issue including re-install; reset; safe mode just to name a few - to no avail. I then tried Internet Explorer to load same Google and Yahoo home URLs. They took less than 1 second and about 5 seconds respectively. I turned on Windows task manager and observed Wifi network throughput while accessing these URLs. I noted when I was running Firefox transfer rate rate ranged 30 kbps - 500 kbps (average around 100 kbps); while IE transfer rate ranged 100 kbps to 4.5 mbps. Being a new PC I have no Extensions nor any active Plugins. Does anyone have any idea idea what's happening, and help resolve this issue please. Thanks.

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 23.0 r0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:49.0) Gecko/20100101 Firefox/49.0

更多資訊

FredMcD
  • Top 10 Contributor
4248 個解決方法 59418 個答案

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

提出問題者

Thanks for your suggestion. I tried safe mode before, but tried that again. Tried to get to my bank's home page. With Firefox it took 140 seconds; with IE it took about 3 seconds.

Thanks for your suggestion. I tried safe mode before, but tried that again. Tried to get to my bank's home page. With Firefox it took 140 seconds; with IE it took about 3 seconds.
FredMcD
  • Top 10 Contributor
4248 個解決方法 59418 個答案

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.


One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

(1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''async''' and pause while the list is filtered (3) Double-click the '''dom.ipc.plugins.asyncdrawing.enabled''' preference to switch the value from true to false This might not take effect until the next time you exit Firefox and start it up again. ------------------------------ One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, check the row for '''Multiprocess Windows''' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with '''browser.tabs.remote.autostart''''' At your next Firefox startup, it should run in the traditional way. Any difference?

提出問題者

Fred, Thanks again for your suggestions. I checked config parameters. dom.ipc.plugins.asyncdrawing.enabled is and has been set to 'false' by default all along. The number of the left side of the fraction in "Multi-process Windows" in the trouble-shooting info page was zero. However, I found the value for browser.tabs.remote.autostart.2' in config is 'false' by user set, although I have no recollection of even touching this parameter. I changed the values to 'true' on both just to see if they have any impact. There seems to be zero impact - it's slow as ever.

Fred, Thanks again for your suggestions. I checked config parameters. ''dom.ipc.plugins.asyncdrawing.enabled'' is and has been set to 'false' by default all along. The number of the left side of the fraction in "Multi-process Windows" in the trouble-shooting info page was zero. However, I found the value for ''browser.tabs.remote.autostart.2''' in config is 'false' by user set, although I have no recollection of even touching this parameter. I changed the values to 'true' on both just to see if they have any impact. There seems to be zero impact - it's slow as ever.
FredMcD
  • Top 10 Contributor
4248 個解決方法 59418 個答案

I've called for more help.

I've called for more help.

提出問題者

Thanks, Fred. Just for your information.... I run Norton Antivirus 360 on this new PC where Firefox program folder has been placed onto the exclusion list from its online protection services; and Firefox is flagged as 'trusted' program in its firewall services. The Wifi modem I use uses IPv4 protocol.

Thanks, Fred. Just for your information.... I run Norton Antivirus 360 on this new PC where Firefox program folder has been placed onto the exclusion list from its online protection services; and Firefox is flagged as 'trusted' program in its firewall services. The Wifi modem I use uses IPv4 protocol.
jbees 1 個解決方法 25 個答案

David did your problem get resolved? I too have this problem and did the suggestions that Fred provided. No help for me. I like Firefox but when I go into Chrome, everything is fast. I have a desktop with win 10. Same problem on my laptop with vista. But Spouses desktop with Win 10, there is no sluggishness or delay. Any other suggestions? Not trying to high jack thread.

David did your problem get resolved? I too have this problem and did the suggestions that Fred provided. No help for me. I like Firefox but when I go into Chrome, everything is fast. I have a desktop with win 10. Same problem on my laptop with vista. But Spouses desktop with Win 10, there is no sluggishness or delay. Any other suggestions? Not trying to high jack thread.

提出問題者

jbees, sorry didn't respond quicker. I did everything Fred suggested but didn't help at all. My old laptop that I've been using till 3 weeks ago runs on Vista, and has no performance issues with Firefox nor with IE. I'll keep looking into this, if I find solution, will let you know.

jbees, sorry didn't respond quicker. I did everything Fred suggested but didn't help at all. My old laptop that I've been using till 3 weeks ago runs on Vista, and has no performance issues with Firefox nor with IE. I'll keep looking into this, if I find solution, will let you know.
jbees 1 個解決方法 25 個答案

Thanks. I needed that. Seems like lots of questions from users but no answers to the problems. This is not like Firefox monitors. Maybe fred has more information. Are they too far ahead of the problems? Kind of makes you want to poke your fist into the monitor. But I guess it doesn't respond to violence.

Thanks. I needed that. Seems like lots of questions from users but no answers to the problems. This is not like Firefox monitors. Maybe fred has more information. Are they too far ahead of the problems? Kind of makes you want to poke your fist into the monitor. But I guess it doesn't respond to violence.

由 jbees 於 修改

Tonnes
  • Locale Leader
246 個解決方法 1454 個答案

Have your system proxy settings been set up properly?

Have you set Firefox to No proxy in Preferences > Advanced > Network > Settings to see if that helps?

Have your system proxy settings been set up properly? Have you set Firefox to ''No proxy'' in Preferences > Advanced > Network > Settings to see if that helps?

由 Tonnes 於 修改

jbees 1 個解決方法 25 個答案

Thanks for the reply. I went into settings and found 'how Firefox connects to the internet' and it was set to 'use system proxy settings'. I changed it to 'no proxy', and restarted Firefox, no help. Is that the setting? I can click on a different tab or cancel out of a tab and sometimes it takes maybe a second or two to do it. There are a lot of settings in Firefox so it would take a lot of time to compare my desktop and laptop to our other good running desktop. Computer takes the looong way home.

Thanks for the reply. I went into settings and found 'how Firefox connects to the internet' and it was set to 'use system proxy settings'. I changed it to 'no proxy', and restarted Firefox, no help. Is that the setting? I can click on a different tab or cancel out of a tab and sometimes it takes maybe a second or two to do it. There are a lot of settings in Firefox so it would take a lot of time to compare my desktop and laptop to our other good running desktop. Computer takes the looong way home.
Tonnes
  • Locale Leader
246 個解決方法 1454 個答案

Yes it is the proper setting.

Are you sure Norton is up-to-date? And did you try disabling it entirely? Although I don’t see any Norton related add-ons in Firefox displayed, are you using either Norton Security Toolbar or Norton Identity Safe, are you sure they’re also up-to-date and did you try disabling them?

If it helps (or not), what happens if you add the Firefox profile folder to the Norton exclusion list?

You could also create a new profile to see how fast things work, even it it was just for testing. If that helps, moving back some files into the new profile could save some time. Basically this is what the Refresh feature does, but I wouldn’t recommend that for troubleshooting issues like these.

Edit: forgot to mention some particularities for Norton 360 mentioned in the How to fix preferences that won't save and Configure Norton 360 to work with Firefox KB articles. Could you check the settings mentioned there?

Yes it is the proper setting. Are you sure Norton is up-to-date? And did you try disabling it entirely? Although I don’t see any Norton related add-ons in Firefox displayed, are you using either Norton Security Toolbar or Norton Identity Safe, are you sure they’re also [https://support.norton.com/sp/en/us/home/current/solutions/v115161915_EndUserProfile_en_us up-to-date] and did you try disabling them? If it helps (or not), what happens if you add the Firefox [[Profiles - Where Firefox stores your bookmarks, passwords and other user data|profile folder]] to the Norton exclusion list? You could also create a new profile to see how fast things work, even it it was just for testing. If that helps, moving back some files into the new profile could save some time. Basically this is what the Refresh feature does, but I wouldn’t recommend that for troubleshooting issues like these. Edit: forgot to mention some particularities for Norton 360 mentioned in the [[How to fix preferences that won't save]] and [[Prevent Norton 360 from erasing Firefox bookmarks]] KB articles. Could you check the settings mentioned there?

由 Tonnes 於 修改

jbees 1 個解決方法 25 個答案

I do not have Norton products. Just windows defender. At one time I had AVG free version but thought that was my problem and deleted it. Also have Malwarebytes. I do have flash player (shock wave flash) which was recently updated through Win 10 update. It does crash often. Think I will disable it as I can always add it back. Thanks again.

I do not have Norton products. Just windows defender. At one time I had AVG free version but thought that was my problem and deleted it. Also have Malwarebytes. I do have flash player (shock wave flash) which was recently updated through Win 10 update. It does crash often. Think I will disable it as I can always add it back. Thanks again.
Tonnes
  • Locale Leader
246 個解決方法 1454 個答案

@jbees Sorry, my reply was to DavidTK. This may happen when "stealing" questions. ;)

However, if you run Malwarebytes, have you included the Firefox process in the Web Exclusions, as well as Malicious Website Protection under Detection and Protection? These features should only be available for paid versions though. According to this thread at tenforums, MBAM should be able to work with Defender though, but miles may vary. I would uninstall all of them and reboot to rule things out, and create a new Firefox profile (using No proxy for home use just in case) and perhaps re-install Firefox.

@jbees Sorry, my reply was to DavidTK. This may happen when "stealing" questions. ;) However, if you run Malwarebytes, have you included the Firefox process in the Web Exclusions, as well as Malicious Website Protection under Detection and Protection? These features should only be available for paid versions though. According to [http://www.tenforums.com/antivirus-firewalls-system-security/24922-running-both-malwarebytes-windows-defender.html this thread] at tenforums, MBAM should be able to work with Defender though, but miles may vary. I would uninstall all of them and reboot to rule things out, and create a new Firefox profile (using No proxy for home use just in case) and perhaps re-install Firefox.

提出問題者

Tonnes

Thank you for your suggestions. Before going into your suggestions, I’d like to explain why this problem is so baffling. I got a new laptop with WIN 10 about a month ago. I still have my old laptop that runs Vista. Both of them run the latest Firefox 49.0.2; and run on wifi off the same router. I did performance comparison again yesterday….

To get to Google home page: Win 10 Firefox – 71 seconds and max transfer rate ~150 kbps. Vista Firebox – 2 seconds and max transfer rate ~1 mbps

To get to Yahoo home page: Win 10 Firebox – 400+ seconds and max transfer rate ~200 kbps. Vista Firefox – 18 seconds and max transfer rate ~4.5 mbps

I also run Internet Explorer on both computers. There are no IE performance issues on either computer. Vista Firefox has all the add-ons WIN 10 Firefox has. So I have to say WIN 10 Firefox setting is different from Vista’s but I can’t put my finger on it. One interesting observation was WIN 10 Firefox transfer rate is stuck at 32 kbps most of the time.

As for your suggestions, I tried to change the proxy setting to ‘No Proxy’ on WIN 10 Firefox, but for some reason it doesn’t save – when I get back in it is automatically reset to ‘Use system proxy settings’ (I believe this is the default setting). But I checked Vista Firefox proxy setting, and it is set to ‘Use system proxy settings’ as well.

I run Norton 360 on both computers. I do have Firefox excluded from firewall and Sonar protection. I'll just keep looking.

Tonnes Thank you for your suggestions. Before going into your suggestions, I’d like to explain why this problem is so baffling. I got a new laptop with WIN 10 about a month ago. I still have my old laptop that runs Vista. Both of them run the latest Firefox 49.0.2; and run on wifi off the same router. I did performance comparison again yesterday…. To get to Google home page: Win 10 Firefox – 71 seconds and max transfer rate ~150 kbps. Vista Firebox – 2 seconds and max transfer rate ~1 mbps To get to Yahoo home page: Win 10 Firebox – 400+ seconds and max transfer rate ~200 kbps. Vista Firefox – 18 seconds and max transfer rate ~4.5 mbps I also run Internet Explorer on both computers. There are no IE performance issues on either computer. Vista Firefox has all the add-ons WIN 10 Firefox has. So I have to say WIN 10 Firefox setting is different from Vista’s but I can’t put my finger on it. One interesting observation was WIN 10 Firefox transfer rate is stuck at 32 kbps most of the time. As for your suggestions, I tried to change the proxy setting to ‘No Proxy’ on WIN 10 Firefox, but for some reason it doesn’t save – when I get back in it is automatically reset to ‘Use system proxy settings’ (I believe this is the default setting). But I checked Vista Firefox proxy setting, and it is set to ‘Use system proxy settings’ as well. I run Norton 360 on both computers. I do have Firefox excluded from firewall and Sonar protection. I'll just keep looking.
Tonnes
  • Locale Leader
246 個解決方法 1454 個答案

Those are interesting facts, thank you. It seems clear the networking is affected.

Have you tried to disable Sonar protection? There have been reports of it slowing down Firefox. link1, link 2.

You could fool/workaround (and check) the current proxy settings by checking the Windows system proxy / internet settings to set them to None. However, not being able to change them in Firefox seems rather unusual, unless there is a lock file in the Firefox profile. I doubt if that will get added by any of the security products.

Those are interesting facts, thank you. It seems clear the networking is affected. Have you tried to disable Sonar protection? There have been reports of it slowing down Firefox. [https://community.norton.com/en/forums/really-bizarre-issue-firefox-development-when-nis-2009-sonar-protection-enabled link1], [https://community.norton.com/en/forums/firefox-extreemly-slow-start link 2]. You could fool/workaround (and check) the current proxy settings by checking the Windows system proxy / internet settings to set them to None. However, not being able to change them in Firefox seems rather unusual, unless there is a [http://kb.mozillazine.org/Locking_preferences lock file] in the Firefox profile. I doubt if that will get added by any of the security products.
FredMcD
  • Top 10 Contributor
4248 個解決方法 59418 個答案

DavidTK said

I tried to change the proxy setting to ‘No Proxy’ on WIN 10 Firefox, but for some reason it doesn’t save

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

''DavidTK [[#answer-935445|said]]'' <blockquote> I tried to change the proxy setting to ‘No Proxy’ on WIN 10 Firefox, but for some reason it doesn’t save </blockquote> '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.