搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Adobe plugins fail to load with a "Connection Error" error.

  • 6 回覆
  • 2 有這個問題
  • 1397 次檢視
  • 最近回覆由 James

more options

An older version of Adobe Flash (ver 21.0.0.242) is causing havoc with the latest version of FireFox (ver 47.0.1). I have gone to the Adobe web site and downloaded the installer file for both Adobe Flash and Adobe Reader (also outdated). Before installing these files, I right click on the file and select Properties>Unblock to install them. I also suspend my Anti-virus software to give me enough time to install the files. However, when I attempt to install the files, the Adobe installer gives me the error of "Connection Error" and fails to install the plugins. In the past, the workaround to this problem was going to Adobe's web page " http://www.adobe.com/products/flashplayer/distribution3.html" and downloading a different installation file of the same Adobe Flash version. However, Adobe has discontinued using this page to download a different installer and instead, redirects you to their download page to download the same version that doesn't work. Workaround searches on the web all tend to send you back to the Adobe Flash installer page and right back into an endless loop.

There has to be a simpler way of doing this installation process. Adobe doesn't seem to accept email support questions for their free software and other than the workaround listed above, I have not yet found any solution via internet searches. I'm having this issue on both my Windows Server and all my computers, even though Adobe is detecting the proper OS and downloading the proper file.

How can I install these plugins so that FireFox has the latest versions?

被選擇的解決方法

James said

Not sure if this link still works to get latest version for Windows. http://download.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe

Yes, it downloads a 19.2MB file which has an internal version number on the Details tab of the Windows Explorer Properties dialog of 23.0.0.185.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

The latest Flash version supported is 23.0.0.185.

more options

Yes, I know! The problem is that the latest version won't install after downloading it from Adobe. Neither have any of the other versions since 21.0.0.242.

The issue I have is how do I get the latest version of Flash Player installed since the version downloaded from Adobe constantly gives a "Connection Error" and quits?

more options

From https://support.mozilla.org/en-US/kb/install-flash-plugin-view-videos-animations-games

Not sure if this link still works to get latest version for Windows. http://download.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe

You can thank scammers spoofing the distribution3 page with fake downloads as one of the main reason they discontinued the easy public access without needing an account. They actually were planning to discontinue page back in Jan, Mar, and June and then finally Sept 29.

由 James 於 修改

more options

選擇的解決方法

James said

Not sure if this link still works to get latest version for Windows. http://download.macromedia.com/pub/flashplayer/latest/help/install_flash_player.exe

Yes, it downloads a 19.2MB file which has an internal version number on the Details tab of the Windows Explorer Properties dialog of 23.0.0.185.

more options

Johnv351 said

I have gone to the Adobe web site and downloaded the installer file for both Adobe Flash and Adobe Reader (also outdated).

Reader For Windows Server 2003, if Firefox reported your Windows version accurately, you can download the installer for Adobe Reader XI (11.0.10) from this page:

https://get.adobe.com/reader/enterprise/

Then after installation, go to its Help menu and use Check for Updates to get the latest security patches. In the end, you should have 11.0.18 (latest release notes: http://www.adobe.com/devnet-docs/acro.../11.0.18.html).

Unfortunately, the Mozilla Plugin Check page does not consider your older OS in declaring the Adobe Reader/Acrobat XI series to be outdated, so you'll have to rely on that internal updater in Adobe Reader to check for updates instead of the plugin check page.

more options

Johnv351 said

...the latest version of FireFox (ver 47.0.1).

Firefox 47.0.1 is old as the latest Release from www.mozilla.org/firefox/all and in internal update is 49.0.1 https://www.mozilla.org/firefox/releases/