Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox won't keep addons installed and enabled

  • 13 回覆
  • 1 有這個問題
  • 670 次檢視
  • 最近回覆由 FredMcD

more options

Every time I reboot my computer, Firefox asks me to reinstall all my add-ons. After reinstalling and enabling them everything is fine. The next time I start Firefox, most of the add-ons appear to be working, but he add-ons manager tells me I have no extensions of that type installed. That state persists until the next time it asks to reinstall the add-ons. That always happens on reboot as I said, but also sometimes after running a different program such as a full-screen game, and sometimes seemingly at random. I have tried refreshing Firefox twice but the problem persists.

I did not add or remove any add-ons before this problem started. There was a Windows 10 update just before this began, perhaps it's related? I've been running Windows 10 home for a long time without any incident of this kind.

I'd be grateful for any suggestions, thanks!

被選擇的解決方法

所有回覆 (13)

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete all extensions*.* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

more options

Thanks for replying FredMcD. There is a slight improvement but not a full fix. After rebooting the computer and running a full-frame game, I have not yet been asked to reinstall the add-ons, but the manager is telling me I have no add-ons installed even though some of them are clearly working.

more options

Keep us posted.

more options

It's back to asking to reinstall all add-ons  :(

more options

FredMcD said

You will have to approve the updating one last time.
more options

I've approved the updating at least three times since my original post.

由 J.Graham 於 修改

more options

Try removing those files again. After,

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

FredMcD said

Try removing those files again. After, Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Unfortunately the problem is still there. Thank you for trying FredMcD. I really appreciate it, but at this point I think I will just uninstall, hunt down and delete all related files and try a fresh installation.

more options

選擇的解決方法

more options

Well, I'm glad I checked back here before reinstalling, this saved me a lot of work. The new profile has been working without a glitch or even a hint of one. Thank you so much FredMcD, I'm very happy!

more options

Glad to help. Safe Surfing.

Do you need help transferring the old profile to the new one?

more options

No, thanks. Everything is all set up already.