X
點擊此處開啟此網站的行動版。

技術支援討論區

if playback doesn't begin shortly, try restarting your device - SOLVED

已張貼

Win 10 pro, version 1607, os build 14393.321 Firefox 49.0.1

For the past few days some videos will not play in firefox, not on my laptop, my kindle fire and my galaxy 3 phone, and yet the videos work on any other browser (Chrome, Pale Moon, Edge) I have on my devices. It either says, "if playback doesn't begin shortly, try restarting your device" or the swirling circle just keeps on swirling to a black background.

I fix computers for a living and have done all of the standards: restarted my laptop, cleared cache/cookies, tested in safe mode, un/re-installed firefox, my drivers are the way they are supposed to be, ensured my plugins are all active and I had the latest versions of flash, java, and real player.

Then I went up a notch: installed a VLC add-on, disabled hardware acceleration and restarted ff, made sure my firewall and antivirus programs trust plugin-container.exe, and followed the instructions from here: https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows,

What gives? And why doesn't FireFox have a fix for this miserable problem?


SOLVED (for me): Installing YouTube Flash Player helped, but only for the youtube video part: https://addons.mozilla.org/en-us/firefox/addon/youtube-flash-player/?src=ss

Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.

Win 10 pro, version 1607, os build 14393.321 Firefox 49.0.1 For the past few days some videos will not play in firefox, not on my laptop, my kindle fire and my galaxy 3 phone, and yet the videos work on any other browser (Chrome, Pale Moon, Edge) I have on my devices. It either says, "if playback doesn't begin shortly, try restarting your device" or the swirling circle just keeps on swirling to a black background. I fix computers for a living and have done all of the standards: restarted my laptop, cleared cache/cookies, tested in safe mode, un/re-installed firefox, my drivers are the way they are supposed to be, ensured my plugins are all active and I had the latest versions of flash, java, and real player. Then I went up a notch: installed a VLC add-on, disabled hardware acceleration and restarted ff, made sure my firewall and antivirus programs trust plugin-container.exe, and followed the instructions from here: https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows, What gives? And why doesn't FireFox have a fix for this miserable problem? -------- SOLVED (for me): Installing YouTube Flash Player helped, but only for the youtube video part: https://addons.mozilla.org/en-us/firefox/addon/youtube-flash-player/?src=ss Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.

被選擇的解決方法

cadwellm said

Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.

Could you give examples of pages where the videos give an error message with autoplay disabled? Perhaps the developers can find a way to not play the video without causing the page to display an error.

從原來的回覆中察看解決方案 3

額外的系統細節

已安裝的外掛程式

  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 23.0 r0

應用程式

  • Firefox 49.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/49.0.1/WINNT/en-US/

擴充套件

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AdBlocker for YouTube™ 0.2.3 (jid1-q4sG8pYhq8KGHs@jetpack)
  • Adguard AdBlocker 2.3.8 (adguardadblocker@adguard.com)
  • Awesome Screenshot - Capture, Annotate & More 3.0.14 (jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack)
  • Classic Theme Restorer 1.5.7 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Classic Toolbar Buttons 1.5.3 (CSTBB@NArisT2_Noia4dev)
  • Customizations for Adblock Plus 1.0.5 (customization@adblockplus.org)
  • Disconnect 3.15.3.1-signed.1-signed (2.0@disconnect.me)
  • Element Hiding Helper for Adblock Plus 1.3.9 (elemhidehelper@adblockplus.org)
  • Enhancer for YouTube™ 2.0.14 (enhancerforyoutube@maximerf.addons.mozilla.org)
  • Google Redirects Fixer 2.1.0 (jid1-zUrvDCat3xoDSQ@jetpack)
  • LastPass 3.3.1 (support@lastpass.com)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pin It button 1.37.9 (jid1-YcMV6ngYmQRA2w@jetpack)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Resurrect Pages 3 ({0c8fbd76-bdeb-4c52-9b24-d587ce7b9dc3})
  • S3.Google Translator 5.25 (s3google@translator)
  • Save Button for Pinterest 49.1 ({677a8f98-fd64-40b0-a883-b8c95d0cbf17})
  • Session Manager 0.8.1.12 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Thumbnail Zoom 1.4.3.1-signed.1-signed ({E10A6337-382E-4FE6-96DE-936ADC34DD04})
  • Vlc context menu 0.8.1-signed.1-signed (vlcplaylist@helgatauscher.de)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Wiktionary and Google Translate 7.5 (googledictionary@toptip.ca)
  • Xmarks 4.3.19 (foxmarks@kei.com)
  • YouTube™ Flash® Player 1.7.0 (jid1-HAV2inXAnQPIeA@jetpack)
  • Avast Online Security 10.3.3.44 (wrc@avast.com) (Inactive)
  • Avast SafePrice 10.3.5.39 (sp@avast.com) (Inactive)
  • Google Translator for Firefox 2.1.0.5.1.1-signed (translator@zoli.bod) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GTX 560M
  • adapterDescription2:
  • adapterDeviceID: 0x1251
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvamwu.inf_amd64_d4715679184092a8\nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterSubsysID: 204a1043
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.321
  • driverDate: 8-1-2016
  • driverDate2:
  • driverVersion: 21.21.13.6909
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560M Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 是
  • 輔助功能: 是
jscher2000
  • Top 10 Contributor
8767 個解決方法 71704 個答案

選擇的解決方法

cadwellm said

Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.

Could you give examples of pages where the videos give an error message with autoplay disabled? Perhaps the developers can find a way to not play the video without causing the page to display an error.

''cadwellm [[#question-1143141|said]]'' <blockquote>Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.</blockquote> Could you give examples of pages where the videos give an error message with autoplay disabled? Perhaps the developers can find a way to not play the video without causing the page to display an error.

有幫助的回覆

I uploaded images of two different sites, and the videos that caused me to finally say, "enough is enough!", and go hunting for the elusive answer(s).

I uninstalled YouTube Flash Player, and changed media.autoplay.enabled back to false, restarted FF, then took the snapshots. Then I reinstalled YouTube Flash Player, and tried both videos. The Youtube video (the one with the error message) worked but the other one (the one that stayed on the swirly of death) didn't. So I changed media.autoplay.enabled back to true, restarted FF and then both videos loaded the way they should.

This just kind of verified that it was the workaround for my laptop.

Also, I only needed to install the YouTube Flash Player add-on in the FF on my Galaxy 3 and both of the same videos started working correctly on my smartphone.

My Kindle Fire won't let me get the YouTube Flash Player add-on though (install button is greyed out) so will have to see what I can do there.

Hope this helps.

I uploaded images of two different sites, and the videos that caused me to finally say, "enough is enough!", and go hunting for the elusive answer(s). I uninstalled YouTube Flash Player, and changed media.autoplay.enabled back to false, restarted FF, then took the snapshots. Then I reinstalled YouTube Flash Player, and tried both videos. The Youtube video (the one with the error message) worked but the other one (the one that stayed on the swirly of death) didn't. So I changed media.autoplay.enabled back to true, restarted FF and then both videos loaded the way they should. This just kind of verified that it was the workaround for my laptop. Also, I only needed to install the YouTube Flash Player add-on in the FF on my Galaxy 3 and both of the same videos started working correctly on my smartphone. My Kindle Fire won't let me get the YouTube Flash Player add-on though (install button is greyed out) so will have to see what I can do there. Hope this helps.

由 cadwellm 於 修改

jscher2000
  • Top 10 Contributor
8767 個解決方法 71704 個答案

Thanks.

I don't understand what's happening with the AOL one (http://www.aol.com/article/news/2016/.../21475326/). Someone needs to look at that in more detail.

With the embedded YouTube video, I have to click on triangle to start the player, but Firefox views the player starting as an autoplay, so then I have to click pause and then play again. It is a limitation of this setting that Firefox can pause the video, but can't fix the appearance of the controls, so having two extra clicks is not unusual. What seems very odd is that the first click doesn't bypass the block on autoplay. It must be something about the way the script works there (either the site's script or the way the YouTube embed works).

Thanks. I don't understand what's happening with the AOL one ([http://www.aol.com/article/news/2016/09/19/mysterious-island-that-rotates-on-its-own-axis-discovered-in-arg/21475326/]). Someone needs to look at that in more detail. With the embedded YouTube video, I have to click on triangle to start the player, but Firefox views the player starting as an autoplay, so then I have to click pause and then play again. It is a limitation of this setting that Firefox can pause the video, but can't fix the appearance of the controls, so having two extra clicks is not unusual. What seems very odd is that the first click doesn't bypass the block on autoplay. It must be something about the way the script works there (either the site's script or the way the YouTube embed works).

提出問題者

Before I started having these video problems in FF I had to do what you were talking about in YouTube - click the play arrow, hit pause, hit play arrow again before the video would start. But, since I installed the YouTube Flash Player, I only have to click once on the play arrow and videos start playing without any extra clicks (like they used to...and are supposed to do).

I don't know what caused this to happen but have an inkling it has quite a bit to do with the Windows 10 anniversary push. (Yeah, good thing that update isn't causing any problems for anyone. /rolling eyes)

My son and I received that update around the same time and we both ended up with the same video difficulties at the same time as well. In his case he pretty much wrote off FF and went fully to Chrome. So, if two of us ended up with the same problem, about the same time, then you know there are more out there also experiencing this irritation. And the more Microsoft sends out that push the more people will probably get this type of video problem.

That's kind of why I posted what I had tried as well as what I was able to figure out.

Hopefully Mozilla will be able to shed some light on this problem.

Before I started having these video problems in FF I had to do what you were talking about in YouTube - click the play arrow, hit pause, hit play arrow again before the video would start. But, since I installed the YouTube Flash Player, I only have to click once on the play arrow and videos start playing without any extra clicks (like they used to...and are supposed to do). I don't know what caused this to happen but have an inkling it has quite a bit to do with the Windows 10 anniversary push. (Yeah, good thing that update isn't causing any problems for anyone. /rolling eyes) My son and I received that update around the same time and we both ended up with the same video difficulties at the same time as well. In his case he pretty much wrote off FF and went fully to Chrome. So, if two of us ended up with the same problem, about the same time, then you know there are more out there also experiencing this irritation. And the more Microsoft sends out that push the more people will probably get this type of video problem. That's kind of why I posted what I had tried as well as what I was able to figure out. Hopefully Mozilla will be able to shed some light on this problem.
LorenAmelang 0 個解決方法 3 個答案

Another Win 10 Anniversary user here, with Firefox 50.1.0. Had manually disabled autoplay, YouTube would work with Play-Pause-Play, but Vevo player totally refused to work. My solution:

https://addons.mozilla.org/en-US/firefox/addon/autoplay-toggle/?src=ss

NOTE! If you disabled autoplay before installing this add-on, it will reset to disable autoplay upon Firefox restart. On the other hand, if you enabled autoplay before installing this add-on, it will reset to enable autoplay upon restart.

Another Win 10 Anniversary user here, with Firefox 50.1.0. Had manually disabled autoplay, YouTube would work with Play-Pause-Play, but Vevo player totally refused to work. My solution: [https://addons.mozilla.org/en-US/firefox/addon/autoplay-toggle/?src=ss https://addons.mozilla.org/en-US/firefox/addon/autoplay-toggle/?src=ss] NOTE! If you disabled autoplay before installing this add-on, it will reset to disable autoplay upon Firefox restart. On the other hand, if you enabled autoplay before installing this add-on, it will reset to enable autoplay upon restart.