搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable autocompleting .com when pasting in searchs address box

  • 7 回覆
  • 3 有這個問題
  • 133 次檢視
  • 最近回覆由 roastedroach

more options

Sometimes, apparently when I past in a search term into the address box for a quick search with the default search engine, Firefox adds ".com" at the end and goes to some unwanted website instead. To be clear, this is not the same behavior as when typing something, and a box with suggestions drops down. It happens when I copy paste something (not all the time for some reason) and when this happens, I must manually remove the ".com" which is very annoying. Sometimes, I accidentally press enter and instead of a google search - I end up on some dubious sites. How do I disable this?

被選擇的解決方法

Here's my understanding: let's say you have visited Yahoo at least once and you type yah in the address bar:

If autofill is enabled (the default setting):

(1) Firefox usually will display yahoo.com/ in the address bar and if you press Enter, Firefox will go to that site.

If autofill is disabled (browser.urlbar.autoFill => false):

(2) Normally the keyword search feature will send yah to your default search engine.

  • If your default search engine is a custom Google search plugin with the "I'm Feeling Lucky" code included in the URL, you would go straight to the site Google felt was the best match.

If keyword search is disabled (keyword.enabled => false):

(3) Normally Firefox will check whether yah is a valid server address (perform a DNS query) and, if it is, go to http://yah/

(4) If it's not a valid server address, Firefox will apply the fixup feature and go to http://www.yah.com/

  • If you want to disable fixup, the preference for that is browser.fixup.alternate.enabled (default: true)
  • If you just want to test whether fixup is causing the problem, you can change the suffix from .com to .whatever by editing the browser.fixup.alternate.suffix preference
從原來的回覆中察看解決方案 👍 1

所有回覆 (7)

more options

Hello roastedroach, try the next :

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config "This might void your warranty!" warning page may appear.
    Click I accept the risk! to continue to the about:config page.
  3. In the seach field copy/paste the next bold : browser.urlbar.autocomplete.enabled
  4. double-click on it to, make it false
  5. close the about:config tab, exit firefox and restart it.

thank you

more options

Disabling this function do not help, and it appears the issue isn't related to that function at all. Moreover, it is hard to replicate. Out of 10 tries that I just did, it only happened once (maybe even less frequently on regular use, but damn is it annoying when it happens). It happens when I copy paste single words, and never when the last letter was typed rather than copied.

由 roastedroach 於 修改

more options

See Address bar autocomplete in Firefox - Search your bookmarks, history and tabs under the section, "Prevent Firefox from automatically completing URLs". (Set the preference browser.urlbar.autoFill to false in about:config)

more options

AliceWyman said

See Address bar autocomplete in Firefox - Search your bookmarks, history and tabs under the section, "Prevent Firefox from automatically completing URLs". (Set the preference browser.urlbar.autoFill to false in about:config)

This didn't help either :(

more options

You could try basic troubleshooting ... see Troubleshoot and diagnose Firefox problems ... except that's hard to do when problems only occur sporadically.

You could try a new Firefox "test" profile and use that for awhile, to see if the problem is profile-related. A new profile will be missing passwords, history, bookmarks, and other customization but you can always go back to your default profile after testing. See Profile Manager - Create, remove, or switch Firefox profiles.

more options

選擇的解決方法

Here's my understanding: let's say you have visited Yahoo at least once and you type yah in the address bar:

If autofill is enabled (the default setting):

(1) Firefox usually will display yahoo.com/ in the address bar and if you press Enter, Firefox will go to that site.

If autofill is disabled (browser.urlbar.autoFill => false):

(2) Normally the keyword search feature will send yah to your default search engine.

  • If your default search engine is a custom Google search plugin with the "I'm Feeling Lucky" code included in the URL, you would go straight to the site Google felt was the best match.

If keyword search is disabled (keyword.enabled => false):

(3) Normally Firefox will check whether yah is a valid server address (perform a DNS query) and, if it is, go to http://yah/

(4) If it's not a valid server address, Firefox will apply the fixup feature and go to http://www.yah.com/

  • If you want to disable fixup, the preference for that is browser.fixup.alternate.enabled (default: true)
  • If you just want to test whether fixup is causing the problem, you can change the suffix from .com to .whatever by editing the browser.fixup.alternate.suffix preference
more options

jscher2000 said

(4) If it's not a valid server address, Firefox will apply the fixup feature and go to http://www.yah.com/
  • If you want to disable fixup, the preference for that is browser.fixup.alternate.enabled (default: true)
  • If you just want to test whether fixup is causing the problem, you can change the suffix from .com to .whatever by editing the browser.fixup.alternate.suffix preference

This solved the problem. Thank you!