搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Bookmarks toolbar doesn't show or accept bookmarks.

  • 7 回覆
  • 1 有這個問題
  • 1223 次檢視
  • 最近回覆由 coffent

more options

When I start Firefox, with add-ons either enabled or disabled - it makes no difference, the Bookmarks toolbar shows as empty. I can't drag a URL to the toolbar (I get the "not allowed" sign). I can drag the URL to the Bookmarks menu and thence to the Bookmarks toolbar listing. The URL appears in this listing but not on the actual toolbar, which remains blank. Any ideas?

被選擇的解決方法

I'm curious why the word "Bookmarks" appears on your Bookmarks Toolbar in the first screen shot. What does that do, if anything?

Could you try the steps in my first reply using Customize: https://support.mozilla.org/questions/1142304#answer-924869

To make that clearer, I'm attaching a screenshot of the item that need to be there in order to actually see bookmarks on the Bookmarks Toolbar.

從原來的回覆中察看解決方案 👍 2

所有回覆 (7)

more options

As you may know, toolbar controls and buttons can be moved around using the Customize feature. When you view the Bookmarks Toolbar in Customize mode, you should see a large item called "Bookmarks Toolbar Items" on the Bookmarks Toolbar -- by default, it is at the left end of the bar.

Could you check to make sure it's still there? If not, can you find it -- for example, among the unused buttons/controls on the Customize tab -- and move it back into position? Or if you can't find it anywhere, please click the Restore Defaults button at the bottom of the Customize tab to see whether that fixes the bar. This article should get you to the starting line:

Customize Firefox controls, buttons and toolbars

more options

Oops, I just noticed you use the Roomy Bookmarks Toolbar extension -- thank you for sharing your extensions list.

You might double-check whether this add-on is causing the problem by disabling it on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find the extension on the right side and click its Disable button.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

And you mentioned you already tried that, so "Never Mind!"

由 jscher2000 於 修改

more options

Thanks for your suggestions. Yes, the Bookmarks toolbar shows. I've attached two screenshots, one with add-ons disabled, and the other with them enabled. In each case the toolbar shows, but is otherwise blank. In the addons-enabled case it says "Bookmarks"; in addition I've opened the menu to show that there purportedly are two URLs bookmarked.

more options

選擇的解決方法

I'm curious why the word "Bookmarks" appears on your Bookmarks Toolbar in the first screen shot. What does that do, if anything?

Could you try the steps in my first reply using Customize: https://support.mozilla.org/questions/1142304#answer-924869

To make that clearer, I'm attaching a screenshot of the item that need to be there in order to actually see bookmarks on the Bookmarks Toolbar.

more options

Thanks again.

LONG STORY: When I started Firefox in Safe Mode and under Customize reset everything to default as you suggested, the Bookmarks toolbar *did* show the two bookmarks I put there. I restarted Firefox in normal mode but now the bookmarks were gone. I disabled *all* add-ons, restarted in Safe Mode, reset to defaults, verified that the bookmarks showed, then restarted in normal mode. Even though I had all add-ons disabled, the bookmarks were once again missing! After at least one more repetition of this cycle, I got Firefox running in normal mode with the bookmarks showing. I re-enabled the add-ons one by one, and everything is now fine. I note that in Roomy Bookmarks there is an option to "Hide bookmarks names", which when checked, reproduces the problem. It's possible that it was inadvertently checked, though it was unchecked when I looked at it and I never manually unchecked it; and even then I don't see how it could have affected things when the add-on was disabled!

SHORT STORY: Everything seems to be working fine now - thanks!

more options

coffent said

I note that in Roomy Bookmarks there is an option to "Hide bookmarks names", which when checked, reproduces the problem.

Thanks, I was thinking -- when I saw your first screenshot and read some reviews of Roomy -- that possibly this combination of settings might cause the problem:

(1) Add-on #1 hides bookmark names so you only see the icons [Roomy] (2) Add-on #2 hides toolbar button icons and shows their text labels

If Add-on #2 applies to the Bookmarks Toolbar and fails to override Add-on #1, then both icons and labels would be invisible on that bar.

If Add-on #2 is CTR, does it have a way to only hide icons on other bars, and not on the Bookmarks Toolbar? Well, anyway, if you like seeing the names, no reason to look into that further.

more options

Thanks for the further info. As you suggest, I'm happy seeing the names so I'm considering the problem solved.