Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Tearing while watching embedded video in Linux

  • 3 回覆
  • 2 有這個問題
  • 858 次檢視
  • 最近回覆由 tomadk

more options

I am experiencing an annoying horizontal screen tearing while watching embedded videos in Firefox 49 on Linux Mint 17.3 KDE 64bit. The issue is only present in embedded view, switching to full screen view stops this behaviour almost every time. It happens both with HTML5 video and flash video. Any suggestions?


In case anyone should mind, I got this issue solved by enabling vsync in desktop settings :)

從原來的回覆中察看解決方案 👍 0

All Replies (3)

more options


We are currently aware of this bug. Please see bug 1304360 for more information about the situation.

This issue can currently be solved by disabling hardware acceleration on Firefox.

The developers need your help to solve this issue. If possible, can you please enter about:support in the Firefox address bar. This page contains information about your system and Firefox. Please click the Copy text to clipboard button and paste the information into this thread. This will help the developers to discover the cause of the issue and create a potential patch.

Thanks in advance for your assistance with this bug. Sorry for any inconvenience.

more options

Disabling hardware acceleration did not solve the issue. Enabling xrender does not solve the issue either but this reduces turds in text fields. Here's the support info:


Navn: Firefox Version: 49.0 Build-ID: 20160923002641 User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0 Styresystem: Linux 3.19.0-32-generic Multiproces-vinduer: 0/1 (Deaktiveret af tilføjelser) Fejlsikret tilstand: false

Fejlrapporter for de seneste 3 døgn

Alle fejlrapporter


Navn: Multi-process staged rollout Version: 1.3 Aktiveret: true ID:

Navn: Pocket Version: 1.0.4 Aktiveret: true ID:

Navn: Web Compat Version: 1.0 Aktiveret: true ID:


Funktioner Komposition: Basic Asynkron panorering/zoom: ingen WebGL Rendering: Intel Open Source Technology Center -- Mesa DRI Intel(R) Skylake DT GT2 H264-afkodning i hardware: No GPU #1 Aktiv: Ja Beskrivelse: Intel Open Source Technology Center -- Mesa DRI Intel(R) Skylake DT GT2 Producent-ID: Intel Open Source Technology Center Enheds-ID: Mesa DRI Intel(R) Skylake DT GT2 Driver-version: 3.0 Mesa 10.5.9

Diagnostik AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: none CairoUseXRender: 0 Beslutnings-log HW_COMPOSITING: blocked by default: Acceleration blocked by platform

Vigtige ændrede indstillinger

accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 true browser.places.importBookmarksHTML: false browser.places.smartBookmarksVersion: 8 true browser.sessionstore.upgradeBackup.latestBuildID: 20160923002641 browser.tabs.remote.autostart.2: true browser.tabs.warnOnClose: false browser.urlbar.suggest.searches: true browser.urlbar.userMadeSearchSuggestionsChoice: true dom.apps.lastUpdate.buildID: 20160923002641 dom.apps.lastUpdate.mstone: 49.0 dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 49.0 font.internaluseonly.changed: true Courier New Droid Serif Droid Sans gfx.crash-guard.glcontext.appVersion: 45.0 gfx.crash-guard.glcontext.deviceID: Mesa DRI Intel(R) Skylake DT GT2 gfx.crash-guard.glcontext.driverVersion: 3.0 Mesa 10.5.9 gfx.crash-guard.status.glcontext: 2 media.gmp-gmpopenh264.abi: x86_64-gcc3 media.gmp-gmpopenh264.lastUpdate: 1471521045 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20160923002641 media.gmp-manager.lastCheck: 1475255834 1 media.webrtc.debug.aec_log_dir: /tmp media.webrtc.debug.log_file: /tmp/WebRTC.log mousewheel.default.delta_multiplier_y: 300 mousewheel.min_line_scroll_amount: 3 network.cookie.prefsMigrated: true network.dns.disablePrefetch: true network.http.speculative-parallel-limit: 0 network.predictor.cleaned-up: true network.prefetch-next: false places.database.lastMaintenance: 1474723730 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 1 print.print_bgcolor: false print.print_bgimages: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11,69 print.print_paper_name: iso_a4 print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8,27 print.print_scaling: 1,00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.sanitize.migrateClearSavedPwdsOnExit: true privacy.sanitize.migrateFx3Prefs: true services.sync.declinedEngines: storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1473503370

Vigtige låste indstillinger

Databasen Places


Incremental GC: true


Aktiveret: false Slå tilgængelighed fra: 0


NSPR Forventet minimumsversion: 4.12 Version i brug: 4.12

NSS Forventet minimumsversion: 3.25 Version i brug: 3.25

NSSSMIME Forventet minimumsversion: 3.25 Version i brug: 3.25

NSSSSL Forventet minimumsversion: 3.25 Version i brug: 3.25

NSSUTIL Forventet minimumsversion: 3.25 Version i brug: 3.25

Eksperimentelle funktioner


Seccomp-BPF (filtrering af systemkald): true Seccomp tråd-synkronisering: true Navneområder: true Sandboxning af medie-plugin: true

more options


In case anyone should mind, I got this issue solved by enabling vsync in desktop settings :)