Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

why is firefox using 49% of my battery?

  • 11 回覆
  • 5 有這個問題
  • 5214 次檢視
  • 最近回覆由 FredMcD

more options

I had a major update of Windows10 automatically, a few days ago since then my battery dies very quickly when I looked up laptopmag.com/articles/battery-saver-windows-10> I eventually found where I could look at what was using the battery up. It stated that firefox is using 49% of battery each time the laptop is turned on. Could someone tell me how I fix this please. Never had any problems before the Windows10 update.

被選擇的解決方法

Have you tried Firefox in Safe Mode? Please do.

After that,

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

從原來的回覆中察看解決方案 👍 1

All Replies (11)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Hi Fred, Thanks for replying; but I do not understand your reply - I have a reasonable understanding of computers but I have no idea how to start Firefox in Safe Mode, nor what is meant by 'web LInk'.

Would you mind explaining it to me? Thanks, Sandra.

more options
more options

I am not too sure exactly what you found, but the results could be fairly normal. If whatever utility it is reports what programs are running on the computer and ranks them in order, of how much power is used then if you are using Firefox actively then maybe it would be high in the list.

This sort of subject would be best discussed elsewhere, however as it is being asked because firefox is getting the blame I will make a short comment.

You probably need to look at tips in other places for saving battery power. For instance turning down the screen brightness may reduce power consumption, and some laptops have power saving options that reduce the speed and power of the computers brain (the CPU). Incidentally you may also wish to look at tips on prolonging the life of the battery, both in terms of its discharge time each cycle, and it lifetime in Years.

For general Windows 10 related questions and tutorials a popular place to look may be tenforums.com & windowssecrets.com , but there are many other sites on the internet.

more options

P.S. The blue text are links, or hyperlinks or weblinks, whatever term you choose and are clickable and will lead you to the related article or webpage

more options

Hi John, yes your posts are helpful and I will look at them; My main problem was that I had NEVER had problems with the battery having to be re-charged after a 'short' time of use UNTIL the Windows10 update last week! Thanks, Sandra

more options

選擇的解決方法

Have you tried Firefox in Safe Mode? Please do.

After that,

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Possibly the update changed some setting or installed new or changed software. My Windows 10 computer does not have the 1607 Anniversary update of Windows 10 yet.

As the problem is related to the Windows update and many of the factors affecting battery life are Windows settings you probably are better consulting a Windows related site for answers to this problem.

more options

In addition to   John99's   advice may I recommend the Microsoft support forum to post your question:

answers.microsoft.com/en-US/windows/forum/windows_10

Good luck   !

more options

Hi Fred McD.

Yes, I did follow the instructions for starting fire fox in Safe-Mode & so far it looks like it has fixed it.

Thank you to everyone who answered my query, I will look at all the sites suggested, to learn a bit more as well as in case it happens again. Thanks. Sandra.

more options

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.