搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Troubleshoot Error code: SSL_ERROR_BAD_CERT_DOMAIN

more options

google.com is giving this error: Error code: SSL_ERROR_BAD_CERT_DOMAIN

No other sites are. Have tried all steps in several help articles. Anti virus is Panda No malware found google.co.uk works

所有回覆 (6)

more options

That's weird, Google is pretty good at certificates. Does the error message mention what site the certificate is for if it's not for Google? Sometimes you need to click an "Advanced" button on the error page for additional details.

more options

Hm, currently it says this:

www.google.com uses an invalid security certificate. The certificate is only valid for the following names: a248.e.akamai.net, *.akamaized.net, *.akamaihd-staging.net, *.akamaihd.net, *.akamaized-staging.net

Error code: SSL_ERROR_BAD_CERT_DOMAIN

This is a different name than previously however.

more options

Is there anything unusual about how you connect to the internet? You could check whether you have Firefox set to use a proxy server in settings, and switch that off as a test. You can do that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that helps.

An add-on still could override that. I notice you have an extension named "Hotspot Shield Free VPN Proxy – Unblock Sites." Is that something you've had for a while or is it a recent addition?

more options

Nothing unusual. Uninstalled the hotspot add on and tried all the proxy settings but not working.

more options

Maybe you're hitting one poorly configured server in the Akamai CDN. I don't know whether there is a way to bypass it and use another part of the network. Other than clearing cache and cookies, I don't know that there's any way to influence what servers are used to respond to your request.

(Copy/paste follows...)

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

more options

Have tried clearing cache, etc. Issue remains. It did work briefly yesterday though.