搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Getting "SEC_ERROR_UNKNOWN_ISSUER" error when trying to register on guest networks

more options

When using guest networks such as at hotels or businesses, am having problems. Typically these sites redirect your first browser request to their registration page. However, if the initial request is to a secure site such as Google, Firefox generates a SEC_ERROR_UNKNOWN_ISSUER" error with no opportunity to add an exception.

When using guest networks such as at hotels or businesses, am having problems. Typically these sites redirect your first browser request to their registration page. However, if the initial request is to a secure site such as Google, Firefox generates a SEC_ERROR_UNKNOWN_ISSUER" error with no opportunity to add an exception.

被選擇的解決方法

Try entering a short address you don't normally visit like cnn.com, abc.com, nbc.com -- anything that Firefox doesn't have in cache. That should force Firefox to query the hotspot and trigger the authentication page.

If it still tries to bypass, check whether you have Firefox set to use a proxy server and switch that off temporarily. You can do that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that helps.

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options
more options

選擇的解決方法

Try entering a short address you don't normally visit like cnn.com, abc.com, nbc.com -- anything that Firefox doesn't have in cache. That should force Firefox to query the hotspot and trigger the authentication page.

If it still tries to bypass, check whether you have Firefox set to use a proxy server and switch that off temporarily. You can do that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that helps.

more options

That works, as long as the target site does not use https protocol. The issue appears to be that when the target uses https, the redirect does not return the expected certificate, ergo the error.

more options

FermentorDr said

That works, as long as the target site does not use https protocol.

To resolve the HTTPS problem, you can either enter a site that NEVER uses HTTPS, or a new site that Firefox will just assume is HTTP since it doesn't yet know any better.

I find it best to just type something short because if I choose something cached, Firefox may not even hit the hotspot and then I have to reload or try a different site.