搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

No duplex printing

  • 6 回覆
  • 10 有這個問題
  • 267 次檢視
  • 最近回覆由 ashergabbay

more options

Hello. I have a Brother MFC-7460DN printer. It will not print duplex (two sided) from Firefox browser. The printer prints duplex just fine from everywhere else (Word, PDF, Internet Explorer), but not from Firefox. The duplex printing is set as default in the printer properties. I uninstalled the drivers, and installed new ones from Brother website. I went to Firefox browser about:config page and "reset" the print_printer parameter of the printer. But the problem persists. Any ideas? Thank you in advance for your help. Asher

被選擇的解決方法

所有回覆 (6)

more options

Did it use to work with previous versions of Firefox?

more options

Now that you mention it, yes. I don't recall the last time that FF updated to a new version, but I didn't have this problem in the past.

more options

ashergabbay said

The duplex printing is set as default in the printer properties.

Check it from within Firefox, as the system wide settings may not be used or passed thru to Firefox. I have seen that with other Brother and with 2 different Epson printers (with Epson it has specifically said "Not Available" when I was using Firefox, where it worked in any Microsoft program.)


I am working with a Brother MFC-J615W inkjet, but most Brother printers have their various user setting in a similar location in the Brother printer software. You need to do this thru Firefox. 1. {Ctrl+P} then make sure that printer is selected at Printer - Name. 2. Then open Properties. 3. Next select Advanced and then maybe Other print options 4. And if you don't see that preference there, look at all the various menu categories for that pref.

I use Brother printers for two reasons; the ability to use generic ink cartridges and their unmatched support for Linux operating systems. At least when I switched to Brother back in 2008, no one else 'did Linux' as well as Brother.

more options

Yes, of course I checked it from within Firefox, opening the printer properties and making sure they're set to duplex. Except for the standard duplex setting, I went through the entire preferences to see if there was another setting. None.

more options

選擇的解決方法

more options

Thank you Oxylatium! That worked.