搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

how to change my firefox background color from black to white

  • 10 回覆
  • 8 有這個問題
  • 1 次檢視
  • 最近回覆由 John99

more options

Ii was trying to change the light blue colors on the browser and accidentally changed the background color to black. I cannot see anything on the option/ content page to try to change the background color back to white. How can I make the change?

Ii was trying to change the light blue colors on the browser and accidentally changed the background color to black. I cannot see anything on the option/ content page to try to change the background color back to white. How can I make the change?

所有回覆 (10)

more options

See:

  • Options/Preferences -> Content : Fonts & Colors -> Colors
more options

That is rather difficult to get out of. You could try the Windows own high contrast options see if that helps you to see what the browser is doing.

T he option you used will have changed the pref

 browser.display.focus_background_color

Normally that is changed form the options setting. It may also be changed from about:config

but you presumably can not see that either.

The actual change is that the new pref and its value is added to the profile file prefs.js

With Firefox closed back up the file prefs.js, just in case you make it even worse, and then have no choice but to fall back to full default settings. Now with notepad (Or some other text editor but NO T a standard Word Processor ) edit out that pref. T he full line including its value and the terminating semicolon ( a dot above a comma ; ) . Save the file. ( it has to remain as prefs.js not prefs.js.txt) N ow restart Firefox and it should have its default white background.


If that was too difficult deleting the file prefs.js would reset all the prefs to default.

more options

That reply did not make any sense to me at all, sorry, I have the opposite problem, I had my background set to black with lime green font colour, not sure what I did, but now it is white with grey font colour, which I have great difficulty in reading, as I am sight challenged.... Is there any way you can give me a Pathway to fix it? Or do you think it is my WIN 10 settings? I ask for a Pathway, as screen shots just disappear for me & I can barely see the content.... Sorry but your reply was a bit too techie for my level of knowledge! Thanks Sylvia

more options

Type about:preferences#content<enter> in the address bar. Look for Colors.

more options

Sylvia,

Please open this in your Edge browser

https://support.mozilla.org/questions/1130517

Is the problem only with Firefox ? Or is it the whole computer ?

All of these questions are in a forum that you would normally see by using the Firefox browser.

If your problem is with Firefox only then for now use Internet Explorer or edge. I think you probably posted from edge. This thread can be found from this link


If you have problems with the whole computer you should get help from a Windows forum. Note Windows itself will have high contrast options for instance see

Note windows also has a magnifying glass option and a screen reader narrator option


If you have the latest Firefox 49 it also is able to read pages out to you, and should be able to read these posts aloud for you. Just turning to reader view will make the text bigger.

Once you can see the posts we can try to help you further.

The quick solution may be to do a Firefox Refresh

See Refresh Firefox - reset add-ons and settings

Open that article with Firefox. Click the blue Button in that article

You may find the articles and advice on the site it links to useful in making Firefox easier to use

more options

Thanks, John99.......great information! I did ask the question on Microsoft after I posted this & got the links I needed, & with a little tweak here & there, it's all fixed, well, I haven't tried any drop down menus yet, lol... I'll address that later if it is still an issue. But, this is terrific information & I am so grateful for it, I will save this & print out a COPY just in case! No doubt I will have similar problems again! Many thanks Kind regards Sylvia

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

Sorry, Fred McD, I would if I could, but now my black background is back, there are some things I cannot see, that includes the select button for the answer that solved my problem. I do know how it works, MS forums are my friends, & I have had much help over the years. All I can say is, if you can tell me where it is, around the John99 post, I will try & guess where it is & hopefully select it....otherwise maybe you could develop a sense of humour about it all, like me, after all, MS did create WIN 10, with all its faults, not I.

Kind regards Sylvia

more options

Hi   Sylvia   !

You're saying that   MS-forums   are your friends;   have you tried this support forum yet :

answers.microsoft.com/en-US/windows/forum/windows_10

(Just a shot in the dark;   might be worth a try   ....... )

more options

Hi Again Sylvia, I have marked my answer as the solution. edit, oops it is not Sylvia's question - thanks Happy112

If you still have problems because of Windows then trying any of the Windows related fora should enable you to get a solution.

If it is Firefox only a Firefox Refresh may help. If you hare no problems reading this Firefox (mozilla) support thread with Edge but you have problems with Firefox then post back again, using Edge so you can see what you are doing and we will try again to help you further.

由 John99 於 修改