搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens "Index of file:///C:/PROGRA~2/MOZILL~1/" on launch.

  • 6 回覆
  • 15 有這個問題
  • 164 次檢視
  • 最近回覆由 cor-el

more options

I had a malware infection recently, but I've cleared most of it out. The only remaining effect seems to be that, in addition to starting where I left off, launching Firefox opens an additional tab accessing "Index of file:///C:/PROGRA~2/MOZILL~1/". Every scanner I've used says the malware itself is gone, but this effect won't go away.

所有回覆 (6)

more options

You may still have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.


Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.

more options

As mentioned, I returned my settings to their correct state (which, for me, is to "show my windows and tabs from last time"). This opens IN ADDITION to whatever setting I have chosen.

I've also run every one of those antimalware options, getting rid of a few more remnants but not solving the problem.

more options

Are you starting Firefox directly, or from a shortcut? Open the properties of the shortcut.

more options

Oh, yeah, that did it. My Firefox shortcut had been replaced with an identical one pointing to "firefox.bat". Thanks!

more options

Glad to help. Safe Surfing.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program. If a period (.) is appended then this could be causing this issue.