搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loads in taskbar but doesn't display on desktop.

  • 9 回覆
  • 1 有這個問題
  • 1338 次檢視
  • 最近回覆由 FredMcD

more options

Firefox was working until yesterday. Now it loads in the taskbar and popups mini windows but never opens on the desktop so it can be used. I have uninstalled/reinstalled, rebooted...nothing helps. HELP!!! I want my Firefox back.

被選擇的解決方法

FredMcD - - I went back and deleted xulstore.json again, restarted firefox and it worked. Yeah. I had reactivated the Add-Ons so the only thing inactive is the yahoo.toolbar....my favorite. I hope that isn't the source of the problem. Anyway, it came up and I'll keep playing. Thanks for your help.

從原來的回覆中察看解決方案 👍 1

所有回覆 (9)

more options

What is your computer system and Firefox?

Do you have the Firefox icon on your quick launch? Right click on the icon and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit.

more options

Can you open the system menu via Alt+Space in case the window is off screen and resize/move the window into view?

Try to rename/remove the xulstore.json file in the Firefox profile folder.

more options

FredMcD - I am running the current version of Windows 10 and I assume the current version of Firefox as I have downloaded it repeatedly. The Firefox Icon displays in the taskbar at the bottom. When the cursor hovers over the icon a small pop-up window of firefox appears but that is all. It will not enlarge for use.

Cor-el...after enabling my ability to see hidden files I was able to delete the xulstore.json file but had no success in solving the problem. Firefox still behaves the same.

Firefox was working on my machine until two days ago...then it started this behavior. Everything else on the taskbar works as it should.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

FredMcD - Thank you. I was able to start Firefox in Safe Mode and get a usable screen display but if I don't start in safe mode it has the same bad behavior. ie. the problem still exists but I do get a display when I start in safe mode.

more options

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.


It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

FredMcD - The only extension was Yahoo Toolbar and I disabled it...no change. There were numerous Add-ons - I made all inactive - no change. Thanks for trying to help me out. I love FF, there is nothing else that comes close and I miss it.

more options

選擇的解決方法

FredMcD - - I went back and deleted xulstore.json again, restarted firefox and it worked. Yeah. I had reactivated the Add-Ons so the only thing inactive is the yahoo.toolbar....my favorite. I hope that isn't the source of the problem. Anyway, it came up and I'll keep playing. Thanks for your help.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.