Search Support

Font rendering not correct - Windows 10

  • 8 回覆
  • 5 有這個問題
  • 3727 次檢視
  • 最近回覆由 FredMcD

more options

Hi all, I am seeing this problem since I wiped my computer and installed Windows 10 a couple of days ago. Just to clarify, everything was fine on Windows 8.1, which I was previously using.

I see that fonts are not correctly renderded, there is a lot of aliansing and they're quite thin. They are ugly. The problem is well described in this ticket. https://support.mozilla.org/it/questions/1115938.

I have tried to reset Firefox, run withot plugin, nothing changes. Here you can find values I see in about:support. I use Firefox in Italian, i have translated these values in English. I don't remember what values I had in W8.1, but my suspect is that my GPU (AMD HD7950) is not detected/enabled correctly by Firefox. http://pastebin.com/QEmYBXpp

I noticed: - DirectWrite enabled false - Assert D3D11 device creation failed: 0x887a0004 - Support for H264 HW decoding No; Hardware video decoding disabled or blacklisted

Maybe I should not say this (lol) but Chrome does render fonts properly on my machine.

Can somebody help me please? Thanks

被選擇的解決方法

Hi,

I have found the root cause of the problem. It's AMD drivers.

I went for a clean uninstall in safe mode via Display Driver Uninstaller and installed AMD Crimson 16.5.2.1 (previous version), now everything is back on! Firefox is smooth, and fonts can be finally admired.

See attached screenshots before and after. It's in Italian, but you can get the translated strings from pastebin or compare it to your system.

FYI the version of AMD drivers that was causing the problem it's not a beta, it's the last production version I get when I select my GPU (v16.5.3). I have installed v16.5.2.1 and it's all good.

Should this problem be reported to Firefox or AMD? Other browsers (Chrome) were rendering fine.

Thanks for your help anyway.

從原來的回覆中察看解決方案 👍 0

All Replies (8)

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Mac You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

It was already enabled. FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

No difference, Safe Mode tried already.

Also h264 decoding is disabled, pushing my CPU to 30% when watching a video on Youtube (forced h264). And I've got an i7 4770k. I know this is a different problem, but I think is linked to this one.

由 olivercervera 於 修改

more options

I'm not sure why Firefox isn't using your GPU but for best results we need to figure out a way to get that working.

For comparison on Windows 7:

Adapter Description: Intel(R) HD Graphics 5500 Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32 Adapter RAM: Unknown Asynchronous Pan/Zoom: none Device ID: 0x1616 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.17568) Driver Date: 11-11-2014 Driver Version: 10.18.10.4013 GPU #2 Active: false GPU Accelerated Windows: 7/7 Direct3D 11 (OMTC) Subsys ID: 503617aa Supports Hardware H264 Decoding: Yes Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0) windowLayerManagerRemote: true AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

I'm not sure if there is a known issue with your ATI hardware/drivers, or whether some startup diagnostic failed and that's why acceleration isn't working for fonts. ???

more options

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

Does it make a difference whether hardware acceleration is enabled or disabled?

more options

cor-el said

Can you attach a screenshot?
  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB
Does it make a difference whether hardware acceleration is enabled or disabled?

Sorry, a screenshot of what?

You mean turning On and Off "use Hardware acceleration when available" from settings>Advanced? No, it does not make a difference at all.

I also use Thunderbird. The same page clearly shows: - Direct2D enabled: false - DirectWrite enabled: false - WebGL Rendering: false

more options

選擇的解決方法

Hi,

I have found the root cause of the problem. It's AMD drivers.

I went for a clean uninstall in safe mode via Display Driver Uninstaller and installed AMD Crimson 16.5.2.1 (previous version), now everything is back on! Firefox is smooth, and fonts can be finally admired.

See attached screenshots before and after. It's in Italian, but you can get the translated strings from pastebin or compare it to your system.

FYI the version of AMD drivers that was causing the problem it's not a beta, it's the last production version I get when I select my GPU (v16.5.3). I have installed v16.5.2.1 and it's all good.

Should this problem be reported to Firefox or AMD? Other browsers (Chrome) were rendering fine.

Thanks for your help anyway.

由 olivercervera 於 修改

more options

I'm not sure whether this is a known issue with the newer driver or not, but sometimes Firefox will disable a driver (or some features of a driver) if it causes a lot of crashes. You might look at the update again in a couple weeks after Firefox 47 is released since there aren't going to be any more fixes for Firefox 46.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.