搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Recently started having redirection problems with Amazon

  • 30 回覆
  • 7 有這個問題
  • 7373 次檢視
  • 最近回覆由 pawnslinger

more options

I have recently started having the redirection issue with Amazon. I click on a product link on the Amazon website and now I get the message that this page is not properly redirecting. I try Chrome and it works fine. I have cleared my cache, insured that cookies are accepted and I have searched for solutions. I did find several others reporting this problem, but none of their solutions worked for me. The odd thing is that some links on Amazon still work properly. But others don't. Here is a link that is not working for me: https://www.amazon.com/ChickenFuel-OMRI-Listed-Organic-Compost-Fertilizer/dp/B0102PAT9O?ie=UTF8&fpl=fresh&redirect=true&ref_=s9_cartx_gw_g86_i3_r

Here is another link that works fine: https://www.amazon.com/gp/product/B00VOLHKHA/ref=br_asw_pdt-2?pf_rd_m=ATVPDKIKX0DER&pf_rd_s=desktop-4&pf_rd_r=57NDHMP0ADH9BCSMAPX8&pf_rd_t=36701&pf_rd_p=4ccd27f1-4604-40d9-92c7-3318b57f8ba8&pf_rd_i=desktop

And, as I wrote above, all these links work in other browsers, i.e. Chrome. But I hate switching to Chrome so I can use Amazon. As far as I can tell, Amazon is the only website that has this issue. I browse a lot, so that seems strange to me.

被選擇的解決方法

pawnslinger said

jscher2000 said
If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it). Start Firefox back up again. Any change with Amazon?

YES! Renaming this file did the trick!! Amazon now is working properly.

Is this something that I will routinely have to fix?? Or is this a 1 time kind of thing?

I think it must be some remote corner of Amazon that set strict transport security on your Firefox, since as far as I know this is an uncommon problem and the result obviously is very dysfunctional.

Do you use any less common features, such as being a vendor or an affiliate?

從原來的回覆中察看解決方案 👍 0

所有回覆 (10)

more options

Yes its a good workaround but irts a shame we have to use a crutch

more options

Are there any more url examples this is happening in?

more options

cynicscorner said

However on my problem machine, every Amazon page comes up https including the home page, and nothing I do can change that. If I hard-type www.amazon.com, I am taken to https://www.amazon.com/. Pages that are supposed to be secure (like shopping cart, order history, etc.) work fine, but the product pages, which normally would have http links instead show https links and they cause the redirect error; manually changing the address to http results in the browser sitting there “Waiting…” (as does trying to access a product page directly from Google).

First the obvious thing that distinguishes a private window from a regular window: did you try clearing Amazon cookies??

While viewing a page on the site (that will load, in a non-private window), try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, amazon.com should be pre-filled in the search box at the top of the dialog so you can remove the site's cookies individually without affecting other sites.

Then try http://www.amazon.com/ -- any improvement? Does it still work if you log into your Amazon account or does the problem return?


If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it).

Start Firefox back up again. Any change with Amazon?

more options

Oops, another thing that distinguish private windows from regular windows is that Tracking Protection is automatically enabled. This article describes that feature and how you can experiment with disabling it to see whether the problem returns in a private window: What happened to Tracking Protection?.

more options

guigs said

Are there any more url examples this is happening in?

Not that I know of... of course, there are quite a few Amazon url's where this happens. I would say about 75 percent of the Amazon url's that I try exhibit this behavior.

more options

jscher2000 said

cynicscorner said
However on my problem machine, every Amazon page comes up https including the home page, and nothing I do can change that. If I hard-type www.amazon.com, I am taken to https://www.amazon.com/. Pages that are supposed to be secure (like shopping cart, order history, etc.) work fine, but the product pages, which normally would have http links instead show https links and they cause the redirect error; manually changing the address to http results in the browser sitting there “Waiting…” (as does trying to access a product page directly from Google).

First the obvious thing that distinguishes a private window from a regular window: did you try clearing Amazon cookies??

While viewing a page on the site (that will load, in a non-private window), try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, amazon.com should be pre-filled in the search box at the top of the dialog so you can remove the site's cookies individually without affecting other sites.

Then try http://www.amazon.com/ -- any improvement? Does it still work if you log into your Amazon account or does the problem return?


If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it).

Start Firefox back up again. Any change with Amazon?

Yes, I have tried just about everything except standing on my head. The only thing I know for sure... Chrome works and Firefox Private Windows works. Why would Chrome work for a regular window (same url's as far as I can tell, including the https) and Firefox not work??

I am changing from Chrome to Firefox as my standard browser. Because Chrome is dropping support for Vista.

As far as I can tell, the only visible difference is that https is always used in a normal window, and plain url's (www.amazon.com) in the private window.

Of course, in a private window I have to manually log into Amazon, so when I first bring up the web page Amazon doesn't realize that I am a registered user of Amazon -- until I login, of course.

more options

jscher2000 said

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it). Start Firefox back up again. Any change with Amazon?

Wow. I had previously and repeatedly cleared cookies, used safe mode, etc. to no avail, but getting rid of that txt file did the trick.

This is awesome. I can't thank you enough.

more options

jscher2000 said

cynicscorner said
However on my problem machine, every Amazon page comes up https including the home page, and nothing I do can change that. If I hard-type www.amazon.com, I am taken to https://www.amazon.com/. Pages that are supposed to be secure (like shopping cart, order history, etc.) work fine, but the product pages, which normally would have http links instead show https links and they cause the redirect error; manually changing the address to http results in the browser sitting there “Waiting…” (as does trying to access a product page directly from Google).

First the obvious thing that distinguishes a private window from a regular window: did you try clearing Amazon cookies??

While viewing a page on the site (that will load, in a non-private window), try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, amazon.com should be pre-filled in the search box at the top of the dialog so you can remove the site's cookies individually without affecting other sites.

Then try http://www.amazon.com/ -- any improvement? Does it still work if you log into your Amazon account or does the problem return?


If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it).

Start Firefox back up again. Any change with Amazon?

YES! Renaming this file did the trick!! Amazon now is working properly.

Is this something that I will routinely have to fix?? Or is this a 1 time kind of thing?

more options

選擇的解決方法

pawnslinger said

jscher2000 said
If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it). Start Firefox back up again. Any change with Amazon?

YES! Renaming this file did the trick!! Amazon now is working properly.

Is this something that I will routinely have to fix?? Or is this a 1 time kind of thing?

I think it must be some remote corner of Amazon that set strict transport security on your Firefox, since as far as I know this is an uncommon problem and the result obviously is very dysfunctional.

Do you use any less common features, such as being a vendor or an affiliate?

more options

jscher2000 said

pawnslinger said
jscher2000 said
If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it). Start Firefox back up again. Any change with Amazon?

YES! Renaming this file did the trick!! Amazon now is working properly.

Is this something that I will routinely have to fix?? Or is this a 1 time kind of thing?

I think it must be some remote corner of Amazon that set strict transport security on your Firefox, since as far as I know this is an uncommon problem and the result obviously is very dysfunctional.

Do you use any less common features, such as being a vendor or an affiliate?

No. I am a normal customer. I am somewhat hesitant to discuss my habits, but I think I am a fairly ordinary customer. I am certainly not a vendor or affiliate, nothing like that at all. Just a buyer.

  1. 1
  2. 2