X
點擊此處開啟此網站的行動版。

技術支援討論區

How to stop checking for Compability of add ons coming up before Firefox opens ?

已張貼

Every time I open Firefox since version 46.0 a message comes up Checking Compability of Add-ons. When I revert back to previous version it stays the same and I can not stop it. Screenshot will not upload as it says the file is too large.

Every time I open Firefox since version 46.0 a message comes up Checking Compability of Add-ons. When I revert back to previous version it stays the same and I can not stop it. Screenshot will not upload as it says the file is too large.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

應用程式

  • Firefox 46.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-GB/

擴充套件

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • All-in-One Sidebar 0.7.28 ({097d3191-e6fa-4728-9826-b533d755359d})
  • BetterPrivacy 1.74 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Black Youtube Theme 5.6.1-signed ({2c93446d-612b-416d-9af0-b7355797b611})
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • FireShot 0.98.85 ({0b457cAA-602d-484a-8fe7-c1d894a011ba})
  • Gmelius 5.7.7.12.1-signed.1-signed (firefox@gmelius.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Stylish 2.0.6 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • X-notifier 3.5.19 ({37fa1426-b82d-11db-8314-0800200c9a66})
  • S3.Google Translator 5.22 (s3google@translator) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GT 540M
  • adapterDescription2:
  • adapterDeviceID: 0x0df4
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 4-27-2016
  • driverDate2:
  • driverVersion: 10.18.13.6510
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 540M Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 是
  • 輔助功能: 是
philipp
  • Top 25 Contributor
  • Moderator
5320 個解決方法 23502 個答案

hi Mharry, this is usually happening when firefox cannot properly store its preferences in the profile folder. please see How to fix preferences that won't save for common fixes...

hi Mharry, this is usually happening when firefox cannot properly store its preferences in the profile folder. please see [[How to fix preferences that won't save]] for common fixes...
cor-el
  • Top 10 Contributor
  • Moderator
17570 個解決方法 158915 個答案

You can also check for problems with the files in the profile folder that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in ""3-bar" menu button or Tools > Add-ons > Extensions" then check if there is a compatibility update available.

  • click the cogwheel button (left of the Search bar) on the about:addons page to "Check for Updates"

If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences.

You can use this button to go to the current Firefox profile folder:

You can also check for problems with the files in the profile folder that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in ""3-bar" menu button or Tools > Add-ons > Extensions" then check if there is a compatibility update available. *click the cogwheel button (left of the Search bar) on the about:addons page to "Check for Updates" If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox