X
點擊此處開啟此網站的行動版。

技術支援討論區

How to disable "Cancel All Downloads " dialog while directly closing firefox

已張貼

Hello i wana disable "Cancel All Downloads " dialog while directly closing firefox i wanted to turn off this prompt feature !

Hello i wana disable "Cancel All Downloads " dialog while directly closing firefox i wanted to turn off this prompt feature !
附加的畫面擷圖

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

更多資訊

FredMcD
  • Top 10 Contributor
4306 個解決方法 60423 個答案

That is a safety device for if the user tried to close Firefox during a download. Have you been having problems with downloading?

That is a safety device for if the user tried to close Firefox during a download. Have you been having problems with downloading?

提出問題者

No i don't have problem with download i just wanted to remove this feature it's important for a work !

No i don't have problem with download i just wanted to remove this feature it's important for a work !
FredMcD
  • Top 10 Contributor
4306 個解決方法 60423 個答案

There is a setting, but I don't remember where. I've called the big guys to help you. Good luck.

There is a setting, but I don't remember where. I've called the big guys to help you. Good luck.
cor-el
  • Top 10 Contributor
  • Moderator
17673 個解決方法 159870 個答案

有幫助的回覆

There is a pref to define what happens if you close Firefox with active downloads.

  • browser.download.manager.quitBehavior
0: QUIT_AND_RESUME  - downloads should be auto-resumed
1: QUIT_AND_PAUSE   - downloads should be paused
2: QUIT_AND_CANCEL  - downloads should be cancelled

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

There is a pref to define what happens if you close Firefox with active downloads. *browser.download.manager.quitBehavior 0: QUIT_AND_RESUME - downloads should be auto-resumed 1: QUIT_AND_PAUSE - downloads should be paused 2: QUIT_AND_CANCEL - downloads should be cancelled *http://mxr.mozilla.org/mozilla-release/source/toolkit/components/downloads/nsDownloadManager.h You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
FredMcD
  • Top 10 Contributor
4306 個解決方法 60423 個答案

I just checked. browser.download.manager.quitBehavior is not there.

I just checked. ''browser.download.manager.quitBehavior'' is not there.
cor-el
  • Top 10 Contributor
  • Moderator
17673 個解決方法 159870 個答案

It is a so called hidden Integer pref that that only shows on about:config when you would create it yourself. Otherwise the default behavior is assumed.

It is a so called hidden Integer pref that that only shows on about:config when you would create it yourself. Otherwise the default behavior is assumed.

提出問題者

browser.download.manager.quitBehavior This feature is not working on mozilla 38.0 :(

browser.download.manager.quitBehavior This feature is not working on mozilla 38.0 :(
cor-el
  • Top 10 Contributor
  • Moderator
17673 個解決方法 159870 個答案

Hi shubhamchaurasiya

Are you using the Firefox 38 esr version (38.8.0) or the outdated Firefox 38 release version?

This should still work unless maybe you are in Private Browsing mode (don't know about this for sure).

Hi shubhamchaurasiya Are you using the Firefox 38 esr version (38.8.0) or the outdated Firefox 38 release version? *https://support.mozilla.org/kb/Finding+your+Firefox+version This should still work unless maybe you are in Private Browsing mode (don't know about this for sure).

提出問題者

cor-el said

Hi shubhamchaurasiya Are you using the Firefox 38 esr version (38.8.0) or the outdated Firefox 38 release version? This should still work unless maybe you are in Private Browsing mode (don't know about this for sure).

Sorry for late reply! yeah i'm using Firefox v38.0 Only and not in private window mode and i,ve added "browser.download.manager.quitBehavior" integar but it's not working as i expected :( even i alsso wanted to disable all anonoying warnings or errors dialogs :(

''cor-el [[#answer-877513|said]]'' <blockquote> Hi shubhamchaurasiya Are you using the Firefox 38 esr version (38.8.0) or the outdated Firefox 38 release version? *https://support.mozilla.org/kb/Finding+your+Firefox+version This should still work unless maybe you are in Private Browsing mode (don't know about this for sure). </blockquote> Sorry for late reply! yeah i'm using Firefox v38.0 Only and not in private window mode and i,ve added "browser.download.manager.quitBehavior" integar but it's not working as i expected :( even i alsso wanted to disable all anonoying warnings or errors dialogs :(

提出問題者

Even tried with Firefox Latest Version v46.0.1 not working :(

Even tried with Firefox Latest Version v46.0.1 not working :(