搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

The My Yahoo page itself gets error message of "The page isn't redirecting properly"

  • 4 回覆
  • 2 有這個問題
  • 22 次檢視
  • 最近回覆由 jscher2000

more options

I have Firefox V44.0.2 on a Mac OSX 10.11.3. Starting sometime yesterday my homepage of My Yahoo gets the error message shown above. I have tried all of the fixes suggested by Mozilla including deleting history, removing cookies and cache, restarting Firefox in Safe Mode, checking my antivirus software (Sophos Home, which shows no bugs or malware currently).

This is the only website I'm having a problem with on Firefox, other Yahoo sites including the main Yahoo homepage and Mail show up just fine. The My Yahoo homepage shows up normally on Chrome and Safari. I have noticed an odd thing about trying to access the My Yahoo page via the Yahoo page: The logon screen comes on, and I sign in. But when I see the My Yahoo page it doesn't show that I've logged on. If I click Mail it does go right to my Mail page.

The issue seems to be very specific to my personal My Yahoo page.

附加的畫面擷圖

被選擇的解決方法

Suddenly seems to be working again after I cleared Yahoo cookies a second time. ???

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

That redirect message usually arises from Firefox using old cached files or old Yahoo cookies, or a mix of old and new. I suggest clearing those as follows.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove your Yahoo cookies (save any pending work first). While viewing a page on the site (can be www.yahoo.com), try either:

  • right-click (or on Mac: Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar, click the ">" button, then More Information > "View Cookies"

In the dialog that opens, yahoo.com should be prefilled at the top so you can remove the site's cookies individually.

Then try reloading My Yahoo. Does that help?

more options

Hmm, since you already tried those things, could you check your cookie permissions to see whether those have any non-default settings? This article has the details: Websites say cookies are blocked - Unblock them

more options

I should try it myself first, right? I see this problem, too. Opening Firefox's Network Monitor tool (part of the Developer Tools - https://developer.mozilla.org/docs/To.../Network_Monitor) I see that the server redirects from insecure to secure and back again in a loop. It doesn't matter whether I'm logged in or not. (Screen shots attached.)

It seems like a server problem, but there are cases in which Firefox "forces" HTTPS on a site because the site previously set a rule to always use HTTPS. Those directions are little difficult to remove, and probably would be re-set when you log in again. Hmm...

more options

選擇的解決方法

Suddenly seems to be working again after I cleared Yahoo cookies a second time. ???